summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortheguy2021-10-21 01:14:22 +0200
committertheguy2021-10-21 01:14:22 +0200
commitb802aa463d5f393903f5d5b94f4edd07794e382e (patch)
tree64edadf01a00f0186cf775eac67ab67fba3c0d8b
downloadaur-osintdb-git.tar.gz
initial release 0.1.0
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD41
-rw-r--r--osintdb.desktop5
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3de45a64ad49
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = osintdb-git
+ pkgdesc = An OSINT ressource collection manager
+ pkgver = 0.1.0.r0.g61e455c
+ pkgrel = 1
+ url = https://github.com/theosintguy/osintdb
+ arch = x86_64
+ license = MIT
+ makedepends = go>=1.14
+ makedepends = npm
+ depends = libobjectbox
+ source = osintdb-git::git+https://github.com/theosintguy/osintdb.git
+ source = osintdb.desktop
+ sha256sums = SKIP
+ sha256sums = cfee7e4dba6b574877a3f3ca5adad94a5895d60b7043231d27fd1530e6e34666
+
+pkgname = osintdb-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e478b937cfda
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: theguy147 <yakamoz147 (at) protonmail (dot) com>
+pkgname=osintdb-git
+pkgver=0.1.0.r0.g61e455c
+pkgrel=1
+pkgdesc='An OSINT ressource collection manager'
+arch=('x86_64')
+url="https://github.com/theosintguy/osintdb"
+license=('MIT')
+makedepends=('go>=1.14' 'npm')
+depends=('libobjectbox')
+source=("${pkgname}::git+${url}.git" "osintdb.desktop")
+sha256sums=('SKIP' 'cfee7e4dba6b574877a3f3ca5adad94a5895d60b7043231d27fd1530e6e34666')
+
+prepare() {
+ # currently, there is no wails package in AUR so this hack is used until the package is published
+ wails version &>/dev/null || (echo -e \
+ "\n==============================================================="\
+ "\n[ERROR] make sure Wails is installed and can be found in \$PATH"\
+ "\n===============================================================\n" && false)
+}
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$pkgname"
+ wails build
+}
+
+package() {
+ install -Dm644 osintdb.desktop "${pkgdir}/usr/share/applications/osintdb.desktop"
+
+ cd "$pkgname"
+ install -Dm755 build/osintdb "${pkgdir}/opt/osintdb/osintdb"
+ install -Dm644 tools.min.json "${pkgdir}/opt/osintdb/tools.min.json"
+
+ mkdir -p "${pkgdir}/usr/bin"
+ ln -s /opt/osintdb/osintdb "${pkgdir}/usr/bin/osintdb"
+}
diff --git a/osintdb.desktop b/osintdb.desktop
new file mode 100644
index 000000000000..dbbae0bf8852
--- /dev/null
+++ b/osintdb.desktop
@@ -0,0 +1,5 @@
+[Desktop Entry]
+Name=OsintDB
+Exec=/usr/bin/osintdb
+Type=Application
+Categories=Osint