summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVadim Yanitskiy2024-01-28 05:49:56 +0700
committerVadim Yanitskiy2024-01-28 05:49:56 +0700
commitff53b54b92a00795ece8b3389d05adf25d17fb55 (patch)
tree4e21cf9035d67433c73b73794a8fa5ae3249e7fa
parent70d3c95643112cd64aec0091016790830bd0e9df (diff)
downloadaur-osmo-mgw-git.tar.gz
update $pkgver, $pkgdesc, $source; fix $provides
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD15
2 files changed, 13 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 40bfb1961a3f..f2c22b5fe8f3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = osmo-mgw-git
- pkgdesc = Media Gateway for handling user plane (voice) traffic in cellular networks
- pkgver = 1.5.0.r2.ge36b775e
+ pkgdesc = Osmocom's Media Gateway for 2G and 3G circuit-switched mobile networks
+ pkgver = 1.12.1.r28.g8ee08c6b7
pkgrel = 1
url = https://osmocom.org/projects/osmo-mgw/
arch = i686
@@ -13,11 +13,10 @@ pkgbase = osmo-mgw-git
depends = libosmo-abis
depends = libosmo-netif
depends = talloc
- provides = osmo-mgw
+ provides = libosmo-mgcp-client.so=12-64
conflicts = osmo-mgw
backup = etc/osmocom/osmo-mgw.cfg
- source = git+https://git.osmocom.org/osmo-mgw
+ source = git+https://gitea.osmocom.org/cellular-infrastructure/osmo-mgw.git
sha256sums = SKIP
pkgname = osmo-mgw-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 1e82e4a29afa..43172ff34d2e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,19 @@
-# Maintainer: Josef Miegl <josef@miegl.cz>
+# Maintainer: Vadim Yanitskiy <fixeria@osmocom.org>
+# Contributor: Josef Miegl <josef@miegl.cz>
pkgname=osmo-mgw-git
-pkgver=1.5.0.r2.ge36b775e
+pkgver=1.12.1.r28.g8ee08c6b7
pkgrel=1
-pkgdesc="Media Gateway for handling user plane (voice) traffic in cellular networks"
+pkgdesc="Osmocom's Media Gateway for 2G and 3G circuit-switched mobile networks"
url="https://osmocom.org/projects/osmo-mgw/"
arch=('i686' 'x86_64' 'aarch64' 'armv7h')
license=(GPL)
depends=('libosmocore' 'libosmo-abis' 'libosmo-netif' 'talloc')
makedepends=('git')
-provides=("${pkgname%-git}")
+provides=('libosmo-mgcp-client.so=12-64')
conflicts=("${pkgname%-git}")
backup=('etc/osmocom/osmo-mgw.cfg')
-source=("git+https://git.osmocom.org/${pkgname%-git}")
+source=("git+https://gitea.osmocom.org/cellular-infrastructure/${pkgname%-git}.git")
sha256sums=('SKIP')
pkgver() {
@@ -27,7 +28,9 @@ prepare() {
build() {
cd "${pkgname%-git}"
- ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var
make
}