summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosef Miegl2019-02-13 20:28:07 +0100
committerJosef Miegl2019-02-13 20:28:07 +0100
commit06a0e6642c195cbb858edb4f6cd949f9b250fd68 (patch)
treeeedfbf03f6d818fb43a6d2e5f100d7cde7b28d5d
parent3cf02c0f72265682eff08848346ace07eeaecdc7 (diff)
downloadaur-06a0e6642c195cbb858edb4f6cd949f9b250fd68.tar.gz
update
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD23
2 files changed, 17 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f488deb75e8c..9c34755647e0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = osmo-msc-git
pkgdesc = Osmocom implementation of a Mobile Switching Center (MSC)
- pkgver = 1.3.1.11.g84528507
+ pkgver = 1.3.1.r14.g3acfe68b
pkgrel = 1
url = https://osmocom.org/projects/osmomsc
arch = i686
@@ -9,13 +9,14 @@ pkgbase = osmo-msc-git
arch = armv7h
license = GPL
makedepends = git
- makedepends = talloc
depends = libosmocore
+ depends = talloc
depends = libosmo-abis
depends = libosmo-netif
depends = libosmo-sccp
depends = osmo-mgw
depends = osmo-iuh
+ depends = osmo-hlr
depends = libsmpp34
depends = libasn1c
depends = libdbi
diff --git a/PKGBUILD b/PKGBUILD
index 0702a3759464..04c685569279 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,15 @@
# Maintainer: Josef Miegl <josef@miegl.cz>
pkgname=osmo-msc-git
-pkgver=1.3.1.11.g84528507
+pkgver=1.3.1.r14.g3acfe68b
pkgrel=1
pkgdesc="Osmocom implementation of a Mobile Switching Center (MSC)"
url="https://osmocom.org/projects/osmomsc"
arch=('i686' 'x86_64' 'aarch64' 'armv7h')
license=(GPL)
-depends=('libosmocore' 'libosmo-abis' 'libosmo-netif' 'libosmo-sccp' 'osmo-mgw' 'osmo-iuh' 'libsmpp34' 'libasn1c' 'libdbi' 'libdbi-drivers' 'openssl')
-makedepends=('git' 'talloc')
+depends=('libosmocore' 'talloc' 'libosmo-abis' 'libosmo-netif' 'libosmo-sccp' 'osmo-mgw' 'osmo-iuh' 'osmo-hlr'
+ 'libsmpp34' 'libasn1c' 'libdbi' 'libdbi-drivers' 'openssl')
+makedepends=('git')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
backup=('etc/osmocom/osmo-msc.cfg')
@@ -16,19 +17,23 @@ source=("git+https://git.osmocom.org/${pkgname%-git}")
sha256sums=('SKIP')
pkgver() {
- cd "${srcdir}/${pkgname%-git}"
- echo $(git describe --always | sed 's/-/./g')
+ cd "${pkgname%-git}"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "${pkgname%-git}"
+ autoreconf -f -i
}
build() {
- cd "${srcdir}/${pkgname%-git}"
- autoreconf -i
- ./configure --prefix=/usr --sysconfdir=/etc --enable-iu --enable-smpp
+ cd "${pkgname%-git}"
+ ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --enable-iu --enable-smpp
make
}
package() {
- cd "${srcdir}/${pkgname%-git}"
+ cd "${pkgname%-git}"
make DESTDIR=${pkgdir} install
}