summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Husička2020-11-12 19:44:47 +0100
committerDavid Husička2020-11-12 19:44:47 +0100
commit1b231e5efbbf9f76a9def2147ee3e451f5877dba (patch)
tree6165ef8581b9a2a8b11b6066273e7dc6ee40e374
downloadaur-1b231e5efbbf9f76a9def2147ee3e451f5877dba.tar.gz
Initial commit for version 2020.1109.0
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD45
-rw-r--r--osu-lazer.desktop6
3 files changed, 78 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..018565f4f4ed
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = osu-lazer-bin
+ pkgdesc = The future of osu! and the beginning of an open era! Commonly known by the codename osu!lazer. Pew pew.
+ pkgver = 2020.1109.0
+ pkgrel = 1
+ url = https://osu.ppy.sh
+ arch = x86_64
+ license = MIT
+ license = custom:CC-BY-NC 4.0
+ depends = ffmpeg
+ depends = zlib
+ provides = osu
+ provides = osu-lazer
+ conflicts = osu
+ conflicts = osu-lazer
+ noextract = osu-lazer-bin-2020.1109.0.AppImage
+ options = !strip
+ source = osu-lazer-bin-2020.1109.0.AppImage::https://github.com/ppy/osu/releases/download/2020.1109.0/osu.AppImage
+ source = osu-lazer-bin.png::https://raw.githubusercontent.com/ppy/osu/master/assets/lazer.png
+ source = osu-lazer-bin-LICENCE.md::https://raw.githubusercontent.com/ppy/osu-resources/master/LICENCE.md
+ source = osu-lazer.desktop
+ sha256sums = 637c31495cb157c54fa8ceebc4d709846aafe3c757515dd9d46475942e44fbe9
+ sha256sums = 36f73cfe0a84cd65a8bb54fcde5a01c419b134bee4a88cc92eb4f33236343a10
+ sha256sums = 30b914824784b6ba6b30a44b22bea4f3c6fbc10f3f0e74fde5ca76a92ef57244
+ sha256sums = f37168074db22cf8e898f08b3f67458e1708a8c4ae179fb14a916e74e12bec4e
+
+pkgname = osu-lazer-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..45372367276c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+## Maintainer: David Husička <contact@bydave.net>
+
+pkgname=osu-lazer-bin
+pkgver=2020.1109.0
+pkgrel=1
+pkgdesc="The future of osu! and the beginning of an open era! Commonly known by the codename osu!lazer. Pew pew."
+arch=('x86_64')
+url="https://osu.ppy.sh"
+license=('MIT' 'custom:CC-BY-NC 4.0')
+groups=()
+depends=(ffmpeg zlib)
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=(osu osu-lazer)
+conflicts=(osu osu-lazer)
+replaces=()
+backup=()
+options=(!strip)
+install=
+changelog=
+source=("$pkgname-$pkgver.AppImage::https://github.com/ppy/osu/releases/download/$pkgver/osu.AppImage"
+ "$pkgname.png::https://raw.githubusercontent.com/ppy/osu/master/assets/lazer.png"
+ "$pkgname-LICENCE.md::https://raw.githubusercontent.com/ppy/osu-resources/master/LICENCE.md"
+ "osu-lazer.desktop")
+noextract=("$pkgname-$pkgver.AppImage")
+sha256sums=("637c31495cb157c54fa8ceebc4d709846aafe3c757515dd9d46475942e44fbe9"
+ "36f73cfe0a84cd65a8bb54fcde5a01c419b134bee4a88cc92eb4f33236343a10"
+ "30b914824784b6ba6b30a44b22bea4f3c6fbc10f3f0e74fde5ca76a92ef57244"
+ "f37168074db22cf8e898f08b3f67458e1708a8c4ae179fb14a916e74e12bec4e")
+
+package() {
+ # Install image
+ install -Dm644 "${srcdir}"/"${pkgname}".png "${pkgdir}"/usr/share/pixmaps/osu-lazer.png
+
+ # Install license
+ install -Dm644 "${srcdir}"/"${pkgname}"-LICENCE.md "${pkgdir}"/usr/share/licenses/"${pkgname}"/LICENCE.md
+
+ # Install desktop file
+ install -Dm644 osu-lazer.desktop "${pkgdir}"/usr/share/applications/osu-lazer.desktop
+
+ # Install binary
+ install -Dm755 "${srcdir}"/"${pkgname}"-"${pkgver}".AppImage "${pkgdir}"/usr/bin/osu
+
+}
diff --git a/osu-lazer.desktop b/osu-lazer.desktop
new file mode 100644
index 000000000000..ed4ada4e35ea
--- /dev/null
+++ b/osu-lazer.desktop
@@ -0,0 +1,6 @@
+[Desktop Entry]
+Type=Application
+Name=osu!lazer
+Icon=/usr/share/pixmaps/osu-lazer.png
+Comment=Open source free-to-win rhythm game
+Exec=/usr/bin/osu