summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTuhana GAYRETLÄ°2022-04-20 18:32:26 +0300
committerTuhana GAYRETLÄ°2022-04-20 18:32:26 +0300
commit9472b75914ca66d29274e4eb61e9457eb6da132d (patch)
treee42f5d3e310111bddd4c6723e85f51229d1af0e6
parent2a5243f3943ba3f680d12de57d63432b4a9d3371 (diff)
downloadaur-9472b75914ca66d29274e4eb61e9457eb6da132d.tar.gz
move executable to `/opt/osu-lazer` folder, bump pkgrel
first change is because if game runned from terminal, it runs without environment variables set in .desktop file, and continues to crash
-rw-r--r--PKGBUILD13
-rw-r--r--osu-lazer2
2 files changed, 10 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 002795293a7b..d573285fa84c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=osu-lazer-bin
_pkgname=${pkgname%-bin}
pkgver=2022.418.0
-pkgrel=1
+pkgrel=3
pkgdesc="The future of osu! and the beginning of an open era! Commonly known by the codename osu!lazer. Pew pew."
arch=("x86_64")
url="https://osu.ppy.sh"
@@ -25,6 +25,7 @@ source=(
"https://raw.githubusercontent.com/ppy/osu/master/assets/lazer.png"
"https://raw.githubusercontent.com/ppy/osu-resources/master/LICENCE.md"
"osu-lazer.desktop"
+ "osu-lazer"
)
noextract=("osu.AppImage")
sha256sums=(
@@ -32,16 +33,18 @@ sha256sums=(
"36f73cfe0a84cd65a8bb54fcde5a01c419b134bee4a88cc92eb4f33236343a10"
"30b914824784b6ba6b30a44b22bea4f3c6fbc10f3f0e74fde5ca76a92ef57244"
"77ace2dca8f81966222eb7cceea4990cc04043b9b4b54991ff8148fc47123c76"
+ "a9a2ea43849e9cb94d40f8668406078b619e96d3b66fc5bce112d9b0e4d6c8a0"
)
package() {
cd "$srcdir"
- # Install pixmap and binary
- install -Dm644 lazer.png "$pkgdir/usr/share/pixmaps/osu-lazer.png"
- install -Dm755 osu.AppImage "$pkgdir/usr/bin/osu-lazer"
+ # Install binary and launch script
+ install -Dm755 -t "$pkgdir/opt/osu-lazer" osu.AppImage
+ install -Dm755 -t "$pkgdir/usr/bin" osu-lazer
- # Install desktop and license file
+ # Install pixmap, desktop and license file
+ install -Dm644 lazer.png "$pkgdir/usr/share/pixmaps/osu-lazer.png"
install -Dm644 -t "$pkgdir/usr/share/applications" osu-lazer.desktop
install -Dm644 -t "$pkgdir/usr/share/licenses/$_pkgname" LICENCE.md
}
diff --git a/osu-lazer b/osu-lazer
new file mode 100644
index 000000000000..5412470f335b
--- /dev/null
+++ b/osu-lazer
@@ -0,0 +1,2 @@
+#!/usr/bin/env sh
+env OSU_EXTERNAL_UPDATE_PROVIDER=1 LD_LIBRARY_PATH=/usr/lib/ffmpeg4.4:"$LD_LIBRARY_PATH" /opt/osu-lazer/osu.AppImage "$@"