summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSwyter2023-04-25 07:49:25 +0200
committerSwyter2023-04-25 07:49:25 +0200
commit9a66cb3e240cd7dc0550ec1725c5a745c233944f (patch)
tree61ca191f4afeccca46ecfdd26dabaee615ffa1c7
parenta2f7b8092d1c8a324d54dd81f6916704fb9f4a4f (diff)
downloadaur-osxcross-git.tar.gz
Explain the alternate source of SDKs, which looks a bit fishy to me. So warn a bit. Add the xar command to /usr/bin as a symlink, as the xar package is in direct conflict and caused me issues when downgrading the whole Arch install with the ABS.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD14
2 files changed, 12 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 713c17cbeb2f..6c1bd39c9612 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = osxcross-git
pkgdesc = macOS cross-compiling toolchain for Linux, FreeBSD and NetBSD
- pkgver = 0.15
+ pkgver = 0.16
pkgrel = 1
url = https://github.com/tpoechtrager/osxcross
install = osxcross-git.install
diff --git a/PKGBUILD b/PKGBUILD
index 0f24162eb56e..d09fde903cd4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=osxcross-git
_pkgname=${pkgname%-git}
_sdkname=MacOSX10.11.sdk # swy: choose your SDK version here
-pkgver=0.15
+pkgver=0.16
pkgrel=1
pkgdesc="macOS cross-compiling toolchain for Linux, FreeBSD and NetBSD"
arch=('x86_64')
@@ -21,6 +21,11 @@ conflicts=("$_pkgname" xar apple-darwin-osxcross)
source=(
'git+https://github.com/tpoechtrager/osxcross.git'
"https://s3.dockerproject.org/darwin/v2/${_sdkname}.tar.xz"
+
+ # swy: this repository by an anonymous individual seems to have pre-bundled versions of the other SDKs,
+ # in case you want to change $_sdkname and use a newer version, comment the URL above and uncomment this one
+ # or pack your own if you don't trust the unofficial source, which I can understand.
+ #"https://github.com/phracker/MacOSX-SDKs/releases/latest/download/${_sdkname}.tar.xz"
)
md5sums=('SKIP' 'b0d81b95746c7e698c39c7df1e15ca7d')
noextract=("${_sdkname}.tar.xz")
@@ -52,8 +57,11 @@ package() {
# swy: copy them over, as we can't seemingly use $pkgdir in build()
mv "$srcdir/usr/" "$pkgdir/usr/"
+ # swy: as this package conflicts with «xar», make that un/packing tool widely available with a symlink
+ mkdir -p "$pkgdir/usr/bin"; ln -s "$pkgdir/usr/local/osx-ndk-x86/bin/xar" "$pkgdir/usr/bin/xar"
+
# swy: make sure the cross-compiled binaries can locate the .so dependencies stored aside in every
# case without having to set funky environment variables or patching every .elf's RUNPATH
- mkdir -p $pkgdir/etc/ld.so.conf.d/
- echo '/usr/local/osx-ndk-x86/lib' > $pkgdir/etc/ld.so.conf.d/osxcross.conf
+ mkdir -p "$pkgdir/etc/ld.so.conf.d/"
+ echo '/usr/local/osx-ndk-x86/lib' > "$pkgdir/etc/ld.so.conf.d/osxcross.conf"
} \ No newline at end of file