summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEmile Pesik2015-07-08 14:13:35 +0100
committerEmile Pesik2015-07-08 14:13:35 +0100
commit7a551a4e782db83e5b3acb9268a31228b3ab549d (patch)
tree1a97c2a30dc73d487c170a61edf8768b191f8d18
downloadaur-otf-mathilde.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD23
-rw-r--r--otf.install15
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..359f38109204
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = otf-mathilde
+ pkgdesc = Mathilde is a beautiful, free, handwritten cursive-hybrid OpenType font with contextual alternatives
+ pkgver = 1.0
+ pkgrel = 1
+ url = http://leeviathan.com/portfolio-item/mathilde-free-handwritten-opentype-font/
+ install = otf.install
+ arch = any
+ license = CCPL:by-sa
+ depends = fontconfig
+ depends = xorg-mkfontdir
+ depends = xorg-mkfontscale
+ source = otf-mathilde.zip::http://img.dafont.com/dl/?f=mathilde
+ md5sums = 3b293339eb59a418ee43a01bb69306ca
+
+pkgname = otf-mathilde
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e84e8ecfda97
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Aerion <emile [at] aerion [dot] co [uk]>
+
+pkgname=otf-mathilde
+pkgver=1.0
+pkgrel=1
+pkgdesc="Mathilde is a beautiful, free, handwritten cursive-hybrid OpenType font with contextual alternatives"
+arch=('any')
+url="http://leeviathan.com/portfolio-item/mathilde-free-handwritten-opentype-font/"
+license=('CCPL:by-sa')
+depends=('fontconfig' 'xorg-mkfontdir' 'xorg-mkfontscale')
+install=otf.install
+source=($pkgname.zip::http://img.dafont.com/dl/?f=mathilde)
+md5sums=('3b293339eb59a418ee43a01bb69306ca')
+
+build() {
+ # nothing to do
+ true
+}
+
+package() {
+ install -d ${pkgdir}/usr/share/fonts/OTF/
+ install -Dm644 ${srcdir}/mathilde.otf ${pkgdir}/usr/share/fonts/OTF/mathilde.otf
+}
diff --git a/otf.install b/otf.install
new file mode 100644
index 000000000000..1fdb52abb721
--- /dev/null
+++ b/otf.install
@@ -0,0 +1,15 @@
+post_install() {
+ echo "Updating font cache... "
+ fc-cache -f > /dev/null
+ mkfontscale /usr/share/fonts/OTF
+ mkfontdir /usr/share/fonts/OTF
+ echo " ...done."
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}