summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcaltlgin2020-12-10 07:29:31 +1300
committercaltlgin2020-12-10 07:29:31 +1300
commita099e5c3a89ca593ec25db4931d4ccddc033bf11 (patch)
treee0795d39bf6986e84d5abab847e75cf03cbaa44f
parent5c49ee14d445b9a47cc8f17135de60c31e40caa8 (diff)
downloadaur-otf-ryman-eco.tar.gz
Refactored PKGBUILD
-rw-r--r--.SRCINFO2
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD17
3 files changed, 15 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1928c4d54fcf..d76f37ad2bdd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,7 +5,7 @@ pkgbase = otf-ryman-eco
url = https://rymaneco.co.uk
arch = any
license = custom
- source = ryman-eco-1.0.zip::https://rymaneco.co.uk/download/ryman-eco.zip
+ source = ryman-eco-1.0-2.zip::https://rymaneco.co.uk/download/ryman-eco.zip
sha256sums = be47185a8ae794ce56a837aae7d7687d46b0c6fd009fde8d299829e7950caa86
pkgname = otf-ryman-eco
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
index 177f13537214..a6e9273f670a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,10 @@
# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
# Contributor: xpt <user.xpt@gmail.com>
-_pkgname=ryman-eco
+# otfinfo --info *.otf
+
+_name='Ryman Eco'
+_pkgname='ryman-eco'
pkgname="otf-${_pkgname}"
pkgver=1.0
pkgrel=2
@@ -9,14 +12,14 @@ pkgdesc='Environmentally sustainable typeface'
arch=('any')
url='https://rymaneco.co.uk'
license=('custom')
-source=("${_pkgname}-${pkgver}.zip::${url}/download/${_pkgname}.zip")
+source=("${_pkgname}-${pkgver}-${pkgrel}.zip::${url}/download/${_pkgname}.zip")
sha256sums=('be47185a8ae794ce56a837aae7d7687d46b0c6fd009fde8d299829e7950caa86')
package() {
- cd "Ryman Eco"
- install -Dm644 -t "${pkgdir}/usr/share/fonts/OTF" "Ryman Eco/RymanEco-Regular.otf"
- install -Dm644 'Ryman EcoPoster.pdf' "${pkgdir}/usr/share/doc/${_pkgname}/poster.pdf"
- install -Dm644 'Ryman Eco End User License Agreement.pdf' "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE.pdf"
+ cd "${_name}"
+ install -Dvm644 "${_name}/${_name/ /}-Regular.otf" -t "${pkgdir}/usr/share/fonts/OTF"
+ install -Dvm644 "${_name}Poster.pdf" "${pkgdir}/usr/share/doc/${_pkgname}/poster.pdf"
+ install -Dvm644 "${_name} End User License Agreement.pdf" "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE.pdf"
}
-# vim:set ts=2 sw=2 et:
+# vim ts=2 sw=2 et: