summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2020-07-14 16:06:44 +0200
committerChristopher Arndt2020-12-10 13:22:33 +0100
commit7f8bdf285e8a2f48199e43bcc1bfefb27291417d (patch)
tree93f4e62a0d28ff8698e34fa2b0bccc0280a67bcd
parentd8bb917764d278debc7ce7185713c1762ad00809 (diff)
downloadaur-otf-xkcd-font.tar.gz
Various package updates & improvements
* Removed obsolete .install files and dependencies * Don't install license file, it's already in the 'licenses' package * Fixed license field * Changed source URL to archive for fixed commit hash * Added .gitignore file * Changed source hash from MD5 to SHA256 Signed-off-by: Christopher Arndt <chris@chrisarndt.de>
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD33
-rw-r--r--otf.install15
-rw-r--r--ttf.install15
5 files changed, 26 insertions, 58 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f4a875fa84ba..4cb52faa7d90 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,14 @@
-# Generated by mksrcinfo v8
-# Fri Aug 25 18:29:23 UTC 2017
pkgbase = otf-xkcd-font
pkgdesc = The xkcd font.
pkgver = r39.5632fde
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/ipython/xkcd-font
arch = any
- license = CCPL:cc-by-nc
- depends = fontconfig
- depends = xorg-font-utils
- source = xkcd-font::git+https://github.com/ipython/xkcd-font.git
- md5sums = SKIP
+ license = CCPL:cc-by-nc-3.0
+ source = xkcd-font-r39.5632fde.zip::https://github.com/ipython/xkcd-font/archive/5632fde618845dba5c22f14adc7b52bf6c52d46d.zip
+ sha256sums = 8d58ee790c9aa35ea7937443cb304ce9f8b663b9628a91c13a5a4b163772b904
pkgname = otf-xkcd-font
- install = otf.install
pkgname = ttf-xkcd-script-font
- install = ttf.install
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..d293afc81570
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+otf-xkcd-font-*.pkg.tar.xz
+otf-xkcd-font-*.pkg.tar.zst
+pkg/
+src/
+ttf-xkcd-script-font-*.pkg.tar.xz
+ttf-xkcd-script-font-*.pkg.tar.zst
+xkcd-font-*.zip
diff --git a/PKGBUILD b/PKGBUILD
index d67e752df6e0..9068993378b5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,25 @@
# Maintainer: Stephen Brown II <Stephen [dot] Brown2 [at] gmail.com>
+# Contributor: Christopher Arndt <aur -at- chrisarndt -dot- de>
+
+_commit=39
+_hash="5632fde618845dba5c22f14adc7b52bf6c52d46d"
_pkgbase=xkcd-font
pkgname=('otf-xkcd-font' 'ttf-xkcd-script-font')
-pkgver=r39.5632fde
-pkgrel=1
+pkgver="r${_commit}.${_hash::7}"
+pkgrel=2
pkgdesc="The xkcd font."
arch=(any)
url="https://github.com/ipython/xkcd-font"
-license=('CCPL:cc-by-nc')
-depends=('fontconfig' 'xorg-font-utils')
-source=($_pkgbase::git+https://github.com/ipython/xkcd-font.git)
-md5sums=(SKIP)
-pkgver() {
- cd "$_pkgbase"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
-}
+license=('CCPL:cc-by-nc-3.0')
+source=("$_pkgbase-$pkgver.zip::https://github.com/ipython/xkcd-font/archive/${_hash}.zip")
+sha256sums=('8d58ee790c9aa35ea7937443cb304ce9f8b663b9628a91c13a5a4b163772b904')
+
package_otf-xkcd-font() {
- install=otf.install
- cd "$srcdir"
- install -Dm644 "${_pkgbase}/xkcd/build/xkcd.otf" "$pkgdir/usr/share/fonts/OTF/xkcd.otf"
- install -Dm644 "${_pkgbase}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ cd "${srcdir}/${_pkgbase}-${_hash}"
+ install -Dm644 xkcd/build/xkcd.otf -t "$pkgdir/usr/share/fonts/OTF"
}
+
package_ttf-xkcd-script-font() {
- install=ttf.install
- cd "$srcdir"
- install -Dm644 "${_pkgbase}/xkcd-script/font/xkcd-script.ttf" "$pkgdir/usr/share/fonts/TTF/xkcd-script.ttf"
- install -Dm644 "${_pkgbase}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ cd "${srcdir}/${_pkgbase}-${_hash}"
+ install -Dm644 xkcd-script/font/xkcd-script.ttf -t "$pkgdir/usr/share/fonts/TTF"
}
diff --git a/otf.install b/otf.install
deleted file mode 100644
index a0836403899f..000000000000
--- a/otf.install
+++ /dev/null
@@ -1,15 +0,0 @@
-post_install() {
- echo -n "==> Rebuilding font cache... "
- fc-cache -f &> /dev/null
- mkfontscale /usr/share/fonts/OTF
- mkfontdir /usr/share/fonts/OTF
- echo "done"
-}
-
-post_upgrade() {
- post_install $1
-}
-
-post_remove() {
- post_install $1
-} \ No newline at end of file
diff --git a/ttf.install b/ttf.install
deleted file mode 100644
index 33b7d65490db..000000000000
--- a/ttf.install
+++ /dev/null
@@ -1,15 +0,0 @@
-post_install() {
- echo -n "==> Rebuilding font cache... "
- fc-cache -f &> /dev/null
- mkfontscale /usr/share/fonts/TTF
- mkfontdir /usr/share/fonts/TTF
- echo "done"
-}
-
-post_upgrade() {
- post_install $1
-}
-
-post_remove() {
- post_install $1
-}