summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMassimiliano Torromeo2018-11-19 08:48:04 +0100
committerMassimiliano Torromeo2018-11-19 08:48:04 +0100
commit52f83869b7bb508eb2a48951303d9904682e932e (patch)
tree5ba5669a0611a0677011ac6139bed2763afc2357
parentf95a6bc091aa9d9ebaaed0697d4f3ebbdba9b2e4 (diff)
downloadaur-otf2bdf.tar.gz
Fixed build and source url
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD20
2 files changed, 17 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b680885fc7eb..20fcb7d16679 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,14 @@
-# Generated by mksrcinfo v8
-# Mon May 15 07:31:49 UTC 2017
pkgbase = otf2bdf
pkgdesc = A command-line OpenType to BDF font converter
pkgver = 3.1
- pkgrel = 2
- url = http://sofia.nmsu.edu/~mleisher/Software/otf2bdf/
+ pkgrel = 3
+ url = https://github.com/jirutka/otf2bdf/
arch = i686
arch = x86_64
license = custom
depends = freetype2
- source = https://github.com/mtorromeo/otf2bdf/archive/3.1/otf2bdf-3.1.tar.gz
- sha256sums = 5842a6c604a8aa747f9f49838e3a91ce587c8568681300bc70418aeebd7ecc43
+ source = https://github.com/jirutka/otf2bdf/archive/cc7f1b5a1220b3a3ffe356e056e6627c64bdf122/otf2bdf-3.1.tar.gz
+ sha256sums = 6f33ae2734ae48258201ce967a0b23cd88e901348591ee978e8250986781bcb4
pkgname = otf2bdf
diff --git a/PKGBUILD b/PKGBUILD
index b286fc762ed3..c21fefed176a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,31 @@
# Maintainer: Anton Bazhenov <anton.bazhenov at gmail>
# Contributor: cs-cam <me.at.camdaniel.com>
+_commit=cc7f1b5a1220b3a3ffe356e056e6627c64bdf122
pkgname=otf2bdf
pkgver=3.1
-pkgrel=2
+pkgrel=3
pkgdesc="A command-line OpenType to BDF font converter"
arch=('i686' 'x86_64')
-url="http://sofia.nmsu.edu/~mleisher/Software/otf2bdf/"
+url="https://github.com/jirutka/otf2bdf/"
license=('custom')
depends=('freetype2')
-source=("https://github.com/mtorromeo/otf2bdf/archive/$pkgver/$pkgname-$pkgver.tar.gz")
-sha256sums=('5842a6c604a8aa747f9f49838e3a91ce587c8568681300bc70418aeebd7ecc43')
+source=("https://github.com/jirutka/otf2bdf/archive/$_commit/$pkgname-$pkgver.tar.gz")
+sha256sums=('6f33ae2734ae48258201ce967a0b23cd88e901348591ee978e8250986781bcb4')
+
+prepare() {
+ cd "${srcdir}/${pkgname}-${_commit}"
+ sed -r 's/freetype-config (--[a-z]+)/pkg-config \1 freetype2/' -i configure
+}
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- ./configure
+ cd "${srcdir}/${pkgname}-${_commit}"
+ ./configure --prefix=/usr
make
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd "${srcdir}/${pkgname}-${_commit}"
install -Dm755 ${pkgname} "${pkgdir}/usr/bin/${pkgname}"
# Install man page and license