summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-12-04 19:09:30 +0800
committerzxp198210052023-12-04 19:09:30 +0800
commita9b815a2f840916999d975b42cfe46a97ebda1be (patch)
treefc84ac1c1d1b7896dd6f0efccdbddca9a060d320
parentced3a9ea62e6bae0e1ee7498074484dc385e87e5 (diff)
downloadaur-ouch-bin.tar.gz
update to 0.5.0
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD14
2 files changed, 18 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 21dd26e9fd6a..af55fcfb689c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,20 @@
pkgbase = ouch-bin
pkgdesc = Painless compression and decompression in the terminal (binary release)
- pkgver = 0.4.2
- pkgrel = 3
+ pkgver = 0.5.0
+ pkgrel = 1
url = https://github.com/ouch-org/ouch
arch = aarch64
arch = armv7h
arch = x86_64
license = MIT
- provides = ouch=0.4.2
+ depends = xz
+ provides = ouch=0.5.0
conflicts = ouch
- source_aarch64 = ouch-0.4.2-aarch64.tar.gz::https://github.com/ouch-org/ouch/releases/download/0.4.2/ouch-aarch64-unknown-linux-gnu.tar.gz
- sha256sums_aarch64 = 6308ae6fb288a445bcbc674b8691ad1adc00389a9e383513ff286487efccd85b
- source_armv7h = ouch-0.4.2-armv7h.tar.gz::https://github.com/ouch-org/ouch/releases/download/0.4.2/ouch-armv7-unknown-linux-gnueabihf.tar.gz
- sha256sums_armv7h = c925dd3f64f96c882055a57d9c24e6b906e7ab81cb8ac7073a06c31571ef023f
- source_x86_64 = ouch-0.4.2-x86_64.tar.gz::https://github.com/ouch-org/ouch/releases/download/0.4.2/ouch-x86_64-unknown-linux-gnu.tar.gz
- sha256sums_x86_64 = 81c71d3cdf61a2ca21e0e973c532e91ffd142a806af60455e08883d1a0decd24
+ source_aarch64 = ouch-0.5.0-aarch64.tar.gz::https://github.com/ouch-org/ouch/releases/download/0.5.0/ouch-aarch64-unknown-linux-gnu.tar.gz
+ sha256sums_aarch64 = 61aa7356180a41efc90f47418181c446c2614c768c12b7fe14663c54dd122903
+ source_armv7h = ouch-0.5.0-armv7h.tar.gz::https://github.com/ouch-org/ouch/releases/download/0.5.0/ouch-armv7-unknown-linux-gnueabihf.tar.gz
+ sha256sums_armv7h = 538d60fa673c39ee5291f1a66544316076d0ce124bf122266e06897eeffc7f2e
+ source_x86_64 = ouch-0.5.0-x86_64.tar.gz::https://github.com/ouch-org/ouch/releases/download/0.5.0/ouch-x86_64-unknown-linux-gnu.tar.gz
+ sha256sums_x86_64 = 504242533518e07d0301c7fdbc8b69aa6e5ddb0261f1f3f0213d8a944cfe554f
pkgname = ouch-bin
diff --git a/PKGBUILD b/PKGBUILD
index b237324dccd7..3ff7fc1d9ae1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,23 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
# Contributor: Yigit Sever <yigit at yigitsever dot com>
pkgname=ouch-bin
-pkgver=0.4.2
-pkgrel=3
+pkgver=0.5.0
+pkgrel=1
pkgdesc="Painless compression and decompression in the terminal (binary release)"
arch=('aarch64' 'armv7h' 'x86_64')
url="https://github.com/ouch-org/ouch"
license=('MIT')
provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
-depends=()
+depends=(
+ 'xz'
+)
source_aarch64=("${pkgname%-bin}-${pkgver}-aarch64.tar.gz::${url}/releases/download/${pkgver}/${pkgname%-bin}-aarch64-unknown-linux-gnu.tar.gz")
source_armv7h=("${pkgname%-bin}-${pkgver}-armv7h.tar.gz::${url}/releases/download/${pkgver}/${pkgname%-bin}-armv7-unknown-linux-gnueabihf.tar.gz")
source_x86_64=("${pkgname%-bin}-${pkgver}-x86_64.tar.gz::${url}/releases/download/${pkgver}/${pkgname%-bin}-x86_64-unknown-linux-gnu.tar.gz")
-sha256sums_aarch64=('6308ae6fb288a445bcbc674b8691ad1adc00389a9e383513ff286487efccd85b')
-sha256sums_armv7h=('c925dd3f64f96c882055a57d9c24e6b906e7ab81cb8ac7073a06c31571ef023f')
-sha256sums_x86_64=('81c71d3cdf61a2ca21e0e973c532e91ffd142a806af60455e08883d1a0decd24')
+sha256sums_aarch64=('61aa7356180a41efc90f47418181c446c2614c768c12b7fe14663c54dd122903')
+sha256sums_armv7h=('538d60fa673c39ee5291f1a66544316076d0ce124bf122266e06897eeffc7f2e')
+sha256sums_x86_64=('504242533518e07d0301c7fdbc8b69aa6e5ddb0261f1f3f0213d8a944cfe554f')
build() {
mv "${srcdir}/${pkgname%-bin}-${CARCH}"* "${srcdir}/${pkgname%-bin}"
}