summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorraininja2023-10-30 03:15:52 -0400
committerraininja2023-10-30 03:15:52 -0400
commit16a921824f0a8b8d596cf44953eef778ef4be766 (patch)
tree02aa0cda2336c8bd73c09792c0c32d36df1a6448
downloadaur-owm.tar.gz
first commit
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD34
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..00de5ecd4b3a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = owm
+ pkgdesc = An experimental River layout generator using mathematical optimization to invent layouts on-the-fly.
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/justinlovinger/owm
+ arch = any
+ license = MIT
+ makedepends = cargo
+ source = owm::git+https://github.com/justinlovinger/owm.git
+ md5sums = SKIP
+
+pkgname = owm
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9ae568fac496
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: denkijin < dandenkijin at gmail dot com >
+pkgname=owm
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="An experimental River layout generator using mathematical optimization to invent layouts on-the-fly."
+arch=('any')
+url="https://github.com/justinlovinger/owm"
+license=('MIT')
+makedepends=('cargo')
+source=("${pkgname}::git+https://github.com/justinlovinger/${pkgname}.git")
+md5sums=('SKIP')
+#pkgver() {
+# cd "${pkgname}"
+# git describe --tags --long | sed 's/\([^-]*-g\)/r\1/; s/-/./g; s/^v//g'
+#}
+prepare() {
+ cd "${pkgname}"
+ export RUSTUP_TOOLCHAIN=stable
+ cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
+}
+build() {
+ cd "${pkgname}"
+ export RUSTUP_TOOLCHAIN=stable
+ export CARGO_TARGET_DIR=target
+ cargo build --release
+}
+
+
+package() {
+ cd "${pkgname}"
+
+ install -Dm755 "${srcdir}/${pkgname}/target/release/owm" "${pkgdir}/usr/bin/owm"
+}
+