summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2020-12-21 21:19:08 +0000
committerAntonio Rojas2020-12-21 21:19:08 +0000
commit4250c2582e50c7e36bf29ee17fba93c90e4324c5 (patch)
tree6c70e5aa39a1886524413e44bf40147a05f47a45
downloadaur-oxygen-gtk2.tar.gz
Dropped from repos
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD31
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7fd9a2e89ed1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = oxygen-gtk2
+ pkgdesc = Port of the default KDE widget theme (Oxygen) to GTK2
+ pkgver = 1.4.6
+ pkgrel = 4
+ url = https://projects.kde.org/projects/playground/artwork/oxygen-gtk/
+ arch = x86_64
+ license = LGPL
+ makedepends = cmake
+ depends = gtk2
+ source = https://download.kde.org/stable/oxygen-gtk2/1.4.6/src/oxygen-gtk2-1.4.6.tar.bz2
+ sha256sums = a289434347cc96054c75d1e4e4408b84adc2e8c7862f0be4e2da8fafbf26bf26
+
+pkgname = oxygen-gtk2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5cdd5b707f21
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Antonio Rojas <arojas@archlinux.org>
+# Contributor: Andrea Scarpino <andrea@archlinux.org>
+# Contributor: birdflesh <antkoul at gmail dot com>
+
+pkgname=oxygen-gtk2
+pkgver=1.4.6
+pkgrel=4
+pkgdesc="Port of the default KDE widget theme (Oxygen) to GTK2"
+arch=(x86_64)
+url='https://projects.kde.org/projects/playground/artwork/oxygen-gtk/'
+license=(LGPL)
+depends=(gtk2)
+makedepends=(cmake)
+source=("https://download.kde.org/stable/$pkgname/$pkgver/src/$pkgname-$pkgver.tar.bz2")
+sha256sums=('a289434347cc96054c75d1e4e4408b84adc2e8c7862f0be4e2da8fafbf26bf26')
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+ cmake ../$pkgname-$pkgver \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="$pkgdir" install
+}