summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTyler Langlois2015-09-10 22:49:20 -0400
committerTyler Langlois2015-09-10 22:49:20 -0400
commitd6e475f5d1ea228a276050ed26744325c22b6be3 (patch)
tree4dbb081a40aecc952de1283c18c58a841fff058a
downloadaur-d6e475f5d1ea228a276050ed26744325c22b6be3.tar.gz
Create packetbeat-bin
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD35
-rw-r--r--packetbeat.service9
4 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0f201b78701f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = packetbeat-bin
+ pkgdesc = An open source network packet analyzer that ships data to Elasticsearch (precompiled)
+ pkgver = 1.0.0_beta3
+ pkgrel = 1
+ url = https://www.elastic.co/products/beats/packetbeat
+ arch = i686
+ arch = x86_64
+ license = APACHE
+ optdepends = elasticsearch: for running standalone installation
+ provides = packetbeat
+ conflicts = packetbeat
+ options = !strip
+ backup = etc/packetbeat/packetbeat.yml
+ source = packetbeat.service
+ sha256sums = 09420676932fd4292351c9b55e835c545013477d015b7ffe8d5009ed1984da64
+ source_i686 = https://download.elastic.co/beats/packetbeat/packetbeat-1.0.0-beta3-i686.tar.gz
+ sha256sums_i686 = 6505bd0e7a103398ca512ca4292667dd89f44237ba8b9095a6e2b8592b0e4906
+ source_x86_64 = https://download.elastic.co/beats/packetbeat/packetbeat-1.0.0-beta3-x86_64.tar.gz
+ sha256sums_x86_64 = 11ec87cd0164c6bf4061fc2a1b28cd3e0c8a9a02009882f71fb0cde8e3d525b2
+
+pkgname = packetbeat-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e9648f0f4308
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4670fcbbb10c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Tyler Langlois <ty at tjll dot net>
+
+pkgname=packetbeat-bin
+_pkgbase=${pkgname%%-bin}
+pkgver=1.0.0_beta3
+_pkgver=${pkgver/_/-}
+pkgrel=1
+pkgdesc='An open source network packet analyzer that ships data to Elasticsearch (precompiled)'
+arch=('i686' 'x86_64')
+url="https://www.elastic.co/products/beats/$_pkgbase"
+license=('APACHE')
+backup=("etc/$_pkgbase/$_pkgbase.yml")
+optdepends=('elasticsearch: for running standalone installation')
+options=('!strip')
+provides=('packetbeat')
+conflicts=('packetbeat')
+source=("$_pkgbase.service")
+sha256sums=('09420676932fd4292351c9b55e835c545013477d015b7ffe8d5009ed1984da64')
+
+source_i686=("https://download.elastic.co/beats/$_pkgbase/$_pkgbase-$_pkgver-i686.tar.gz")
+source_x86_64=("https://download.elastic.co/beats/$_pkgbase/$_pkgbase-$_pkgver-x86_64.tar.gz")
+sha256sums_i686=('6505bd0e7a103398ca512ca4292667dd89f44237ba8b9095a6e2b8592b0e4906')
+sha256sums_x86_64=('11ec87cd0164c6bf4061fc2a1b28cd3e0c8a9a02009882f71fb0cde8e3d525b2')
+
+package() {
+ cd "$srcdir/$_pkgbase-$_pkgver-$CARCH"
+
+ install -D -m755 $_pkgbase "$pkgdir/usr/bin/$_pkgbase"
+ install -D -m644 $_pkgbase.yml "$pkgdir/etc/$_pkgbase/$_pkgbase.yml"
+ install -D -m644 $_pkgbase.template.json \
+ "$pkgdir/etc/$_pkgbase/$_pkgbase.template.json"
+
+ install -D -m644 "$srcdir/$_pkgbase.service" \
+ "$pkgdir/usr/lib/systemd/system/$_pkgbase.service"
+}
diff --git a/packetbeat.service b/packetbeat.service
new file mode 100644
index 000000000000..55e3060ebaa8
--- /dev/null
+++ b/packetbeat.service
@@ -0,0 +1,9 @@
+[Unit]
+Description=Open Source Real-Time Packet Analyzer
+After=network.target
+
+[Service]
+ExecStart=/usr/bin/packetbeat -c /etc/packetbeat/packetbeat.yml
+
+[Install]
+WantedBy=multi-user.target