summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2021-11-27 06:46:35 +0300
committerCaleb Maclennan2021-11-27 06:46:35 +0300
commit0161effad3e6e4fbdfc10d8e22e5dacc419279d8 (patch)
treeb58a402f36d1b41a08c2b0d188134101c1b56ae5
parentf68f737508d66a2446bd252afdbd002aa329b3ce (diff)
downloadaur-pacman-cleanup-hook.tar.gz
upgpkg: pacman-cleanup-hook 1.1-1
upstream release
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD16
-rw-r--r--pacman-cache-cleanup.hook (renamed from cleanup.hook)4
3 files changed, 15 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index db260432054a..2ee3134408f4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,10 @@
pkgbase = pacman-cleanup-hook
- pkgdesc = hook to cleanup pacman cache keeping only the installed version plus most recent cache
- pkgver = 1.0
- pkgrel = 8
+ pkgdesc = hook to cleanup pacman cache keeping only the installed plus next most recent packages
+ pkgver = 1.1
+ pkgrel = 1
arch = any
depends = pacman-contrib
- source = cleanup.hook
- sha256sums = 235d6743e8d91bec5ab911a12e061be417f2d179edbc8423fe628fdbfec6876a
+ source = pacman-cache-cleanup.hook
+ sha256sums = 6b37d7694deeebe1c6a865ed635b96dd1c0b1b8eb486b5c87a92bb3009e43654
pkgname = pacman-cleanup-hook
-
diff --git a/PKGBUILD b/PKGBUILD
index 3fc7e2d6e56d..79e30824f1b1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
# Contributor: KopfKrieg <archlinux [at] absolem [dot] cc>
pkgname=pacman-cleanup-hook
-pkgver=1.0
-pkgrel=8
-pkgdesc='hook to cleanup pacman cache keeping only the installed version plus most recent cache'
-arch=('any')
-depends=('pacman-contrib')
-source=('cleanup.hook')
-sha256sums=('235d6743e8d91bec5ab911a12e061be417f2d179edbc8423fe628fdbfec6876a')
+pkgver=1.1
+pkgrel=1
+pkgdesc='hook to cleanup pacman cache keeping only the installed plus next most recent packages'
+arch=(any)
+depends=(pacman-contrib)
+source=(pacman-cache-cleanup.hook)
+sha256sums=('6b37d7694deeebe1c6a865ed635b96dd1c0b1b8eb486b5c87a92bb3009e43654')
package() {
- install -D -m0644 "${srcdir}/cleanup.hook" "${pkgdir}/usr/share/libalpm/hooks/cleanup.hook"
+ install -Dm0644 -t "$pkgdir/usr/share/libalpm/hooks/" ${source[0]}
}
diff --git a/cleanup.hook b/pacman-cache-cleanup.hook
index 883468dc0f31..a22ff15fc39b 100644
--- a/cleanup.hook
+++ b/pacman-cache-cleanup.hook
@@ -1,11 +1,11 @@
[Trigger]
+Type = Package
Operation = Remove
Operation = Install
Operation = Upgrade
-Type = Package
Target = *
[Action]
-Description = Removing unnecessary cached files (keeping the latest two)…
+Description = Removing obsolete cached package files (keeping the latest two)...
When = PostTransaction
Exec = /usr/bin/paccache -rvk2