summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Blakeney2023-10-21 15:43:36 +1000
committerMark Blakeney2023-10-21 15:43:36 +1000
commit202e13b9a7577c1ad66df1d1d5e9159e42a54616 (patch)
tree02f48d00796fbb99f53646f3f1e124aa9e248042
parent0433d2ef7ec52ca72db63f42b98e927ec287ec4a (diff)
downloadaur-202e13b9a7577c1ad66df1d1d5e9159e42a54616.tar.gz
Update to 3.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD14
2 files changed, 10 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 25ef8ba2db66..00f2bf45a803 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = pacpush
pkgdesc = Utility to push an Arch hosts package and AUR caches to other hosts
- pkgver = 2.26
- pkgrel = 3
+ pkgver = 3.0
+ pkgrel = 1
url = https://github.com/bulletmark/pacpush
arch = any
license = GPL3
@@ -14,10 +14,10 @@ pkgbase = pacpush
depends = rsync
depends = sudo
depends = openssh
+ depends = python-platformdirs
depends = python-requests
- depends = python-ruamel-yaml
depends = pyalpm
- source = pacpush-2.26.tar.gz::https://github.com/bulletmark/pacpush/archive/2.26.tar.gz
- sha1sums = 7a10ddc00b8d9f5c614963f9176f6ad2b568600f
+ source = pacpush-3.0.tar.gz::https://github.com/bulletmark/pacpush/archive/3.0.tar.gz
+ sha1sums = 9fdca00bc5e46e7b790bee86f70c5346f3ef93fb
pkgname = pacpush
diff --git a/PKGBUILD b/PKGBUILD
index d83713c54fb7..2d36339e396e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
# Maintainer: mark.blakeney at bullet-systems dot net
pkgname=pacpush
-pkgver=2.26
-pkgrel=3
+pkgver=3.0
+pkgrel=1
pkgdesc="Utility to push an Arch hosts package and AUR caches to other hosts"
url="https://github.com/bulletmark/$pkgname"
license=("GPL3")
arch=("any")
-depends=("python>=3.10" "rsync" "sudo" "openssh" "python-requests"
- "python-ruamel-yaml" "pyalpm")
+depends=("python>=3.10" "rsync" "sudo" "openssh" "python-platformdirs"
+ "python-requests" "pyalpm")
makedepends=(python-setuptools python-build python-installer
python-wheel python-setuptools-scm)
source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
-sha1sums=('7a10ddc00b8d9f5c614963f9176f6ad2b568600f')
+sha1sums=('9fdca00bc5e46e7b790bee86f70c5346f3ef93fb')
build() {
cd "$srcdir/$pkgname-$pkgver"
@@ -21,10 +21,6 @@ build() {
package() {
cd "$srcdir/$pkgname-$pkgver"
python -m installer --destdir="$pkgdir" dist/*.whl
-
- # Require special handling for python data files on Arch
- local pdir=$(python -c "import site; print(site.getsitepackages()[0])")
- install -m 644 -t "$pkgdir/$pdir/$pkgname/" "$pkgname/${pkgname}.conf"
}
# vim:set ts=2 sw=2 et: