summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Blakeney2023-02-25 14:18:21 +1000
committerMark Blakeney2023-02-25 14:18:21 +1000
commit8b3b2d974132b0956c36ba7e37aa815d1d6e299f (patch)
tree2371bb3a15fbbf0c6b6d42d64de3268c765fa926
parent36557e8c3f92b8a3e2afb7bad2fb69693119c2a4 (diff)
downloadaur-8b3b2d974132b0956c36ba7e37aa815d1d6e299f.tar.gz
Update to 2.24
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD6
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7bba4c84f0cb..e6027324aaf3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = pacpush
pkgdesc = Utility to push an Arch hosts package and AUR caches to other hosts
- pkgver = 2.23
+ pkgver = 2.24
pkgrel = 1
url = https://github.com/bulletmark/pacpush
arch = any
@@ -15,9 +15,10 @@ pkgbase = pacpush
depends = openssh
depends = python-requests
depends = python-ruamel-yaml
+ depends = pyalpm
conflicts = pacsync
replaces = pacsync
- source = pacpush-2.23.tar.gz::https://github.com/bulletmark/pacpush/archive/2.23.tar.gz
- sha1sums = 112470f31ccd6de79fe52b067c46d601ca140903
+ source = pacpush-2.24.tar.gz::https://github.com/bulletmark/pacpush/archive/2.24.tar.gz
+ sha1sums = 7a4a1e9d77e0d8d2ee2a324f185d6eda621bf28d
pkgname = pacpush
diff --git a/PKGBUILD b/PKGBUILD
index 4bb1aa4c85fe..6a7b29d3eef6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,18 @@
# Maintainer: mark.blakeney at bullet-systems dot net
pkgname=pacpush
-pkgver=2.23
+pkgver=2.24
pkgrel=1
pkgdesc="Utility to push an Arch hosts package and AUR caches to other hosts"
url="https://github.com/bulletmark/$pkgname"
license=("GPL3")
arch=("any")
depends=("python>=3.7" "rsync" "sudo" "openssh" "python-requests"
- "python-ruamel-yaml")
+ "python-ruamel-yaml" "pyalpm")
makedepends=(python-setuptools python-build python-installer python-wheel)
source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
replaces=("pacsync")
conflicts=("pacsync")
-sha1sums=('112470f31ccd6de79fe52b067c46d601ca140903')
+sha1sums=('7a4a1e9d77e0d8d2ee2a324f185d6eda621bf28d')
build() {
cd "$srcdir/$pkgname-$pkgver"