summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Blakeney2021-01-28 16:44:15 +1000
committerMark Blakeney2021-01-28 16:44:15 +1000
commitb066f167820df9004785059de0a42a1be0dcb4e2 (patch)
tree10538fb235f5d8f22a2ef4f881a03aeb2a7f39ec
parent1b18e6be82ebe520b6a294e0ebb0bf01911616f0 (diff)
downloadaur-b066f167820df9004785059de0a42a1be0dcb4e2.tar.gz
Update to 2.8.1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD29
2 files changed, 29 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ce50967b1353..8e8712830d50 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = pacpush
pkgdesc = Utility to push an Arch hosts package and AUR caches to other hosts
- pkgver = 2.8
+ pkgver = 2.8.1
pkgrel = 1
url = https://github.com/bulletmark/pacpush
arch = any
license = GPL3
- makedepends = python-setuptools
+ makedepends = python-pip
+ makedepends = python-wheel
depends = python>=3.6
depends = rsync
depends = sudo
@@ -14,9 +15,8 @@ pkgbase = pacpush
depends = python-ruamel-yaml
conflicts = pacsync
replaces = pacsync
- backup = etc/pacpush.conf
- source = pacpush-2.8.tar.gz::https://github.com/bulletmark/pacpush/archive/2.8.tar.gz
- sha1sums = 3fb1c0806beca822f692e032dfa06b74c7238081
+ source = pacpush-2.8.1.tar.gz::https://github.com/bulletmark/pacpush/archive/2.8.1.tar.gz
+ sha1sums = fd9dbb7f370c23486d2b22557d656f8276fbc662
pkgname = pacpush
diff --git a/PKGBUILD b/PKGBUILD
index 56f91febbf36..e19126b23bed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,40 @@
# Maintainer: mark.blakeney at bullet-systems dot net
pkgname=pacpush
-pkgver=2.8
+pkgver=2.8.1
pkgrel=1
pkgdesc="Utility to push an Arch hosts package and AUR caches to other hosts"
url="https://github.com/bulletmark/$pkgname"
license=("GPL3")
arch=("any")
depends=("python>=3.6" "rsync" "sudo" "openssh" "python-requests" "python-ruamel-yaml")
-makedepends=("python-setuptools")
+makedepends=("python-pip" "python-wheel")
source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
replaces=("pacsync")
conflicts=("pacsync")
-sha1sums=('3fb1c0806beca822f692e032dfa06b74c7238081')
+sha1sums=('fd9dbb7f370c23486d2b22557d656f8276fbc662')
package() {
- cd "$pkgname-$pkgver"
- python setup.py install --root="$pkgdir/" --optimize=1
+ cd "$srcdir/$pkgname-$pkgver"
+
+ PIP_CONFIG_FILE=/dev/null pip install \
+ --root="$pkgdir" \
+ --isolated \
+ --ignore-installed \
+ --no-deps \
+ --disable-pip-version-check \
+ --no-python-version-warning \
+ --no-warn-script-location \
+ --no-cache-dir \
+ --no-compile \
+ --progress-bar=off \
+ .
+
+ local pdir=$(python -c "import site; print(site.getsitepackages()[0])")
+ local _pkgname="${pkgname//-/_}"
+ cd "$pkgdir/$pdir"
+ rm -f $_pkgname-*.dist-info/direct_url.json
+ sed -i "/\/direct_url.json,/d" $_pkgname-*.dist-info/RECORD
+ python -O -m compileall -q .
}
# vim:set ts=2 sw=2 et: