summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Blakeney2021-12-14 07:48:34 +1000
committerMark Blakeney2021-12-14 07:48:34 +1000
commiteb54c8d5904c8af0a0aae579ca2fc1e3d5fc7393 (patch)
tree064921c731a9f34de342e6339b0b8e1e9a464952
parent4234cd7c771de8d82aa3f936610a87f1f2859d9e (diff)
downloadaur-eb54c8d5904c8af0a0aae579ca2fc1e3d5fc7393.tar.gz
Update to 2.11
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD7
2 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 371a963ff267..cb045568dc00 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = pacpush
pkgdesc = Utility to push an Arch hosts package and AUR caches to other hosts
- pkgver = 2.10
+ pkgver = 2.11
pkgrel = 1
url = https://github.com/bulletmark/pacpush
arch = any
@@ -14,9 +14,10 @@ pkgbase = pacpush
depends = python-requests
depends = python-ruamel-yaml
depends = python-rich
+ depends = python-packaging
conflicts = pacsync
replaces = pacsync
- source = pacpush-2.10.tar.gz::https://github.com/bulletmark/pacpush/archive/2.10.tar.gz
- sha1sums = 38f2d31d8b397089c42217fc54fa3cab52a1dc6c
+ source = pacpush-2.11.tar.gz::https://github.com/bulletmark/pacpush/archive/2.11.tar.gz
+ sha1sums = 27b597b9decb87dc5cb96f2e164d38408cf7144b
pkgname = pacpush
diff --git a/PKGBUILD b/PKGBUILD
index 3d5e0e0524c8..cbc7bb4aa499 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,18 @@
# Maintainer: mark.blakeney at bullet-systems dot net
pkgname=pacpush
-pkgver=2.10
+pkgver=2.11
pkgrel=1
pkgdesc="Utility to push an Arch hosts package and AUR caches to other hosts"
url="https://github.com/bulletmark/$pkgname"
license=("GPL3")
arch=("any")
-depends=("python>=3.6" "rsync" "sudo" "openssh" "python-requests" "python-ruamel-yaml" "python-rich")
+depends=("python>=3.6" "rsync" "sudo" "openssh" "python-requests"
+ "python-ruamel-yaml" "python-rich" "python-packaging")
makedepends=("python-pip" "python-wheel")
source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
replaces=("pacsync")
conflicts=("pacsync")
-sha1sums=('38f2d31d8b397089c42217fc54fa3cab52a1dc6c')
+sha1sums=('27b597b9decb87dc5cb96f2e164d38408cf7144b')
package() {
cd "$srcdir/$pkgname-$pkgver"