summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIan Denhardt2020-09-09 11:56:03 -0400
committerIan Denhardt2020-09-09 11:56:03 -0400
commitf329805c73b7b8e3f52da6d0a86d1647b9b0994e (patch)
treed882f9ea87eec11405dba14ef85481e5a2142db4
parent6bce739bfdfd2498930fe0db02cf0891d7424487 (diff)
downloadaur-pacsync-git.tar.gz
Update package re: VCS package guidelines.
- Add a pkgver() function. - Actually fetch this via git; necessary to get pkgver to work - set the checksums to SKIP - Remove no-op build() function. IIRC this was originally a workaround to deal with makepkg not being able to handle pkgbuilds without a build(), though obviously that has changed.
-rw-r--r--.SRCINFO7
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD23
3 files changed, 22 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cf1938ec1793..d5f001d7f2f3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = pacsync-git
pkgdesc = A pacman frontend which manages packages based on a holistic view of the system
- pkgver = 8
+ pkgver = 9
pkgrel = 1
url = https://gitlab.com/isd/pacsync
arch = any
license = custom
+ makedepends = git
replaces = pacsync-hg
- source = https://gitlab.com/isd/pacsync/-/archive/master/pacsync-master.tar.gz
- sha256sums = 3cca7885a3579900fd7c69620c84f856eb40f25645642b43afa8d4bfbb0286e5
+ source = git+https://gitlab.com/isd/pacsync
+ sha256sums = SKIP
pkgname = pacsync-git
diff --git a/.gitignore b/.gitignore
index 62399afa57c6..3c17067576c4 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,3 +1,6 @@
*.tar.*
src/
pkg/
+
+# Git checkout:
+pacsync
diff --git a/PKGBUILD b/PKGBUILD
index f63370b9342c..3d5d1c3da796 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,29 @@
# Maintainer: Ian Denhardt <ian@zenhack.net>
pkgname=pacsync-git
-pkgver=8
+pkgver=9
pkgrel=1
pkgdesc="A pacman frontend which manages packages based on a holistic view of the system"
arch=('any')
url="https://gitlab.com/isd/pacsync"
license=('custom')
-# TODO: should pin the exact version here -- but not really a huge rush, since
-# this isn't actively developed...
-source=('https://gitlab.com/isd/pacsync/-/archive/master/pacsync-master.tar.gz')
+source=('git+https://gitlab.com/isd/pacsync')
replaces=('pacsync-hg')
+makedepends=('git')
-build() {
- :
+pkgver() {
+ # We omit the leading r recommended in the VCS package guidelines, because:
+ #
+ # - Earlier versions of this package already used bare numbers, so adding
+ # an r would cause the version number to run backwards
+ # - We can guarantee upstream will never tag a release (since the author
+ # of this PKGBUILD is also the upstream author), so there is no need to
+ # worry about a release appearing and messing up the versioning
+ cd "$srcdir"/pacsync
+ git rev-list --count HEAD
}
package() {
- cd "$srcdir"/pacsync-master
+ cd "$srcdir"/pacsync
install -Dm755 pacsync $pkgdir/usr/bin/pacsync
install -Dm644 pacsync.8 $pkgdir/usr/share/man/man8/pacsync.8
@@ -25,4 +32,4 @@ package() {
}
# vim:set ts=2 sw=2 et:
-sha256sums=('3cca7885a3579900fd7c69620c84f856eb40f25645642b43afa8d4bfbb0286e5')
+sha256sums=('SKIP')