summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWorMzy Tykashi2016-08-23 15:30:02 +0100
committerWorMzy Tykashi2016-08-23 15:30:02 +0100
commit8ad83d3fed7cd024bf73ef5d1c4e159ded60a437 (patch)
tree119a7a8fbaf7b8c2632d2fd9867d346a81072ab9
parentba4b55b68532b4c51322c164968e69e6c15c1412 (diff)
downloadaur-8ad83d3fed7cd024bf73ef5d1c4e159ded60a437.tar.gz
Updated to 26.4.0.1
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD17
-rw-r--r--mozconfig.in2
3 files changed, 21 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 13bca2a904bc..d5a19c2649c7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = palemoon
pkgdesc = Open source web browser based on Firefox focusing on efficiency.
- pkgver = 26.4.0
+ pkgver = 26.4.0.1
pkgrel = 1
url = http://www.palemoon.org/
arch = i686
@@ -14,8 +14,8 @@ pkgbase = palemoon
makedepends = unzip
makedepends = zip
makedepends = yasm
- makedepends = gstreamer
- makedepends = gst-plugins-base
+ makedepends = gstreamer0.10
+ makedepends = gstreamer0.10-base-plugins
makedepends = libpulse
makedepends = gcc5
depends = gtk2
@@ -28,12 +28,15 @@ pkgbase = palemoon
optdepends = libpulse: PulseAudio audio driver
optdepends = hunspell: spell checker and morphological analyzer
optdepends = hyphen: library for hyphenation and justification
- optdepends = gst-libav: h.264 support
- optdepends = gst-plugins-good: h.264 support
- source = git+https://github.com/MoonchildProductions/Pale-Moon#tag=26.4.0_Release
+ optdepends = gstreamer0.10-base-plugins: vorbis decoding, ogg demuxing
+ optdepends = gstreamer0.10-good-plugins: webm and mp4 demuxing
+ optdepends = gstreamer0.10-bad-plugins: aac, vp8 and opus decoding
+ optdepends = gstreamer0.10-ugly-plugins: h.264 and mp3 decoding
+ optdepends = gstreamer0.10-ffmpeg: h.264 decoding
+ source = git+https://github.com/MoonchildProductions/Pale-Moon#commit=7a756323e31eee935a518a28bf4254319df2ee59
source = mozconfig.in
md5sums = SKIP
- md5sums = 1436a11b51bdd6ec1e107a2451c72d8c
+ md5sums = 6c23b737a8ef846926d247116b69f33d
pkgname = palemoon
diff --git a/PKGBUILD b/PKGBUILD
index 31f752aace8c..76c8e5325e6b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: ilikenwf
# Contributor: American_Jesus
pkgname=palemoon
-pkgver=26.4.0
+pkgver=26.4.0.1
pkgrel=1
pkgdesc="Open source web browser based on Firefox focusing on efficiency."
arch=('i686' 'x86_64')
@@ -11,17 +11,20 @@ url="http://www.palemoon.org/"
license=('MPL' 'GPL' 'LGPL')
depends=('gtk2' 'dbus-glib' 'desktop-file-utils' 'libxt' 'mime-types' 'alsa-lib'
'startup-notification')
-makedepends=('git' 'python2' 'autoconf2.13' 'unzip' 'zip' 'yasm' 'gstreamer'
- 'gst-plugins-base' 'libpulse' 'gcc5')
+makedepends=('git' 'python2' 'autoconf2.13' 'unzip' 'zip' 'yasm' 'gstreamer0.10'
+ 'gstreamer0.10-base-plugins' 'libpulse' 'gcc5')
optdepends=('libpulse: PulseAudio audio driver'
'hunspell: spell checker and morphological analyzer'
'hyphen: library for hyphenation and justification'
- 'gst-libav: h.264 support'
- 'gst-plugins-good: h.264 support')
-source=(git+"https://github.com/MoonchildProductions/Pale-Moon#tag=${pkgver}_Release"
+ 'gstreamer0.10-base-plugins: vorbis decoding, ogg demuxing'
+ 'gstreamer0.10-good-plugins: webm and mp4 demuxing'
+ 'gstreamer0.10-bad-plugins: aac, vp8 and opus decoding'
+ 'gstreamer0.10-ugly-plugins: h.264 and mp3 decoding'
+ 'gstreamer0.10-ffmpeg: h.264 decoding')
+source=(git+"https://github.com/MoonchildProductions/Pale-Moon#commit=7a756323e31eee935a518a28bf4254319df2ee59" # Devs haven't bothered to tag this release
mozconfig.in)
md5sums=('SKIP'
- '1436a11b51bdd6ec1e107a2451c72d8c')
+ '6c23b737a8ef846926d247116b69f33d')
prepare() {
sed 's#%SRCDIR%#'"$srcdir"'#g' mozconfig.in > mozconfig
diff --git a/mozconfig.in b/mozconfig.in
index 0af96ca34a7a..73a9b5262921 100644
--- a/mozconfig.in
+++ b/mozconfig.in
@@ -46,7 +46,7 @@ ac_add_options --disable-valgrind
# enable useful features
ac_add_options --enable-chrome-format=omni
-ac_add_options --enable-gstreamer=1.0
+ac_add_options --enable-gstreamer=0.10
ac_add_options --enable-pulseaudio
ac_add_options --enable-startup-notification
ac_add_options --enable-url-classifier