summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWorMzy Tykashi2015-06-10 19:46:45 +0100
committerWorMzy Tykashi2015-06-10 19:46:45 +0100
commita4abfd1c0d2b3432304371532a59311413a092bc (patch)
treea62d1cc88e77bdf2fb85c51547ab83bfb8a590d0
downloadaur-a4abfd1c0d2b3432304371532a59311413a092bc.tar.gz
Copied from non-git
-rw-r--r--.SRCINFO51
-rw-r--r--PKGBUILD75
-rw-r--r--mozconfig.in42
-rw-r--r--palemoon.desktop13
-rw-r--r--palemoon.install12
5 files changed, 193 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..15f9217b0b10
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,51 @@
+pkgbase = palemoon
+ pkgdesc = Open source web browser based on Firefox focusing on efficiency.
+ pkgver = 25.5.0
+ pkgrel = 1
+ url = http://www.palemoon.org/
+ install = palemoon.install
+ arch = i686
+ arch = x86_64
+ license = MPL
+ license = GPL
+ license = LGPL
+ makedepends = zip
+ makedepends = unzip
+ makedepends = freetype2
+ makedepends = fontconfig
+ makedepends = pkg-config
+ makedepends = iw
+ makedepends = libidl2
+ makedepends = python2
+ makedepends = curl
+ makedepends = libnotify
+ makedepends = mesa
+ makedepends = autoconf2.13
+ makedepends = yasm
+ makedepends = gstreamer0.10
+ makedepends = git
+ makedepends = gstreamer0.10-base-plugins
+ makedepends = gstreamer0.10-good-plugins
+ makedepends = gstreamer0.10-bad-plugins
+ makedepends = gstreamer0.10-ugly-plugins
+ makedepends = gstreamer0.10-ffmpeg
+ depends = gtk2
+ depends = dbus-glib
+ depends = desktop-file-utils
+ depends = libxt
+ depends = mime-types
+ depends = nss
+ depends = alsa-lib
+ optdepends = networkmanager: Location detection via available WiFi networks
+ optdepends = libpulse: PulseAudio audio driver
+ optdepends = hunspell: spell checker and morphological analyzer
+ optdepends = hyphen: library for hyphenation and justification
+ source = git+https://github.com/MoonchildProductions/Pale-Moon#tag=25.5.0_Release
+ source = palemoon.desktop
+ source = mozconfig.in
+ md5sums = SKIP
+ md5sums = 32231f6e6a532021fd04c6d7b32f4270
+ md5sums = 9ff0a5a4cfa930148cb96612bed4fe09
+
+pkgname = palemoon
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..28dc85d454d9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,75 @@
+# Maintainer: WorMzy Tykashi <wormzy.tykashi@gmail.com>
+# Contributor: artiom <a.mv at gmx dot fr>
+pkgname=palemoon
+pkgver=25.5.0
+pkgrel=1
+pkgdesc="Open source web browser based on Firefox focusing on efficiency."
+arch=('i686' 'x86_64')
+url="http://www.palemoon.org/"
+license=('MPL' 'GPL' 'LGPL')
+depends=('gtk2' 'dbus-glib' 'desktop-file-utils' 'libxt' 'mime-types' 'nss' 'alsa-lib')
+makedepends=('zip' 'unzip' 'freetype2' 'fontconfig' 'pkg-config' 'iw' 'libidl2' 'python2'
+ 'curl' 'libnotify' 'mesa' 'autoconf2.13' 'yasm' 'gstreamer0.10' 'git'
+ 'gstreamer0.10-base-plugins'
+ 'gstreamer0.10-good-plugins'
+ 'gstreamer0.10-bad-plugins'
+ 'gstreamer0.10-ugly-plugins'
+ 'gstreamer0.10-ffmpeg'
+)
+optdepends=('networkmanager: Location detection via available WiFi networks'
+ 'libpulse: PulseAudio audio driver'
+ 'hunspell: spell checker and morphological analyzer'
+ 'hyphen: library for hyphenation and justification')
+install=palemoon.install
+source=(git+"https://github.com/MoonchildProductions/Pale-Moon#tag=${pkgver}_Release"
+ palemoon.desktop
+ mozconfig.in)
+md5sums=('SKIP'
+ '32231f6e6a532021fd04c6d7b32f4270'
+ '9ff0a5a4cfa930148cb96612bed4fe09')
+
+build() {
+ export MOZBUILD_STATE_PATH="$srcdir/mozbuild"
+ export MOZCONFIG="$srcdir/mozconfig"
+ echo MOZBUILD_STATE_PATH=$MOZBUILD_STATE_PATH
+ echo MOZCONFIG=$MOZCONFIG
+ sed 's#%SRCDIR%#'"$srcdir"'#g' mozconfig.in > mozconfig
+
+ cd "$srcdir/Pale-Moon"
+ chmod -R +x build/autoconf/* python/*
+ find . -name '*.sh' -exec chmod +x {} \;
+
+ CPPFLAGS="$CPPFLAGS -O2"
+ python2 mach build || echo "Next =>"
+ python2 mach build
+}
+
+package() {
+ cd "$srcdir/pmbuild"
+ make package
+ cd dist
+ install -d "$pkgdir"/usr/{bin,lib}
+ cp -r palemoon/ "$pkgdir/usr/lib/$pkgname"
+ ln -s "../lib/$pkgname/palemoon" "$pkgdir/usr/bin/palemoon"
+ install -Dm644 "$srcdir/palemoon.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
+
+ # icons
+ install -Dm644 palemoon/browser/chrome/icons/default/default16.png \
+ "$pkgdir/usr/share/icons/hicolor/16x16/apps/$pkgname.png"
+ install -Dm644 palemoon/browser/chrome/icons/default/default32.png \
+ "$pkgdir/usr/share/icons/hicolor/32x32/apps/$pkgname.png"
+ install -Dm644 palemoon/browser/chrome/icons/default/default48.png \
+ "$pkgdir/usr/share/icons/hicolor/48x48/apps/$pkgname.png"
+ install -Dm644 palemoon/browser/icons/mozicon128.png \
+ "$pkgdir/usr/share/icons/hicolor/128x128/apps/$pkgname.png"
+
+ # use system-provided dictionaries
+ rm -rf "$pkgdir"/usr/lib/$pkgname/{dictionaries,hyphenation}
+ ln -s /usr/share/hunspell "$pkgdir/usr/lib/$pkgname/dictionaries"
+ ln -s /usr/share/hyphen "$pkgdir/usr/lib/$pkgname/hyphenation"
+
+ # avoid duplicate binaries
+ # https://bugzilla.mozilla.org/show_bug.cgi?id=658850
+ #ln -sf palemoon "$pkgdir/usr/lib/$pkgname/palemoon-bin"
+ rm -f "$pkgdir/usr/lib/$pkgname/palemoon-bin"
+}
diff --git a/mozconfig.in b/mozconfig.in
new file mode 100644
index 000000000000..d34d034fb4e4
--- /dev/null
+++ b/mozconfig.in
@@ -0,0 +1,42 @@
+mk_add_options PYTHON=/usr/bin/python2
+ac_add_options --enable-official-branding
+ac_add_options --with-distribution-id=Palemoon
+export MOZILLA_OFFICIAL=1
+export CC=gcc
+export CXX=g++
+
+mk_add_options MOZ_CO_PROJECT=browser
+ac_add_options --enable-application=browser
+
+mk_add_options MOZ_OBJDIR=%SRCDIR%/pmbuild
+
+ac_add_options --disable-crashreporter
+ac_add_options --disable-accessibility
+ac_add_options --disable-parental-controls
+ac_add_options --disable-gamepad
+ac_add_options --disable-webrtc
+ac_add_options --disable-logging
+ac_add_options --disable-necko-wifi
+ac_add_options --disable-installer
+ac_add_options --disable-updater
+ac_add_options --disable-websms-backend
+ac_add_options --disable-windows-mobile-components
+ac_add_options --disable-metro
+ac_add_options --disable-maintenance-service
+
+ac_add_options --disable-tests
+ac_add_options --disable-mochitests
+ac_add_options --disable-debug
+ac_add_options --disable-debug-symbols
+
+ac_add_options --enable-strip
+ac_add_options --disable-jemalloc # see https://github.com/MoonchildProductions/Pale-Moon/issues/39
+mk_add_options MOZ_MAKE_FLAGS="-j4"
+mk_add_options _FORTIFY_SOURCE=0
+ac_add_options --enable-optimize="-O2"
+
+ac_add_options --enable-safe-browsing
+ac_add_options --enable-url-classifier
+ac_add_options --enable-chrome-format=omni
+
+ac_add_options --x-libraries=/usr/lib
diff --git a/palemoon.desktop b/palemoon.desktop
new file mode 100644
index 000000000000..0c29485d6f2c
--- /dev/null
+++ b/palemoon.desktop
@@ -0,0 +1,13 @@
+[Desktop Entry]
+Version=1.0
+Name=Pale Moon Web Browser
+Comment=Browse the World Wide Web
+Keywords=Internet;WWW;Browser;Web;Firefox
+Exec=palemoon %u
+Terminal=false
+X-MultipleArgs=false
+Type=Application
+Icon=palemoon
+Categories=Network;WebBrowser;Internet
+MimeType=text/html;text/xml;application/xhtml+xml;application/xml;application/rss+xml;application/rdf+xml;image/gif;image/jpeg;image/png;x-scheme-handler/http;x-scheme-handler/https;x-scheme-handler/ftp;x-scheme-handler/chrome;video/webm;application/x-xpinstall;
+StartupNotify=true
diff --git a/palemoon.install b/palemoon.install
new file mode 100644
index 000000000000..c929b541c726
--- /dev/null
+++ b/palemoon.install
@@ -0,0 +1,12 @@
+post_install() {
+ update-desktop-database -q
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+} \ No newline at end of file