summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSantiago Burgos2024-04-22 21:58:39 -0600
committerSantiago Burgos2024-04-22 21:58:39 -0600
commit0287b467011b2b15f3f68c656db165358c31481e (patch)
tree888aca95078eb06ae29c3959e17c8d8711d5b318
parent110d16a9d5eb3d5d47315c3c6ba9bb8aac120a86 (diff)
downloadaur-pamac-flatpak.tar.gz
readded pamac-flatpak as combined with pamac-nosnap and based on it
-rw-r--r--.SRCINFO42
-rw-r--r--LICENSE24
-rw-r--r--PKGBUILD83
-rw-r--r--README.md11
-rw-r--r--pamac.install22
5 files changed, 75 insertions, 107 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0534fdd2098f..477c4da85cab 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,8 @@
pkgbase = pamac-flatpak
- pkgdesc = A Gtk3 frontend for libalpm (with AUR, Flatpak and AppIndicator support)
- pkgver = 10.4.3
+ pkgdesc = A GUI frontend for libalpm. With Flatpak support
+ pkgver = 11.7.1
pkgrel = 1
url = https://gitlab.manjaro.org/applications/pamac
- install = pamac.install
arch = i686
arch = x86_64
arch = arm
@@ -11,36 +10,33 @@ pkgbase = pamac-flatpak
arch = armv7h
arch = aarch64
license = GPL3
+ makedepends = asciidoc
makedepends = gettext
+ makedepends = git
+ makedepends = gobject-introspection
makedepends = itstool
- makedepends = vala>=0.45
makedepends = meson
- makedepends = gobject-introspection
+ makedepends = ninja
+ makedepends = vala
makedepends = xorgproto
- makedepends = asciidoc
- depends = libnotify
- depends = libpamac-flatpak>=10.3.0
+ depends = desktop-file-utils
+ depends = gnutls
+ depends = gtk4
+ depends = libadwaita
depends = libhandy
- depends = git
- depends = fakeroot
- depends = pkgconf
- depends = appstream-glib
+ depends = libnotify
+ depends = libpamac-flatpak
+ optdepends = lxsession: needed for authentification in Xfce, LXDE etc.
optdepends = polkit-gnome: needed for authentification in Cinnamon, Gnome
- optdepends = fwupd: support firmware updates
- provides = pamac
+ optdepends = plymouth: offline upgrades
+ provides = pamac=11.7.1-1
conflicts = pamac
- conflicts = pamac-cli
- conflicts = pamac-gtk
- conflicts = pamac-qt
- conflicts = pamac-classic
conflicts = pamac-aur
- conflicts = pamac-aur-git
conflicts = pamac-all
- conflicts = pamac-all-git
- conflicts = pamac-flatpak-gnome
+ conflicts = pamac-cli
conflicts = pamac-nosnap
options = !emptydirs
- source = pamac-10.4.3.tar.bz2::https://gitlab.manjaro.org/applications/pamac/-/archive/v10.4.3/pamac-v10.4.3.tar.bz2
- sha512sums = 011af395092c27c4e73f50b5f43e662b5fb5cd7ae920176c3702479fb05df958fa7ceaf206bfcdad016103d0fc9d6b94e0d94d27701e5afcad2ae92024c90e5c
+ source = https://gitlab.manjaro.org/applications/pamac/-/archive/11.7.1/pamac-11.7.1.tar.gz
+ sha256sums = bdf93f7efde43a1d0fa9ef9cceea409691f1d5e42bbd4fb0f9b3e38e0cd0c22a
pkgname = pamac-flatpak
diff --git a/LICENSE b/LICENSE
deleted file mode 100644
index fdddb29aa445..000000000000
--- a/LICENSE
+++ /dev/null
@@ -1,24 +0,0 @@
-This is free and unencumbered software released into the public domain.
-
-Anyone is free to copy, modify, publish, use, compile, sell, or
-distribute this software, either in source code form or as a compiled
-binary, for any purpose, commercial or non-commercial, and by any
-means.
-
-In jurisdictions that recognize copyright laws, the author or authors
-of this software dedicate any and all copyright interest in the
-software to the public domain. We make this dedication for the benefit
-of the public at large and to the detriment of our heirs and
-successors. We intend this dedication to be an overt act of
-relinquishment in perpetuity of all present and future rights to this
-software under copyright law.
-
-THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
-EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
-MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.
-IN NO EVENT SHALL THE AUTHORS BE LIABLE FOR ANY CLAIM, DAMAGES OR
-OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE,
-ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
-OTHER DEALINGS IN THE SOFTWARE.
-
-For more information, please refer to <https://unlicense.org>
diff --git a/PKGBUILD b/PKGBUILD
index 4e75bcb3fda8..732107a7d4fe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,69 @@
-# Maintainer: TommyTran732 <contact@tommytran.io>
-# Contributor: Frederic Bezies <fredbezies@gmail.com>, Cassandra Watergate (saltedcoffii) <cassandrajwatergate@gmail.com>, LSUtigers3131
+# Maintainer: Sam Burgos <santiago.burgos1089@gmail.com>
+# Contributer: TommyTran732 <contact@tommytran.io>
+# Contributer: Cassandra Watergate (saltedcoffii) <cassandrajwatergate@gmail.com>
+# Contributer: LSUtigers3131
-pkgname=pamac-flatpak
-pkgver=10.4.3
+_pkgname=pamac
+pkgname=${_pkgname}-flatpak
+pkgver=11.7.1
pkgrel=1
-_pkgfixver=$pkgver
-
-pkgdesc="A Gtk3 frontend for libalpm (with AUR, Flatpak and AppIndicator support)"
+_srcdir="$_pkgname-$pkgver"
+pkgdesc="A GUI frontend for libalpm. With Flatpak support"
arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h' 'aarch64')
-url="https://gitlab.manjaro.org/applications/pamac"
+url="https://gitlab.manjaro.org/applications/$_pkgname"
license=('GPL3')
-depends=('libnotify' 'libpamac-flatpak>=10.3.0' 'libhandy' 'git' 'fakeroot' 'pkgconf' 'appstream-glib')
-optdepends=('polkit-gnome: needed for authentification in Cinnamon, Gnome'
- 'fwupd: support firmware updates')
-makedepends=('gettext' 'itstool' 'vala>=0.45' 'meson' 'gobject-introspection' 'xorgproto' 'asciidoc')
-conflicts=('pamac' 'pamac-cli' 'pamac-gtk' 'pamac-qt' 'pamac-classic' 'pamac-aur' 'pamac-aur-git' 'pamac-all' 'pamac-all-git' 'pamac-flatpak-gnome' 'pacmac-nosnap')
-provides=('pamac')
+depends=(
+ 'desktop-file-utils'
+ 'gnutls'
+ 'gtk4'
+ 'libadwaita'
+ 'libhandy'
+ 'libnotify'
+ 'libpamac-flatpak'
+)
+optdepends=(
+ 'lxsession: needed for authentification in Xfce, LXDE etc.'
+ 'polkit-gnome: needed for authentification in Cinnamon, Gnome'
+ 'plymouth: offline upgrades'
+)
+makedepends=(
+ 'asciidoc'
+ 'gettext'
+ 'git'
+ 'gobject-introspection'
+ 'itstool'
+ 'meson'
+ 'ninja'
+ 'vala'
+ 'xorgproto'
+)
+#provides=(pamac)
+provides=("${_pkgname}=${pkgver}-${pkgrel}")
+conflicts=(
+ 'pamac'
+ 'pamac-aur'
+ 'pamac-all'
+ 'pamac-cli'
+ 'pamac-nosnap'
+)
options=(!emptydirs)
-install=pamac.install
-source=("pamac-$pkgver.tar.gz::$url/-/archive/v$pkgver/pamac-v$pkgver.tar.bz2")
-sha512sums=('011af395092c27c4e73f50b5f43e662b5fb5cd7ae920176c3702479fb05df958fa7ceaf206bfcdad016103d0fc9d6b94e0d94d27701e5afcad2ae92024c90e5c')
+source=("$url/-/archive/$pkgver/pamac-$pkgver.tar.gz")
+sha256sums=('bdf93f7efde43a1d0fa9ef9cceea409691f1d5e42bbd4fb0f9b3e38e0cd0c22a')
+
+_srcdir="$_pkgname-$pkgver"
prepare() {
- # adjust version string
- sed -i -e "s|\"$_pkgfixver\"|\"$pkgver-$pkgrel\"|g" $srcdir/pamac-v$pkgver/src/version.vala
+ cd "$_srcdir"
+ # adjust version string
+ sed -i -e "s|\"$pkgver\"|\"$pkgver-$pkgrel\"|g" 'src/version.vala'
}
build() {
- arch-meson --buildtype=release -Denable-fake-gnome-software=false $srcdir/pamac-v$pkgver build
- meson compile -C build
-}
-
-check() {
- meson test -C build --print-errorlogs
+ arch-meson "$_srcdir" 'build' -Denable-fake-gnome-software=false
+ meson compile -C 'build'
}
package() {
- meson install -C build --destdir "$pkgdir"
-} \ No newline at end of file
+ meson install -C 'build' --destdir "$pkgdir"
+ install -Dm644 "$_srcdir/COPYING" "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+}
diff --git a/README.md b/README.md
deleted file mode 100644
index 74095260d114..000000000000
--- a/README.md
+++ /dev/null
@@ -1,11 +0,0 @@
-# pamac-flatpak
-A Gtk3 frontend for libalpm (with AUR, Flatpak, and AppIndicator support)
-
-# Attribution
-This package is a modified version of [pamac-nosnap](https://aur.archlinux.org/packages/pamac-nosnap) with slightly different install and build scripts. <br >
-
-It was originally based on [pamac-all](https://aur.archlinux.org/packages/pamac-all) with snapd removed.
-
-# Notes
-The Flathub Beta repository is enable by default. <br >
-I have also removed the post_upgrade() function to make it so that if you remove any of the default Flatpak repo, they won't persistently come back after an update. \ No newline at end of file
diff --git a/pamac.install b/pamac.install
deleted file mode 100644
index 272d6b4a05ea..000000000000
--- a/pamac.install
+++ /dev/null
@@ -1,22 +0,0 @@
-post_install() {
- # enable flatpak repo
- if [ -f /usr/bin/flatpak ]; then
- flatpak remote-add --if-not-exists flathub https://flathub.org/repo/flathub.flatpakrepo
- flatpak remote-add --if-not-exists flathub-beta https://flathub.org/beta-repo/flathub-beta.flatpakrepo
- fi
- # enable systemd timers
- systemctl enable --now pamac-cleancache.timer
- #systemctl enable --now pamac-mirrorlist.timer
- # polkit agent
- printf '==> An authentication agent is required\n'
- printf ' Cinnamon, Deepin, GNOME, GNOME Flashback, KDE, LXDE, LXQt, MATE and Xfce\n'
- printf ' have an authentication agent already.\n'
- printf ' See https://wiki.archlinux.org/index.php/Polkit#Authentication_agents\n'
- printf ' for other desktop environments.\n'
-}
-
-post_remove() {
- # disable systemd timers
- systemctl disable --now pamac-cleancache.timer
- #systemctl disable --now pamac-mirrorlist.timer
-}