summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Kitching2017-06-25 04:48:49 +0100
committerChris Kitching2017-06-25 04:48:49 +0100
commit8251093b14660a90f8588b4910661cd15ca14d44 (patch)
treec448e2b88a65aca090a04ea512b0bb347a46c5dd
downloadaur-pandoc-lite.tar.gz
I'll make my own pandoc, then, with blackjack. And hookers.
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD44
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4171cb0777ba
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Sun Jun 25 03:48:43 UTC 2017
+pkgbase = pandoc-lite
+ pkgdesc = Pandoc - executable only, without 750MB Haskell depends/makedepends
+ pkgver = 1.19.2.1
+ pkgrel = 1
+ url = http://pandoc.org
+ arch = x86_64
+ license = GPL
+ provides = pandoc=1.19.2.1
+ conflicts = pandoc
+ replaces = pandoc-static
+ source = https://github.com/jgm/pandoc/releases/download/1.19.2.1/pandoc-1.19.2.1-1-amd64.deb
+ source = https://hackage.haskell.org/package/pandoc-1.19.2.1/pandoc-1.19.2.1.tar.gz
+ sha256sums = db828cbab2a6d0d33f3754c4061a844ae2d1f0a01cbb12c512ef109117595dd2
+ sha256sums = 08692f3d77bf95bb9ba3407f7af26de7c23134e7efcdafad0bdaf9050e2c7801
+
+pkgname = pandoc-lite
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9746ad525259
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+pkgname=pandoc-lite
+pkgver=1.19.2.1
+pkgrel=1
+pkgdesc="Pandoc - executable only, without 750MB Haskell depends/makedepends"
+url="http://pandoc.org"
+license=("GPL")
+arch=('x86_64')
+conflicts=("pandoc")
+provides=("pandoc=${pkgver}")
+replaces=('pandoc-static')
+
+source=(
+ "https://github.com/jgm/pandoc/releases/download/${pkgver}/pandoc-${pkgver}-1-amd64.deb"
+
+ # Note that they use a git submodule for data/templates, so soure tarballs from github are incomplete.
+ # Fetching from hackage gets us a complete tarball without writing our own `git submodule` commands.
+ "https://hackage.haskell.org/package/pandoc-${pkgver}/pandoc-${pkgver}.tar.gz"
+)
+sha256sums=(
+ "db828cbab2a6d0d33f3754c4061a844ae2d1f0a01cbb12c512ef109117595dd2"
+ "08692f3d77bf95bb9ba3407f7af26de7c23134e7efcdafad0bdaf9050e2c7801"
+)
+
+package() {
+ cd "${srcdir}"
+
+ # To avoid having to download over a gigabyte of haskell makedepends (400-ish for ghc, plus 750 in libs), we
+ # just yoink the binary from static compiled binary distributed by pandoc:
+ tar -zxf data.tar.gz
+ cp -R usr "${pkgdir}/"
+
+ # Citeproc is provided by a different package, and depends on various other datafiles we don't handle here.
+ rm "${pkgdir}/usr/bin/pandoc-citeproc"
+ rm "${pkgdir}/usr/share/man/man1/pandoc-citeproc.1.gz"
+ rm -R "${pkgdir}/usr/share/doc/pandoc-citeproc"
+
+ # We're still missing all the datafiles and so on. We get those from the source tarball...
+ cd "pandoc-${pkgver}"
+ mkdir -p "${pkgdir}/usr/share/pandoc/"
+
+ cp -R data "${pkgdir}/usr/share/pandoc/"
+ cp COPYRIGHT "${pkgdir}/usr/share/pandoc/COPYRIGHT"
+ cp MANUAL.txt "${pkgdir}/usr/share/pandoc/MANUAL.txt"
+}