summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrank Seifferth2019-11-17 13:28:47 +0000
committerFrank Seifferth2019-11-17 13:28:47 +0000
commitad434544475a7d28f7b5b01448bce723e849a176 (patch)
tree14d56cd1f77fb5c84d981a8030cc114b24e4df54
downloadaur-pandoc-manpage.tar.gz
Initial commit
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD19
2 files changed, 31 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b7aa4872eeac
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = pandoc-manpage
+ pkgdesc = A temporary solution for getting the manpage while the missing manpage bug persists in the official package
+ pkgver = 2.7.3
+ pkgrel = 1
+ url = https://pandoc.org
+ arch = any
+ license = GPL2
+ source = https://raw.githubusercontent.com/jgm/pandoc/2.7.3/man/pandoc.1
+ md5sums = c0f56df3283f8ec8b8caf166125c50e0
+
+pkgname = pandoc-manpage
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..097224a1fb5e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Frank Seifferth <frankseifferth@posteo.net>
+pkgname=pandoc-manpage
+pkgver=2.7.3
+pkgrel=1
+pkgdesc="A temporary solution for getting the manpage while the missing manpage bug persists in the official package"
+arch=('any')
+url="https://pandoc.org"
+license=('GPL2')
+source=("https://raw.githubusercontent.com/jgm/pandoc/$pkgver/man/pandoc.1")
+md5sums=('c0f56df3283f8ec8b8caf166125c50e0')
+
+build() {
+ cd "$srcdir/"
+ cat "pandoc.1" | gzip > "pandoc.1.gz"
+}
+
+package() {
+ install -Dm 644 "$srcdir/pandoc.1.gz" "$pkgdir/usr/share/man/man1/pandoc.1.gz"
+}