summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgesh2021-03-03 21:08:44 +0200
committergesh2021-10-28 00:32:55 +0300
commit085eafbc8bb6327c5b249a2c9a71946c530fca34 (patch)
tree1e344560429920c6ec739398bc0eff975866e575
downloadaur-085eafbc8bb6327c5b249a2c9a71946c530fca34.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--.gitattributes1
-rw-r--r--PKGBUILD51
3 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ff9b06bac165
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = pandoc-static-git
+ pkgdesc = Conversion between markup formats (static build, dynamic Lua support)
+ pkgver = 2.11.4.r33.gb79aba6ea
+ pkgrel = 1
+ url = https://pandoc.org
+ arch = x86_64
+ license = GPL
+ makedepends = stack>=1.7.0
+ optdepends = pandoc-citeproc: for citation rendering with pandoc-citeproc filter
+ optdepends = texlive-core: for pdf output
+ provides = pandoc=2.11.4
+ conflicts = haskell-pandoc
+ conflicts = pandoc
+ conflicts = pandoc-bin
+ replaces = haskell-pandoc
+ replaces = pandoc
+ replaces = pandoc-bin
+ source = git+https://github.com/jgm/pandoc.git
+ sha512sums = SKIP
+
+pkgname = pandoc-static-git
diff --git a/.gitattributes b/.gitattributes
new file mode 100644
index 000000000000..a4dab8edd10c
--- /dev/null
+++ b/.gitattributes
@@ -0,0 +1 @@
+.SRCINFO binary
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fd5927f695fd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Gesh <gesh@gesh.uni.cx>
+# based on pandoc-sile-git, by
+# Contributor: Caleb Maclennan <caleb@alerque.com>
+# Contributor: Felix Yan <felixonmars@archlinux.org>
+# Contributor: Arch Haskell Team <arch-haskell@haskell.org>
+
+pkgname=pandoc-static-git
+_pkgname="${pkgname%-static-git}"
+pkgver=2.11.4.r33.gb79aba6ea
+pkgrel=1
+pkgdesc='Conversion between markup formats (static build, dynamic Lua support)'
+url='https://pandoc.org'
+license=('GPL')
+arch=('x86_64')
+optdepends=('pandoc-citeproc: for citation rendering with pandoc-citeproc filter'
+ 'texlive-core: for pdf output')
+conflicts=('haskell-pandoc' 'pandoc' 'pandoc-bin')
+replaces=('haskell-pandoc' 'pandoc' 'pandoc-bin')
+provides=("pandoc=${pkgver%.r*}")
+makedepends=('stack>=1.7.0')
+source=("git+https://github.com/jgm/pandoc.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --tags --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+# prepare() {
+# cd "$_pkgname"
+# # TODO: find a better solution
+# sed -i "s|let env' = dynlibEnv ++ |let env' = dynlibEnv ++ [(\"LD_LIBRARY_PATH\", \"$PWD/dist/build\")] ++ |" test/Tests/Command.hs
+# }
+
+build() {
+ cd "$_pkgname"
+
+ stack setup
+ stack build \
+ --install-ghc \
+ --ghc-options='-fdiagnostics-color=always' \
+ --flag 'pandoc:embed_data_files' \
+ --fast
+}
+
+package() {
+ cd "$_pkgname"
+ find ./ -path '*/dist/*' -type f -name pandoc -perm /u+x \
+ -execdir install -Dm755 -t "$pkgdir/usr/bin/" {} \;
+ install -Dm644 man/pandoc.1 "${pkgdir}"/usr/share/man/man1/pandoc.1
+}