summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgesh2021-11-29 00:21:48 +0200
committergesh2021-11-29 00:21:48 +0200
commit1bbeaef63b1fc8a808d8f5e107f6306099d8da84 (patch)
tree6fc56c6ef14050c82934ef03ca2758cf3a6f1ba6
parent1c3d50eec66c0590d7b9db22b84205028a300149 (diff)
downloadaur-1bbeaef63b1fc8a808d8f5e107f6306099d8da84.tar.gz
Fix lower bounds on pandoc-lua-marshal
Commits 3692a1d..c5287e9 introduce a dependency on pandoc-lua-marshal 0.1.0.1 However, this bound change was only reflected in stack.yaml, not pandoc.cabal For some reason stack.yaml isn't picked up by `stack build`, so this breaks the build Reported upstream as https://github.com/jgm/pandoc/issues/7721
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
-rw-r--r--ver-bump.patch13
3 files changed, 27 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ae4a0f25744c..4c32fa9bcbb1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = pandoc-static-git
pkgdesc = Conversion between markup formats (static build, dynamic Lua support)
- pkgver = 2.14rc.r12.g54ab7a0a3
+ pkgver = 2.16.2.r18.gc5287e9de
pkgrel = 1
url = https://pandoc.org
arch = x86_64
@@ -8,7 +8,7 @@ pkgbase = pandoc-static-git
makedepends = stack>=1.7.0
optdepends = pandoc-citeproc: for citation rendering with pandoc-citeproc filter
optdepends = texlive-core: for pdf output
- provides = pandoc=2.14
+ provides = pandoc=2.16.2
conflicts = haskell-pandoc
conflicts = pandoc
conflicts = pandoc-bin
@@ -16,6 +16,8 @@ pkgbase = pandoc-static-git
replaces = pandoc
replaces = pandoc-bin
source = git+https://github.com/jgm/pandoc.git
+ source = ver-bump.patch
sha512sums = SKIP
+ sha512sums = 7593c460253fdfa958ce48b79dcef2a781c18fffb5aad31628b27042dc59b4b57ef42e2a21c5069de74eda485bd1ed8b4e2d81ed995cc31fee0b97879598cb76
pkgname = pandoc-static-git
diff --git a/PKGBUILD b/PKGBUILD
index eb22dc4d39b3..640a213b5eab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ shopt -s extglob
pkgname=pandoc-static-git
_pkgname="${pkgname%-static-git}"
-pkgver=2.14rc.r12.g54ab7a0a3
+pkgver=2.16.2.r18.gc5287e9de
pkgrel=1
pkgdesc='Conversion between markup formats (static build, dynamic Lua support)'
url='https://pandoc.org'
@@ -20,8 +20,9 @@ conflicts=('haskell-pandoc' 'pandoc' 'pandoc-bin')
replaces=('haskell-pandoc' 'pandoc' 'pandoc-bin')
provides=("pandoc=${pkgver%%*([a-z]).r*}")
makedepends=('stack>=1.7.0')
-source=("git+https://github.com/jgm/pandoc.git")
-sha512sums=('SKIP')
+source=("git+https://github.com/jgm/pandoc.git" ver-bump.patch)
+sha512sums=('SKIP'
+ '7593c460253fdfa958ce48b79dcef2a781c18fffb5aad31628b27042dc59b4b57ef42e2a21c5069de74eda485bd1ed8b4e2d81ed995cc31fee0b97879598cb76')
pkgver() {
cd "$_pkgname"
@@ -37,6 +38,12 @@ pkgver() {
# sed -i "s|let env' = dynlibEnv ++ |let env' = dynlibEnv ++ [(\"LD_LIBRARY_PATH\", \"$PWD/dist/build\")] ++ |" test/Tests/Command.hs
# }
+prepare() {
+ cd "$_pkgname"
+ patch --forward --strip=1 --input="${srcdir}/ver-bump.patch"
+}
+
+
build() {
cd "$_pkgname"
diff --git a/ver-bump.patch b/ver-bump.patch
new file mode 100644
index 000000000000..f1ef21de6208
--- /dev/null
+++ b/ver-bump.patch
@@ -0,0 +1,13 @@
+diff --git a/pandoc.cabal b/pandoc.cabal
+index e7d1349fc..42e28d086 100644
+--- a/pandoc.cabal
++++ b/pandoc.cabal
+@@ -477,7 +477,7 @@ library
+ mtl >= 2.2 && < 2.3,
+ network >= 2.6,
+ network-uri >= 2.6 && < 2.8,
+- pandoc-lua-marshal >= 0.1 && < 0.2,
++ pandoc-lua-marshal >= 0.1.0.1 && < 0.2,
+ pandoc-types >= 1.22.1 && < 1.23,
+ parsec >= 3.1 && < 3.2,
+ pretty >= 1.1 && < 1.2,