summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorQue Quotion2015-10-24 02:38:03 +0900
committerQue Quotion2015-10-24 02:38:03 +0900
commit915b5f5e39f8f5de419a039d23f040add7834cac (patch)
tree9ae9043a56888171f4d973e201e93891a1e3a61b
downloadaur-915b5f5e39f8f5de419a039d23f040add7834cac.tar.gz
Pantheon-3d: replaces Gala with Compiz
-rw-r--r--.SRCINFO34
-rw-r--r--.gitignore54
-rw-r--r--PKGBUILD33
-rw-r--r--pantheon-compiz.desktop7
-rw-r--r--pantheon-compiz.session5
5 files changed, 133 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..22114e239b33
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,34 @@
+pkgbase = pantheon-3d
+ pkgdesc = Pantheon 3d Session (replaces Gala with Compiz)
+ pkgver = 2
+ pkgrel = 4
+ url = https://bbs.archlinux.org/viewtopic.php?pid=1401967#p1401967
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = dconf
+ depends = compiz
+ depends = pantheon-workarounds
+ depends = gnome-settings-daemon
+ depends = gnome-settings-daemon-compat
+ depends = gnome-session
+ depends = plank
+ depends = cerbere
+ depends = wingpanel-bzr
+ optdepends = indicator-powersave: On the fly power savings and performance toggles
+ optdepends = wingpanel-indicator-ayatana-bzr: Tray applet
+ optdepends = wingpanel-indicator-bluetooth-bzr: Tray applet
+ optdepends = wingpanel-indicator-datetime-bzr: Tray applet
+ optdepends = wingpanel-indicator-network-bzr: Tray applet
+ optdepends = wingpanel-indicator-power-bzr: Tray applet
+ optdepends = wingpanel-indicator-slingshot-bzr: Tray applet
+ optdepends = wingpanel-indicator-sound-bzr: Tray applet
+ optdepends = xscreensaver-dbus-screenlock: xscreensaver locker for gnome-derivative desktops
+ provides = pantheon-3d
+ source = pantheon-compiz.desktop
+ source = pantheon-compiz.session
+ sha512sums = 18d3e1280c315014645e1f2ecf3bc5667e18fb718a83f46a6209b7d7b0fe407f69f23a567f67cddb0cb3dea8a8a99365529814d8093169b57ec308334bec10de
+ sha512sums = 8eda0a25ee90eabc7262e7f57d764457d651225ed841d5b1235b4792da5421132599e0b58eb41db7e8546a23791785c9a68f3b9860891d37ee5443daed4f17a3
+
+pkgname = pantheon-3d
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e08ca2112f65
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,54 @@
+# Compiled source #
+###################
+*.com
+*.class
+*.dll
+*.exe
+*.o
+*.so
+
+# Packages #
+############
+# it's better to unpack these files and commit the raw source
+# git has its own built in compression methods
+*.7z
+*.dmg
+*.gz
+*.iso
+*.jar
+*.rar
+*.tar
+*.zip
+*.xz
+
+# Archlinux Packaging #
+#######################
+*.tar
+*.tar.*
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+pkg/
+src/
+
+# Logs and databases #
+######################
+*.log
+*.sql
+*.sqlite
+
+# OS generated files #
+######################
+.DS_Store
+.DS_Store?
+._*
+.Spotlight-V100
+.Trashes
+ehthumbs.db
+Thumbs.db
+*~
+
+# Particulars #
+###############
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1ef6e8edc889
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Que Quotion <quequotion@bugmenot.org>
+# Contributor: Maxime Gauduin <alucryd@archlinux.org>
+# Contributor: Ner0 <darkelfdarkelf666@yahoo.co.uk>
+
+pkgname=pantheon-3d
+pkgver=2
+pkgrel=4
+pkgdesc='Pantheon 3d Session (replaces Gala with Compiz)'
+arch=('i686' 'x86_64')
+url='https://bbs.archlinux.org/viewtopic.php?pid=1401967#p1401967'
+license=('GPL3')
+depends=('dconf' 'compiz' 'pantheon-workarounds'
+ gnome-{settings-daemon{,-compat},session}
+ 'plank' 'cerbere' 'wingpanel-bzr')
+optdepends=("indicator-powersave: On the fly power savings and performance toggles"
+ wingpanel-indicator-{ayatana,bluetooth,datetime,network,power,slingshot,sound}-bzr": Tray applet"
+ "xscreensaver-dbus-screenlock: xscreensaver locker for gnome-derivative desktops")
+provides=("pantheon-3d")
+conflicts=()
+source=(pantheon-compiz.{desktop,session})
+sha512sums=('18d3e1280c315014645e1f2ecf3bc5667e18fb718a83f46a6209b7d7b0fe407f69f23a567f67cddb0cb3dea8a8a99365529814d8093169b57ec308334bec10de'
+ '8eda0a25ee90eabc7262e7f57d764457d651225ed841d5b1235b4792da5421132599e0b58eb41db7e8546a23791785c9a68f3b9860891d37ee5443daed4f17a3')
+
+package() {
+ install -Dm655 {,"${pkgdir}"/usr/share/xsessions/}pantheon-compiz.desktop
+ install -Dm655 {,"${pkgdir}"/usr/share/gnome-session/sessions/}pantheon-compiz.session
+ # If you were prevously using compiz, check your configuration!
+ #[[ -f "${HOME}"/.config/compiz-1/compizconfig/config ]] && \
+ # cp "${HOME}"/.config/compiz-1/compizconfig/config{,.bak}
+ #[[ -n "$(cat "${HOME}"/.config/compiz-1/compizconfig/config | grep backend)" ]] && \
+ # sed -i 's|backend = ini|backend = gsettings|g' "${HOME}"/.config/compiz-1/compizconfig/config
+}
+
diff --git a/pantheon-compiz.desktop b/pantheon-compiz.desktop
new file mode 100644
index 000000000000..3200c505acdf
--- /dev/null
+++ b/pantheon-compiz.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Name=Pantheon 3D
+Comment=This session provides elementary-3d experience
+Exec=/usr/bin/pantheon-session 3d
+TryExec=compiz
+Icon=/usr/share/compiz/icon.png
+Type=Application
diff --git a/pantheon-compiz.session b/pantheon-compiz.session
new file mode 100644
index 000000000000..5b7f5df6d8ef
--- /dev/null
+++ b/pantheon-compiz.session
@@ -0,0 +1,5 @@
+[GNOME Session]
+Name=Pantheon
+RequiredComponents=compiz;
+FallbackSession=gnome-shell
+DesktopNames=Pantheon