summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBinary variant maintainer, see PKGBUILD2020-03-20 15:12:26 +0000
committerBinary variant maintainer, see PKGBUILD2020-03-20 15:12:26 +0000
commit4b95bb096f187659518397753d36d6ec46af360f (patch)
tree420e2be6cb091f65030e1ab5ca02d4421d70e692
parent7bd1f059a95012c9a143cc232d6b65cbb6dfd1a8 (diff)
downloadaur-pantum-p2000-driver.tar.gz
Remove explicit, not useful, unzip line at build()
makepkg implicitly unzip the source anyway. Minor other modifications to build() function.
-rw-r--r--PKGBUILD11
1 files changed, 3 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6f0a69b561c1..417c607f7316 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,15 +17,10 @@ md5sums=('0024556a55eacef3d63ed4478ea1490d')
build() {
cd $srcdir
-
- unzip Pantum-P2000-Series-Linux-DriverUbutun12.04V1.00-1.zip
- # rename unzipped directory, otherwise bsdtar is sad
- mv ' Pantum 2000 Series Linux Driver (Ubutun12.04) V1.00' Pantum-P2000-Series-Linux-DriverUbutun12.04V1.00-1
-
mkdir -p ${pkgname}-${pkgver}
- cd ./${pkgname}-${pkgver}
-
- bsdtar -xf "../Pantum-P2000-Series-Linux-DriverUbutun12.04V1.00-1/Pantum-0.3-1.${arch}.rpm"
+ bsdtar -xf \
+ " Pantum 2000 Series Linux Driver (Ubutun12.04) V1.00/Pantum-0.3-1.${arch}.rpm" \
+ -C ${pkgname}-${pkgver}
}
package() {