summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlisson Lauffer2023-06-09 00:06:25 -0300
committerAlisson Lauffer2023-06-09 00:06:25 -0300
commit95a32a2267124a2e0229acebba701b571ef2eca3 (patch)
tree69732a6fce98817ae07ccee4d684bb2cbf311199
parent2fe782a079f2b450a5f9bf340e20518647537286 (diff)
downloadaur-95a32a2267124a2e0229acebba701b571ef2eca3.tar.gz
Add a crash fix for unstable gtk4
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD12
2 files changed, 12 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7c0f1a367f17..964f3975c756 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -21,6 +21,8 @@ pkgbase = paper-plane-git
provides = paper-plane
conflicts = paper-plane
source = git+https://github.com/paper-plane-developers/paper-plane.git
+ source = unstable-gtk-crash-fix.patch::https://github.com/paper-plane-developers/paper-plane/commit/dee19785c1e6a79b07f3984080f7ce18ccdfd74c.patch
sha256sums = SKIP
+ sha256sums = 10f8b9d8956d1bf44e227d99e5f9b7562c488ac4e8ace22103e9718b1100f7e9
pkgname = paper-plane-git
diff --git a/PKGBUILD b/PKGBUILD
index bb6faf7f315a..24473fdc990d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,8 +13,16 @@ makedepends=(git meson rust blueprint-compiler appstream)
provides=(paper-plane)
conflicts=(paper-plane)
-source=("git+$url.git")
-sha256sums=('SKIP')
+source=("git+$url.git"
+ "unstable-gtk-crash-fix.patch::$url/commit/dee19785c1e6a79b07f3984080f7ce18ccdfd74c.patch")
+sha256sums=('SKIP'
+ '10f8b9d8956d1bf44e227d99e5f9b7562c488ac4e8ace22103e9718b1100f7e9')
+
+prepare() {
+ cd "$_pkgname"
+
+ patch --forward --strip=1 --input="$srcdir/unstable-gtk-crash-fix.patch"
+}
pkgver() {
cd "$_pkgname"