summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCong Gu2017-10-02 18:41:03 -0500
committerCong Gu2017-10-02 18:41:03 -0500
commit0389514cafa2f565944437d33dacc278007057d9 (patch)
tree59785994dd688d94e4aad9d65f25559027450880
parent29433e1c763d9a2ebf333d0a1a77e77e9d408ce6 (diff)
downloadaur-paraview-manta.tar.gz
update 5.4.1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD15
-rw-r--r--visit_fix_gcc7.patch43
3 files changed, 60 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 870c45a92474..cf4002a31518 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sat Jul 8 00:02:50 UTC 2017
+# Mon Oct 2 23:40:32 UTC 2017
pkgbase = paraview-manta
pkgdesc = Parallel Visualization Application using VTK (with MantaView plugin, Qt4, legacy OpenGL)
- pkgver = 5.4.0
- pkgrel = 2
+ pkgver = 5.4.1
+ pkgrel = 1
url = http://www.paraview.org
arch = i686
arch = x86_64
@@ -35,8 +35,10 @@ pkgbase = paraview-manta
depends = lz4
provides = paraview
conflicts = paraview
- source = ParaView-v5.4.0.tar.gz::http://paraview.org/files/v5.4/ParaView-v5.4.0.tar.gz
- sha1sums = d1bc9112d76f603d3232069b4ea9c507c4e1b1a7
+ source = http://paraview.org/files/v5.4/ParaView-v5.4.1.tar.gz
+ source = visit_fix_gcc7.patch
+ sha1sums = 3b7df6f6bbf978bb9a8583c97208a58af9afcdde
+ sha1sums = f86feb14e7e17ce3ad5341ee4f52b40111cecbec
pkgname = paraview-manta
diff --git a/PKGBUILD b/PKGBUILD
index 7aec98f9b61f..a01730e595bd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,9 +10,9 @@
# Contributor: chuckdaniels
pkgname=paraview-manta
-_pkgver=5.4.0
+_pkgver=5.4.1
pkgver=${_pkgver//-/.}
-pkgrel=2
+pkgrel=1
pkgdesc='Parallel Visualization Application using VTK (with MantaView plugin, Qt4, legacy OpenGL)'
arch=('i686' 'x86_64')
url='http://www.paraview.org'
@@ -26,14 +26,19 @@ depends=('qt4'
makedepends=('cmake' 'mesa' 'gcc-fortran' 'ninja')
conflicts=('paraview')
provides=('paraview')
-source=("ParaView-v${_pkgver}.tar.gz::http://paraview.org/files/v${pkgver:0:3}/ParaView-v${_pkgver}.tar.gz")
-sha1sums=('d1bc9112d76f603d3232069b4ea9c507c4e1b1a7')
+source=("http://paraview.org/files/v${pkgver:0:3}/ParaView-v${_pkgver}.tar.gz"
+ "visit_fix_gcc7.patch")
+sha1sums=('3b7df6f6bbf978bb9a8583c97208a58af9afcdde'
+ 'f86feb14e7e17ce3ad5341ee4f52b40111cecbec')
prepare() {
cd "${srcdir}/ParaView-v${_pkgver}"
rm -rf "${srcdir}/build"
mkdir -p "${srcdir}/build"
+
+ patch Utilities/VisItBridge/databases/readers/Vs/VsStaggeredField.C \
+ "${srcdir}/visit_fix_gcc7.patch"
}
build() {
@@ -62,7 +67,7 @@ build() {
-DPARAVIEW_INSTALL_DEVELOPMENT_FILES:BOOL=ON \
-DPARAVIEW_QT_VERSION:STRING=4 \
-DPARAVIEW_USE_MPI:BOOL=ON \
- -DPARAVIEW_USE_VISITBRIDGE:BOOL=OFF \
+ -DPARAVIEW_USE_VISITBRIDGE:BOOL=ON \
-DPARAVIEW_USE_OSPRAY:BOOL=ON \
-DVISIT_BUILD_READER_CGNS:BOOL=ON \
-DVTK_PYTHON_FULL_THREADSAFE:BOOL=ON \
diff --git a/visit_fix_gcc7.patch b/visit_fix_gcc7.patch
new file mode 100644
index 000000000000..f9c3a518ffe7
--- /dev/null
+++ b/visit_fix_gcc7.patch
@@ -0,0 +1,43 @@
+------------------------------------------------------------------------
+r31082 | whitlocb | 2017-06-16 00:19:15 +0200 (Fri, 16 Jun 2017) | 1 line
+
+Fix for GCC 7
+
+Index: databases/Vs/VsStaggeredField.C
+===================================================================
+--- databases/Vs/VsStaggeredField.C (revision 31081)
++++ databases/Vs/VsStaggeredField.C (revision 31082)
+@@ -26,10 +26,13 @@
+ this->indexOrder = VsSchema::compMajorCKey;
+ this->centering = VsSchema::nodalCenteringKey;
+
++#if 0
++ // There is no clear method under GCC 7. What good would it do here anyway?
+ this->oriCellDims.clear();
+ this->oriCellDimProd.clear();
+ this->newCellDims.clear();
+ this->newCellDimProd.clear();
++#endif
+ }
+
+ template<class TYPE>
+@@ -136,7 +139,7 @@
+ // iterate over subgrid
+ for (size_t subBigIndx = 0; subBigIndx < this->numNeighbors; ++subBigIndx) {
+ std::valarray<int> subCellInds = this->getSubCellIndexSet(subBigIndx);
+- std::valarray<int> newCellInds = oriCellInds*this->numNeighbors + subCellInds;
++ std::valarray<int> newCellInds = oriCellInds*static_cast<TYPE>(this->numNeighbors) + subCellInds;
+ size_t newBigIndx = this->getNewBigIndex(newCellInds);
+ std::valarray<TYPE> xi = std::valarray<TYPE>(subCellInds) / this->twoPowSubRes;
+ this->setNewFieldVals(newBigIndx, xi, sigmaVals, neighVals, dataPtr);
+@@ -147,7 +150,7 @@
+ template <class TYPE>
+ std::valarray<int>
+ VsStaggeredField<TYPE>::getOriCellIndexSet(size_t bigIndex) const {
+- return (bigIndex / this->oriCellDimProd) % this->oriCellDims;
++ return (bigIndex / static_cast<TYPE>(this->oriCellDimProd)) % this->oriCellDims;
+ }
+
+ template <class TYPE>
+
+------------------------------------------------------------------------