summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichele Mocciola2017-12-02 15:40:22 +0100
committerMichele Mocciola2017-12-02 15:40:22 +0100
commit2301b438268fed0ef2c8e8b81563d03a5f6f15d0 (patch)
tree5e7301e660988f2e1d8c1f9116064f146c1d3c5f
parent99c2d96c2bfcfe86dac11a49d23a990497bf1cc7 (diff)
downloadaur-paraview-salome.tar.gz
Updated
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD49
-rw-r--r--ffmpeg3.patch61
3 files changed, 34 insertions, 94 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aae2e77a1a77..3c052a7ea1ae 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Tue Dec 20 06:30:17 UTC 2016
+# Sat Dec 2 14:39:59 UTC 2017
pkgbase = paraview-salome
pkgdesc = Parallel Visualization Application using VTK - This version is built to be linked against salome modules
- pkgver = 5.0.1p1
- pkgrel = 2
+ pkgver = 5.1.2plus
+ pkgrel = 1
url = http://www.paraview.org
arch = i686
arch = x86_64
@@ -12,7 +12,6 @@ pkgbase = paraview-salome
makedepends = mesa
makedepends = eigen3
makedepends = doxygen
- depends = qtwebkit
depends = python2
depends = ffmpeg
depends = boost
@@ -28,18 +27,19 @@ pkgbase = paraview-salome
depends = protobuf
depends = openmpi
depends = gl2ps
+ depends = qt5-x11extras
+ depends = qt5-tools
optdepends = python2-matplotlib: Needed to support equation rendering using MathText markup language
optdepends = python2-numpy: Needed for using some filters such as "Python Calculator"
- provides = paraview=5.0.1
+ provides = paraview=5.1.2
+ conflicts = icet
options = staticlibs
- source = http://files.salome-platform.org/Salome/Salome7.8.0/SALOME-7.8.0-OPENSOURCE-DB08.tgz
+ source = http://files.salome-platform.org/Salome/Salome8.3.0/SALOME-8.3.0-DB08.tgz
source = paraview-salome.png
source = paraview-salome.desktop
- source = ffmpeg3.patch
- md5sums = 53c07c80009555d1ffc5e0bf13cfbf20
+ md5sums = 0d355acf763aa054e064b2495579ae8c
md5sums = db623002bc71a257ddfdd0c9c7b14c3f
md5sums = e3ba22be644f91da7018f429c3b7dd39
- md5sums = ec32574de308796bc8086a896eb8c2f9
pkgname = paraview-salome
diff --git a/PKGBUILD b/PKGBUILD
index a0970f49090f..c959e11250a3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,19 +5,21 @@
# Contributor: Simon Zilliken <simon____AT____zilliken____DOT____name>
pkgname=paraview-salome
-pkgver=5.0.1p1
-_salomever=7.8.0
-pkgrel=2
+pkgver=5.1.2plus
+_salomever=8.3.0
+_salomepkg=DB08
+pkgrel=1
pkgdesc='Parallel Visualization Application using VTK - This version is built to be linked against salome modules'
arch=('i686' 'x86_64')
url='http://www.paraview.org'
license=('custom')
-depends=('qtwebkit' 'python2' 'ffmpeg' 'boost' 'expat' 'freetype2' 'hdf5-salome' 'libjpeg' 'libxml2' 'libtheora' 'libpng' 'libtiff' 'zlib' 'protobuf' 'openmpi' 'gl2ps')
+depends=('python2' 'ffmpeg' 'boost' 'expat' 'freetype2' 'hdf5-salome' 'libjpeg' 'libxml2' 'libtheora' 'libpng' 'libtiff' 'zlib' 'protobuf' 'openmpi' 'gl2ps' 'qt5-x11extras' 'qt5-tools')
makedepends=('cmake' 'mesa' 'eigen3' 'doxygen')
optdepends=('python2-matplotlib: Needed to support equation rendering using MathText markup language' 'python2-numpy: Needed for using some filters such as "Python Calculator"')
-source=("http://files.salome-platform.org/Salome/Salome${_salomever}/SALOME-${_salomever}-OPENSOURCE-DB08.tgz"
- "${pkgname}.png" "${pkgname}.desktop"
- "ffmpeg3.patch" )
+source=("http://files.salome-platform.org/Salome/Salome${_salomever}/SALOME-${_salomever}-${_salomepkg}.tgz"
+ "${pkgname}.png" "${pkgname}.desktop" )
+provides=("icet")
+conflicts=("icet")
options=(staticlibs)
provides=("paraview=${pkgver:0:5}")
@@ -32,10 +34,7 @@ prepare(){
rm -rf build
fi
- bsdtar -xf "${srcdir}/SALOME-${_salomever}-OPENSOURCE-DB08/PREREQUISITES/SOURCES/ParaView-5.0.1p1.tar.gz"
-
- cd "${srcdir}/ParaView-${pkgver}"
- patch -Np1 -i ../ffmpeg3.patch
+ bsdtar -xf "${srcdir}/SALOME-${_salomever}-${_salomepkg}/ARCHIVES/ParaView-${pkgver}.tar.gz"
}
build() {
@@ -56,7 +55,7 @@ build() {
cmake_options+=" -DBUILD_TESTING:BOOL=OFF"
cmake_options+=" -DBUILD_EXAMPLES:BOOL=OFF"
cmake_options+=" -DBUILD_DOCUMENTATION:BOOL=OFF"
- cmake_options+=" -DDOCUMENTATION_HTML_HELP:BOOL=ON"
+ # cmake_options+=" -DDOCUMENTATION_HTML_HELP:BOOL=ON"
# verbose mode
cmake_options+=" -DCMAKE_VERBOSE_MAKEFILE:BOOL=OFF"
@@ -85,7 +84,10 @@ build() {
# activating VTK_RENDERING_BACKEND=OpenGL2, gl2ps on archlinux repository is
# too old; you must use gl2ps on the package (change to OFF following option)
cmake_options+=" -DVTK_USE_SYSTEM_GL2PS:BOOL=ON"
-
+
+# cmake_options+=" -DVTK_USE_SYSTEM_ICET:BOOL=ON"
+# cmake_options+=" -Dicet_DIR:STRING=/usr/lib"
+
### OpenMP to speed computation of some filters
# https://blog.kitware.com/simple-parallel-computing-with-vtksmptools-2/
# https://blog.kitware.com/accelerated-filters-in-paraview-5/
@@ -93,10 +95,10 @@ build() {
# Qt settings
cmake_options+=" -DPARAVIEW_BUILD_QT_GUI:BOOL=ON"
- cmake_options+=" -DPARAVIEW_QT_VERSION=4"
- cmake_options+=" -DVTK_QT_VERSION=4"
- cmake_options+=" -DQT_HELP_GENERATOR:STRING=/usr/bin/qhelpgenerator-qt4"
- cmake_options+=" -DQT_QMAKE_EXECUTABLE=/usr/bin/qmake-qt4"
+ cmake_options+=" -DPARAVIEW_QT_VERSION=5"
+ cmake_options+=" -DVTK_QT_VERSION=5"
+ cmake_options+=" -DQT_HELP_GENERATOR:STRING=/usr/bin/qhelpgenerator-qt5"
+ cmake_options+=" -DQT_QMAKE_EXECUTABLE=/usr/bin/qmake-qt5"
# Python settings
cmake_options+=" -DPARAVIEW_ENABLE_PYTHON:BOOL=ON"
@@ -128,7 +130,7 @@ build() {
cmake_options+=" -DHDF5_INCLUDE_DIRS:PATH=/usr/include/hdf5_18/"
cmake_options+=" -DHDF5_C_COMPILER_EXECUTABLE:FILEPATH=/usr/bin/h5cc_18"
cmake_options+=" -DHDF5_C_LIBRARY_hdf5:FILEPATH=/usr/lib/hdf5_18/libhdf5.so"
- cmake_options+=" -DHDF5_CXX_LIBRARY_hdf5:FILEPATH=/usr/lib/hdf5_18/libhdf5.so"
+ # cmake_options+=" -DHDF5_CXX_LIBRARY_hdf5:FILEPATH=/usr/lib/hdf5_18/libhdf5.so"
cmake_options+=" -DHDF5_C_LIBRARY_hdf5_hl:FILEPATH=/usr/lib/hdf5_18/libhdf5_hl.so"
cmake_options+=" -DHDF5_DIFF_EXECUTABLE:FILEPATH=/usr/bin/h5diff_18"
@@ -157,9 +159,9 @@ build() {
cmake_options+=" -DFREETYPE_LIBRARY:STRING=/usr/lib/libfreetype.so"
# Extra options since OCC presta to improve Paraview for Salome
- cmake_options+=" -DPARAVIEW_USE_3DGLYPH:BOOL=OFF"
- cmake_options+=" -DPARAVIEW_USE_EXTENDED_OPENFILEDIALOG:BOOL=ON"
- cmake_options+=" -DPARAVIEW_USE_TIMECONTROL_SLIDER:BOOL=ON"
+ # cmake_options+=" -DPARAVIEW_USE_3DGLYPH:BOOL=OFF"
+ # cmake_options+=" -DPARAVIEW_USE_EXTENDED_OPENFILEDIALOG:BOOL=ON"
+ # cmake_options+=" -DPARAVIEW_USE_TIMECONTROL_SLIDER:BOOL=ON"
# Extra options (switch off non-used Paraview plug-ins)
cmake_options+=" -DPARAVIEW_BUILD_PLUGIN_Moments:BOOL=OFF"
@@ -216,7 +218,6 @@ package() {
install -Dm644 "${srcdir}/${pkgname}.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
desktop-file-install --dir="${pkgdir}/usr/share/applications" "${srcdir}/${pkgname}.desktop"
}
-md5sums=('53c07c80009555d1ffc5e0bf13cfbf20'
+md5sums=('0d355acf763aa054e064b2495579ae8c'
'db623002bc71a257ddfdd0c9c7b14c3f'
- 'e3ba22be644f91da7018f429c3b7dd39'
- 'ec32574de308796bc8086a896eb8c2f9')
+ 'e3ba22be644f91da7018f429c3b7dd39')
diff --git a/ffmpeg3.patch b/ffmpeg3.patch
deleted file mode 100644
index b5a2cb940141..000000000000
--- a/ffmpeg3.patch
+++ /dev/null
@@ -1,61 +0,0 @@
-diff -Naur ParaView-5.0.1p1.orig/VTK/IO/FFMPEG/vtkFFMPEGWriter.cxx ParaView-5.0.1p1/VTK/IO/FFMPEG/vtkFFMPEGWriter.cxx
---- ParaView-5.0.1p1.orig/VTK/IO/FFMPEG/vtkFFMPEGWriter.cxx 2016-11-19 23:17:56.596094663 +0100
-+++ ParaView-5.0.1p1/VTK/IO/FFMPEG/vtkFFMPEGWriter.cxx 2016-11-19 23:18:17.099178065 +0100
-@@ -191,11 +191,11 @@
- c->height = this->Dim[1];
- if (this->Writer->GetCompression())
- {
-- c->pix_fmt = PIX_FMT_YUVJ422P;
-+ c->pix_fmt = AV_PIX_FMT_YUVJ422P;
- }
- else
- {
-- c->pix_fmt = PIX_FMT_BGR24;
-+ c->pix_fmt = AV_PIX_FMT_BGR24;
- }
-
- //to do playback at actual recorded rate, this will need more work see also below
-@@ -274,13 +274,13 @@
- #endif
-
- //for the output of the writer's input...
-- this->rgbInput = avcodec_alloc_frame();
-+ this->rgbInput = av_frame_alloc();
- if (!this->rgbInput)
- {
- vtkGenericWarningMacro (<< "Could not make rgbInput avframe." );
- return 0;
- }
-- int RGBsize = avpicture_get_size(PIX_FMT_RGB24, c->width, c->height);
-+ int RGBsize = avpicture_get_size(AV_PIX_FMT_RGB24, c->width, c->height);
- unsigned char *rgb = (unsigned char *)av_malloc(sizeof(unsigned char) * RGBsize);
- if (!rgb)
- {
-@@ -288,10 +288,10 @@
- return 0;
- }
- //The rgb buffer should get deleted when this->rgbInput is.
-- avpicture_fill((AVPicture *)this->rgbInput, rgb, PIX_FMT_RGB24, c->width, c->height);
-+ avpicture_fill((AVPicture *)this->rgbInput, rgb, AV_PIX_FMT_RGB24, c->width, c->height);
-
- //and for the output to the codec's input.
-- this->yuvOutput = avcodec_alloc_frame();
-+ this->yuvOutput = av_frame_alloc();
- if (!this->yuvOutput)
- {
- vtkGenericWarningMacro (<< "Could not make yuvOutput avframe." );
-@@ -349,12 +349,12 @@
- //convert that to YUV for input to the codec
- #ifdef VTK_FFMPEG_HAS_IMG_CONVERT
- img_convert((AVPicture *)this->yuvOutput, cc->pix_fmt,
-- (AVPicture *)this->rgbInput, PIX_FMT_RGB24,
-+ (AVPicture *)this->rgbInput, AV_PIX_FMT_RGB24,
- cc->width, cc->height);
- #else
- //convert that to YUV for input to the codec
- SwsContext* convert_ctx = sws_getContext(
-- cc->width, cc->height, PIX_FMT_RGB24,
-+ cc->width, cc->height, AV_PIX_FMT_RGB24,
- cc->width, cc->height, cc->pix_fmt,
- SWS_BICUBIC, NULL, NULL, NULL);
-