summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrederik Schwan2020-04-28 15:04:48 +0200
committerFrederik Schwan2020-04-28 15:04:48 +0200
commitc55f47d8b0312444f7992511b178fa57aeac6f4d (patch)
tree426bf36ae9c05465889f2383a88ae815bf477c86
parente57cefce5f4348dad33be7968e474cc5b66ab093 (diff)
downloadaur-c55f47d8b0312444f7992511b178fa57aeac6f4d.tar.gz
review with Alad Wenter
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD44
2 files changed, 15 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bcf4580b45c9..21515eeb1204 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = parcimonie-sh-git
pkgdesc = Bash reimplementation of parcimonie - Refresh your GnuPG keyring without disclosing your whole contact list to the world
pkgver = 73.551999c
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/EtiennePerot/parcimonie.sh
arch = any
license = custom:WTFPL
@@ -10,10 +10,9 @@ pkgbase = parcimonie-sh-git
depends = torsocks
depends = tor
depends = gnupg
- source = git+https://github.com/EtiennePerot/parcimonie.sh
- source = pgp-key::https://perot.me/pgp-minimal.asc
+ source = git+https://github.com/EtiennePerot/parcimonie.sh?signed
+ validpgpkeys = 5039F36EE75CCD6EC444A0075CFC3B88974EE250
b2sums = SKIP
- b2sums = b0a2a2394ce27e6271344a85ae3547e3d80deca3e16709d1d86c2da31fb6d89968062e56e6db214e1f8fc16fb6e86f5dc17acdd30ef8120f4f0bbd9ccdca4b78
pkgname = parcimonie-sh-git
diff --git a/PKGBUILD b/PKGBUILD
index 29ebd059fed1..bc07522b81db 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,51 +3,31 @@
pkgname=parcimonie-sh-git
pkgver=73.551999c
-pkgrel=1
+pkgrel=2
pkgdesc='Bash reimplementation of parcimonie - Refresh your GnuPG keyring without disclosing your whole contact list to the world'
arch=('any')
url='https://github.com/EtiennePerot/parcimonie.sh'
license=('custom:WTFPL')
depends=('bash' 'torsocks' 'tor' 'gnupg')
makedepends=('git')
-source=('git+https://github.com/EtiennePerot/parcimonie.sh'
- 'pgp-key::https://perot.me/pgp-minimal.asc')
-b2sums=('SKIP'
- 'b0a2a2394ce27e6271344a85ae3547e3d80deca3e16709d1d86c2da31fb6d89968062e56e6db214e1f8fc16fb6e86f5dc17acdd30ef8120f4f0bbd9ccdca4b78')
+source=('git+https://github.com/EtiennePerot/parcimonie.sh?signed')
+b2sums=('SKIP')
+validpgpkeys=(
+ '5039F36EE75CCD6EC444A0075CFC3B88974EE250' # Etienne Perot https://perot.me/pgp-minimal.asc
+)
pkgver() {
cd parcimonie.sh
echo "$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
}
-check() {
- cd parcimonie.sh
- msg2 'Verifying GPG signature on HEAD commit.'
- export GNUPGHOME="$(pwd)"/.gnupg
- mkdir -p "$GNUPGHOME"
- chmod 700 "$GNUPGHOME"
- gpg --import < "${srcdir}"/pgp-key
- gpgKeyId="$(gpg --show-key --batch --with-colons < "${srcdir}"/pgp-key | grep '^sub:' | head -1 | cut -d ':' -f 5)"
- git log --max-count=1 --pretty="format:%H,%G?,%GK" HEAD | grep -q ",[GU],${gpgKeyId}\$"
- returnValue="$?"
- if [ "$returnValue" -eq 0 ]; then
- msg2 'Latest commit is properly signed.'
- else
- error "Latest commit '$(git rev-parse HEAD)' is not signed by GPG key '$gpgKeyId'."
- fi
- rm -r "${GNUPGHOME}"
- unset GNUPGHOME
- return "${returnValue}"
-}
-
package() {
cd parcimonie.sh
- install -D -m644 LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
- install -D -m644 README.md "${pkgdir}"/usr/share/parcimonie.sh/README.md
- install -D -m755 parcimonie.sh "${pkgdir}"/usr/share/parcimonie.sh/parcimonie.sh
- install -D -m644 pkg/parcimonie.sh@.service "${pkgdir}"/usr/lib/systemd/system/parcimonie.sh@.service
- install -D -m644 pkg/sample-configuration.conf.sample "${pkgdir}"/etc/parcimonie.sh.d/sample-configuration.conf.sample
- install -D -m644 pkg/all-users.conf "${pkgdir}"/etc/parcimonie.sh.d/all-users.conf
- mkdir -p "${pkgdir}"/usr/bin
+ install -dm755 "${pkgdir}"/usr/bin
+ install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
+ install -Dm644 README.md "${pkgdir}"/usr/share/parcimonie.sh/README.md
+ install -Dm755 parcimonie.sh "${pkgdir}"/usr/share/parcimonie.sh/parcimonie.sh
+ install -Dm644 pkg/parcimonie.sh@.service "${pkgdir}"/usr/lib/systemd/system/parcimonie.sh@.service
+ install -Dm644 -t "${pkgdir}"/etc/parcimonie.sh.d/ pkg/sample-configuration.conf.sample pkg/all-users.conf
ln -sf /usr/share/parcimonie.sh/parcimonie.sh "${pkgdir}"/usr/bin/parcimonie.sh
}