summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWillem Mulder2018-03-28 18:27:23 +0200
committerWillem Mulder2018-03-28 18:44:32 +0200
commit5339ccbe292ab79100b29eb3935fe4695a2fb864 (patch)
tree6b2bdf6be3de49dd76d5d4889cfc916810390d25
downloadaur-5339ccbe292ab79100b29eb3935fe4695a2fb864.tar.gz
Initial packaging of git version
-rw-r--r--.SRCINFO19
-rw-r--r--.gitattributes1
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD33
4 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4a73c0c0afcc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Wed Mar 28 16:44:31 UTC 2018
+pkgbase = passff-host-git
+ pkgdesc = Host app for the WebExtension PassFF
+ pkgver = 1.0.1.r7.1feab77
+ pkgrel = 1
+ url = https://github.com/passff/passff-host
+ arch = any
+ license = GPL2
+ makedepends = git
+ makedepends = jq
+ depends = python
+ provides = passff-host
+ conflicts = passff-host
+ source = passff-host::git+https://github.com/passff/passff-host.git
+ sha384sums = SKIP
+
+pkgname = passff-host-git
+
diff --git a/.gitattributes b/.gitattributes
new file mode 100644
index 000000000000..08c7cb3413a1
--- /dev/null
+++ b/.gitattributes
@@ -0,0 +1 @@
+.SRCINFO -whitespace
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..8c4874d666bd
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*
+!*.patch
+!.SRCINFO
+!.gitattributes
+!.gitignore
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d89131aa057e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Willem Mulder <14mRh4X0r@gmail.com>
+_pkgname=passff-host
+pkgname=$_pkgname-git
+pkgver=1.0.1.r7.1feab77
+pkgrel=1
+pkgdesc="Host app for the WebExtension PassFF"
+arch=(any)
+url="https://github.com/passff/passff-host"
+license=('GPL2')
+depends=('python')
+makedepends=(git jq)
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("$_pkgname::git+https://github.com/passff/passff-host.git")
+sha384sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ printf "%s" "$(git describe --tags --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
+package() {
+ cd "$_pkgname"
+
+ sed -i -e '1c#!/usr/bin/python3' -e s/_VERSIONHOLDER_/${pkgver}/g src/passff.py
+
+ install -Dm755 src/passff.py \
+ "${pkgdir}/usr/lib/mozilla/native-messaging-hosts/passff.py"
+ jq '.path = "/usr/lib/mozilla/native-messaging-hosts/passff.py"' src/passff.json \
+ > "${pkgdir}/usr/lib/mozilla/native-messaging-hosts/passff.json"
+}
+
+# vim:set ts=2 sw=2 et: