summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-03-22 11:24:17 +0800
committerzxp198210052024-03-22 11:24:17 +0800
commit86484e35530f12b621b283e72441da8d8aebec58 (patch)
tree036f281207653b1eeff15afd59d1dd92c0fdcde5
parent245fdcef0213bd231e15098d4b53ef74eb0135f7 (diff)
downloadaur-paster-bin.tar.gz
fix errors
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD5
-rw-r--r--paster.sh5
3 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2df32990d738..a6eb1dba9c8c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = paster-bin
pkgdesc = A clipboard management tool implemented with Electron + React + ArcoDesign.It well be a handy paste tool
pkgver = 1.0.0
- pkgrel = 4
+ pkgrel = 5
url = https://github.com/zengxiaolou/paste
arch = x86_64
license = GPL-3.0-only
@@ -12,6 +12,6 @@ pkgbase = paster-bin
source = paster-1.0.0.deb::https://github.com/zengxiaolou/paste/releases/download/v1.0.0/paster_1.0.0_amd64.deb
source = paster.sh
sha256sums = 051afe059a8eb439c7c8250eda48e5c485ed49abd7d82d7f65f6a4148de25309
- sha256sums = 50b10386d13e5bec806aeb78f819c4edd0208a4d184332e53866c802731217fe
+ sha256sums = dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8
pkgname = paster-bin
diff --git a/PKGBUILD b/PKGBUILD
index adbb44f427a7..eb224bfbcfaf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ pkgname=paster-bin
_pkgname=paster
pkgver=1.0.0
_electronversion=27
-pkgrel=4
+pkgrel=5
pkgdesc="A clipboard management tool implemented with Electron + React + ArcoDesign.It well be a handy paste tool"
arch=("x86_64")
url="https://github.com/zengxiaolou/paste"
@@ -19,11 +19,12 @@ source=(
"${pkgname%-bin}.sh"
)
sha256sums=('051afe059a8eb439c7c8250eda48e5c485ed49abd7d82d7f65f6a4148de25309'
- '50b10386d13e5bec806aeb78f819c4edd0208a4d184332e53866c802731217fe')
+ 'dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8')
build() {
sed -e "s|@electronversion@|${_electronversion}|g" \
-e "s|@appname@|${pkgname%-bin}|g" \
-e "s|@runname@|app.asar|g" \
+ -e "s|@options@||g" \
-i "${srcdir}/${pkgname%-bin}.sh"
bsdtar -xf "${srcdir}/data."*
sed "s|/opt/${pkgname%-bin}/${pkgname%-bin}|${pkgname%-bin}|g" -i "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop"
diff --git a/paster.sh b/paster.sh
index 86cb3dc6a9bf..7ddcaab8d734 100644
--- a/paster.sh
+++ b/paster.sh
@@ -2,6 +2,7 @@
set -e
_APPDIR="/usr/lib/@appname@"
_RUNNAME="${_APPDIR}/@runname@"
+_OPTIONS="@options@"
export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
@@ -9,7 +10,7 @@ export ELECTRON_FORCE_IS_PACKAGED=true
export NODE_ENV=production
cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec electron@electronversion@ "${_RUNNAME}" "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" "$@" || exit $?
else
- exec electron@electronversion@ "${_RUNNAME}" --no-sandbox "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" --no-sandbox "$@" || exit $?
fi \ No newline at end of file