summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhelsotainer2018-06-03 01:11:53 +0300
committerhelsotainer2018-06-03 01:11:53 +0300
commit2c5c4ef19561d0d773a1c1b60b02124d8ebf2874 (patch)
treefb843bd8c21f238f40b534527c3c33176bd38ec3
downloadaur-pavuk.tar.gz
Just pavuk package. What did you expect?
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD31
-rw-r--r--pavuk.desktop13
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..70fb26c5cc73
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = pavuk
+ pkgdesc = UNIX program used to mirror the contents of WWW documents or files.
+ pkgver = 0.9.35
+ pkgrel = 1
+ url = http://www.pavuk.org/
+ arch = x86_64
+ license = GPLv2
+ depends = glibc
+ optdepends = gtk2: for X windows support
+ optdepends = zlib: for online decoding of encoded documents
+ optdepends = openssl: for SSL support
+ options = !buildflags
+ options = !makeflags
+ source = https://netix.dl.sourceforge.net/project/pavuk/pavuk/0.9.35/pavuk-0.9.35.tar.bz2
+ source = pavuk.desktop
+ md5sums = 6204c7a1339433ab32456ccd62126ea9
+ md5sums = SKIP
+
+pkgname = pavuk
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c38e28eb1f1a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Helso Tainer <helsotainer@gmail.com>
+pkgname=pavuk
+pkgver=0.9.35
+pkgrel=1
+pkgdesc="UNIX program used to mirror the contents of WWW documents or files."
+url="http://www.pavuk.org/"
+arch=('x86_64')
+license=('GPLv2')
+depends=('glibc')
+optdepends=('gtk2: for X windows support'
+ 'zlib: for online decoding of encoded documents'
+ 'openssl: for SSL support')
+source=("https://netix.dl.sourceforge.net/project/pavuk/pavuk/0.9.35/pavuk-0.9.35.tar.bz2"
+ "pavuk.desktop")
+md5sums=('6204c7a1339433ab32456ccd62126ea9'
+ 'SKIP')
+options=('!buildflags' '!makeflags')
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr --enable-utf-8 --with-x
+ make "LDFLAGS=-lX11" all
+}
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ #make VERBOSE=1 DESTDIR="${pkgdir}" prefix="$pkgdir/usr" install
+ make DESTDIR="${pkgdir}" PREFIX=/usr install
+ cd "${srcdir}/"
+ install -Dm644 pavuk.desktop "$pkgdir/usr/share/applications/pavuk.desktop"
+}
+
+# vim:set ts=2 sw=2 et: \ No newline at end of file
diff --git a/pavuk.desktop b/pavuk.desktop
new file mode 100644
index 000000000000..a1436a1ecf57
--- /dev/null
+++ b/pavuk.desktop
@@ -0,0 +1,13 @@
+[Desktop Entry]
+Name=Pavuk
+Name[sk]=Pavúk
+Name[cs]=Pavúk
+Comment=Recursive World Wide Web mirroring tool for HTTP, HTTPS, FTP and Gopher protocols
+Comment[sk]=Nástroj na rekurzívne kopírovanie dokumentov z WWW cez protokoly HTTP, HTTPS, FTP, FTPS a Gopher
+Comment[cs]=Nástroj na rekurzivní kopírování dokumentů z WWW pomocí protokolů HTTP, HTTPS, FTP, FTPS a Gopher
+Comment[de]=Rekursives WWW-Speicherprogramm für die Protokolle HTTP, HTTPS, FTP und Gopher
+Exec=pavuk -X
+Icon=pavuk_as_icon
+Terminal=0
+Type=Application
+Categories=Network;FileTransfer