summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZack Buhman2017-05-22 15:26:00 -0500
committerZack Buhman2017-05-22 15:26:00 -0500
commit4d9a0992082a50d0e87215665152144c7abc0b1f (patch)
treefdfac0e18bee6d8381590b054d3827688f4baa58
parent119a2fc654acdf84486cafce2e32a08be4e2302b (diff)
downloadaur-pb-git.tar.gz
PKGBUILD: fix disgusting grunt hackery
All of the hard work is now done in pbs-git
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD22
2 files changed, 7 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fb0453f3c38e..f3177b3b5f4c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,15 @@
-# Generated by mksrcinfo v8
-# Sat Jan 23 21:50:58 UTC 2016
pkgbase = pb-git
pkgdesc = My attempt at a light pastebin
- pkgver = r311.529e8fc
+ pkgver = r357.dc04f7f
pkgrel = 1
url = https://github.com/ptpb/pb
arch = any
license = GPLv3
makedepends = python-setuptools
makedepends = git
- makedepends = graphicsmagick
- makedepends = npm
depends = python
depends = python-werkzeug
- depends = python-flask-git
+ depends = python-flask
depends = python-yaml
depends = python-requests
depends = python-docutils
@@ -26,6 +22,7 @@ pkgbase = pb-git
depends = python-click
depends = python-pygments
depends = python-pytz
+ optdepends = pbs-git: pb styles and static resources
provides = pb
backup = etc/xdg/pb/config.yaml
backup = etc/uwsgi/pb.ini
diff --git a/PKGBUILD b/PKGBUILD
index 4acc96541be2..e86939995b3c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,20 @@
pkgname=pb-git
-pkgver=r311.529e8fc
+pkgver=r357.dc04f7f
pkgrel=1
pkgdesc="My attempt at a light pastebin"
arch=('any')
url="https://github.com/ptpb/pb"
license=('GPLv3')
-depends=('python' 'python-werkzeug' 'python-flask-git' 'python-yaml'
+depends=('python' 'python-werkzeug' 'python-flask' 'python-yaml'
'python-requests' 'python-docutils' 'python-xdg'
'python-pymongo' 'python-markdown' 'python-dateutil'
'uwsgi' 'uwsgi-plugin-python'
'python-click' 'python-pygments' 'python-pytz')
-makedepends=('python-setuptools' 'git' 'graphicsmagick' 'npm')
+makedepends=('python-setuptools' 'git')
#checkdepends=('tox' 'python-pytest' 'python-pytest-cov')
+optdepends=('pbs-git: pb styles and static resources')
provides=('pb')
backup=('etc/xdg/pb/config.yaml' 'etc/uwsgi/pb.ini')
@@ -26,21 +27,6 @@ pkgver() {
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-prepare() {
- cd $pkgname
-
- npm install
- npm install grunt-cli
-
- # npm and grunt are retarded pieces of shit
- (
- cd node_modules/pbs
- npm install
- )
-
- node_modules/grunt-cli/bin/grunt
-}
-
build() {
cd $pkgname