summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormcgyver2024-02-26 21:51:32 +0000
committermcgyver2024-02-26 21:51:32 +0000
commitc66e548e04b39e3d49c4638f4077d5ce305583ba (patch)
tree32a607552c7355eb0fd011f05762df8db44a3bc6
parent43754d89b7c9a7d0d1780f907d0fb3c1caf6ccbb (diff)
downloadaur-pcapplusplus-git.tar.gz
Removing examples and added zstd library for compressed file stream - left comments in PKGBUILD on how to reactivate examples if needed
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD14
2 files changed, 13 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 843ba34d666e..c8583247bd54 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = pcapplusplus-git
pkgdesc = A multi-platform C++ library for capturing, parsing and crafting of network packets
- pkgver = 22.11.r104.gfb3a5604
+ pkgver = 23.09.r80.ga93506c9
pkgrel = 1
url = https://pcapplusplus.github.io/
arch = x86_64
@@ -9,6 +9,7 @@ pkgbase = pcapplusplus-git
depends = libpcap
depends = glibc
depends = gcc-libs
+ depends = zstd
source = pcapplusplus::git+https://github.com/seladb/PcapPlusPlus.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 3994459a637e..f0ee91277662 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: mcgyver <newsletter.sergio@gmail.com>
pkgname=pcapplusplus-git
-pkgver=22.11.r104.gfb3a5604
+pkgver=23.09.r80.ga93506c9
pkgrel=1
pkgdesc="A multi-platform C++ library for capturing, parsing and crafting of network packets"
arch=("x86_64")
url="https://pcapplusplus.github.io/"
license=('Unlicense')
makedepends=("git")
-depends=("libpcap" "glibc" "gcc-libs")
+depends=("libpcap" "glibc" "gcc-libs" "zstd")
source=("pcapplusplus::git+https://github.com/seladb/PcapPlusPlus.git")
sha256sums=('SKIP')
@@ -21,8 +21,16 @@ build() {
cd "pcapplusplus"
mkdir -p "build"
cd build
- cmake -DBUILD_SHARED_LIBS=ON -DCMAKE_INSTALL_PREFIX='/usr' -DCMAKE_INSTALL_LIBDIR='/usr/lib/pcapplusplus' ..
+
+ #if zstd is not needed, set -DLIGHT_PCAPNG_ZSTD=OFF
+ #examples may be built and installed under /usr/bin folder. If needed set -DPCAPPP_BUILD_EXAMPLES=ON
+
+ cmake -DLIGHT_PCAPNG_ZSTD=ON -DPCAPPP_BUILD_EXAMPLES=OFF -DBUILD_SHARED_LIBS=ON -DCMAKE_INSTALL_PREFIX='/usr' -DCMAKE_INSTALL_LIBDIR='/usr/lib/pcapplusplus' ..
make
+
+ #alternative UNTESTED compilation script
+ #cmake -DPCAPPP_BUILD_EXAMPLES=OFF -DBUILD_SHARED_LIBS=ON -DCMAKE_INSTALL_PREFIX='/usr' -DCMAKE_INSTALL_LIBDIR='/usr/lib/pcapplusplus' -S . -B build
+ #cmake --build build
}
package() {