summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNoel Maersk2020-04-28 23:20:47 +0300
committerNoel Maersk2020-04-28 23:20:47 +0300
commitad377538b5cab7fd2e5cbe3d5a0b3e4b8a5cf677 (patch)
tree22c73d7517e4267591375d71f1ab18460d07ebd0
parent152802a15dc01178b3b0eb1b38ca1c15d3c75f08 (diff)
downloadaur-pcb-git.tar.gz
Change versioning scheme, remove .install, no need to patch, build docs.
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
-rw-r--r--fix-gts-search-missing-libm.patch13
-rw-r--r--pcb.install37
4 files changed, 15 insertions, 73 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 05e304f66205..bb1314d68225 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,14 @@
+# Generated by mksrcinfo v8
+# Tue Apr 28 20:20:06 UTC 2020
pkgbase = pcb-git
- pkgdesc = Interactive printed circuit board editor
- pkgver = 20160425
+ pkgdesc = Interactive printed circuit board editor (latest git revision)
+ pkgver = 4227.e6acd71d
pkgrel = 1
+ epoch = 1
url = http://pcb.geda-project.org/
- install = pcb.install
arch = i686
arch = x86_64
license = GPL
- makedepends = autoconf
- makedepends = automake
- makedepends = bison
- makedepends = flex
makedepends = git
makedepends = intltool
makedepends = tk
@@ -24,9 +22,7 @@ pkgbase = pcb-git
provides = pcb
conflicts = pcb
source = git://git.geda-project.org/pcb.git
- source = fix-gts-search-missing-libm.patch
md5sums = SKIP
- md5sums = 85ba1f0766697fdec313aa4d84f11d99
pkgname = pcb-git
diff --git a/PKGBUILD b/PKGBUILD
index 1475a35ca2dc..28b52885c037 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,9 +3,10 @@
pkgname=pcb-git
_gitname=pcb
-pkgver=20160425
+pkgver=4227.e6acd71d
pkgrel=1
-pkgdesc='Interactive printed circuit board editor'
+epoch=1
+pkgdesc='Interactive printed circuit board editor (latest git revision)'
url='http://pcb.geda-project.org/'
license=('GPL')
arch=('i686' 'x86_64')
@@ -14,32 +15,27 @@ optdepends=('tk: additional tools'
'tcl: additional tools'
'perl: additional tools'
'desktop-file-utils: desktop integration')
-makedepends=('autoconf' 'automake' 'bison' 'flex' 'git' 'intltool' 'tk')
+makedepends=('git' 'intltool' 'tk')
provides=('pcb')
conflicts=('pcb')
-source=("git://git.geda-project.org/${_gitname}.git"
- 'fix-gts-search-missing-libm.patch')
-md5sums=('SKIP'
- '85ba1f0766697fdec313aa4d84f11d99')
-install=pcb.install
+source=("git://git.geda-project.org/${_gitname}.git")
+md5sums=('SKIP')
pkgver() {
cd "${_gitname}"
- echo $(date +%Y%m%d) # format used by `pcb` in [community]
- #echo $(git rev-list --count master).$(git rev-parse --short master)
+ echo $(git rev-list --count master).$(git rev-parse --short master)
}
build() {
cd "${srcdir}/${_gitname}"
- patch -p1 < "$srcdir/fix-gts-search-missing-libm.patch"
+
./autogen.sh
./configure \
--prefix=/usr \
--enable-dbus \
- --disable-doc \
--disable-update-mime-database \
- --disable-update-desktop-database \
- --disable-gl # FIXME: `configure` looks for weird libs
+ --disable-update-desktop-database
+
make
}
diff --git a/fix-gts-search-missing-libm.patch b/fix-gts-search-missing-libm.patch
deleted file mode 100644
index c1ab91d3a5d5..000000000000
--- a/fix-gts-search-missing-libm.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/configure.ac b/configure.ac
-index bd74db3..1436670 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -316,7 +316,7 @@ if test "x$enable_toporouter" = "xyes"; then
- # apart toporouter related stuff and because testing for the library makes
- # reasonably sure that GTS is available, we omit a test for gts.h.
- #AC_CHECK_HEADER(gts.h, , AC_MSG_ERROR($this_error_text), glib.h)
-- AC_SEARCH_LIBS(gts_object_class_new, gts, , AC_MSG_ERROR($this_error_text))
-+ AC_SEARCH_LIBS(gts_object_class_new, gts, , AC_MSG_ERROR($this_error_text), -lm)
- unset this_error_text
- fi
-
diff --git a/pcb.install b/pcb.install
deleted file mode 100644
index 62ce80440970..000000000000
--- a/pcb.install
+++ /dev/null
@@ -1,37 +0,0 @@
-infodir=/usr/share/info
-filelist=(pcb.info pcb.info-1 pcb.info-2)
-
-post_install() {
- if [ -x /usr/bin/update-mime-database ]; then
- echo Updating mime database...
- /usr/bin/update-mime-database /usr/share/mime
- fi
- if [ -x /usr/bin/update-desktop-database ]; then
- echo Updating desktop database..
- /usr/bin/update-desktop-database /usr/share/applications
- fi
- if [ -x /usr/bin/install-info ]; then
- echo Updating info directory...
- for file in ${filelist[@]}; do
- install-info $infodir/$file $infodir/dir 2> /dev/null
- done
- fi
- /usr/bin/gtk-update-icon-cache -f -t /usr/share/icons/hicolor
-}
-
-post_upgrade() {
- post_install $1
-}
-
-pre_remove() {
- if [ -x /usr/bin/install-info ]; then
- echo Updating info directory...
- for file in ${filelist[@]}; do
- install-info --delete $infodir/$file $infodir/dir 2> /dev/null
- done
- fi
-}
-
-post_remove() {
- /usr/bin/gtk-update-icon-cache -f -t /usr/share/icons/hicolor
-}