summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCebtenzzre2019-05-27 23:23:33 -0400
committerCebtenzzre2019-05-27 23:28:23 -0400
commitd1cd7c3d398d9e5f9904e8e798d723c9011b5cad (patch)
tree8e793c38189a1d11a4a84364e0f9ee66bbd98e32
parent03600af2a07c4977ccb392572462068dd59f4536 (diff)
downloadaur-pcg-cpp-git.tar.gz
Make package() Makefile-independent
The install target in the upstream Makefile changed, but it still isn't quite right. Patching it is silly for such a simple operation, so run install directly in package().
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD18
-rw-r--r--fix-makefile.patch17
3 files changed, 6 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fbfb186ce786..5d92a42a0ecc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = pcg-cpp-git
pkgdesc = A family of fast, statistically excellent algorithms for random number generation.
- pkgver = 0.98.1.r36.gb656278
+ pkgver = 0.98.1.r45.g3191635
pkgrel = 1
url = http://www.pcg-random.org/
arch = any
@@ -8,9 +8,7 @@ pkgbase = pcg-cpp-git
license = MIT
makedepends = git
provides = pcg-cpp
- source = fix-makefile.patch
source = git+https://github.com/imneme/pcg-cpp.git
- sha256sums = 3867f1a75bf30b4aa73c2ab0b5e821fc8764a8d7bb20f6a44f12bc1b1477d361
sha256sums = SKIP
pkgname = pcg-cpp-git
diff --git a/PKGBUILD b/PKGBUILD
index 61de68f8391f..d0631760dc29 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,15 @@
# Maintainer: Cebtenzzre <cebtenzzre (at) gmail (dot) com>
_pkgname=pcg-cpp
pkgname="${_pkgname}-git"
-pkgver=0.98.1.r36.gb656278
+pkgver=0.98.1.r45.g3191635
pkgrel=1
pkgdesc='A family of fast, statistically excellent algorithms for random number generation.'
arch=('any')
url='http://www.pcg-random.org/'
license=('Apache' 'MIT')
makedepends=('git')
-source=('fix-makefile.patch'
- "git+https://github.com/imneme/${_pkgname}.git")
-sha256sums=('3867f1a75bf30b4aa73c2ab0b5e821fc8764a8d7bb20f6a44f12bc1b1477d361'
- 'SKIP')
+source=("git+https://github.com/imneme/${_pkgname}.git")
+sha256sums=('SKIP')
provides=("${_pkgname}")
pkgver() {
@@ -19,11 +17,6 @@ pkgver() {
git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
-prepare() {
- cd "$_pkgname"
- patch -Np1 <../fix-makefile.patch
-}
-
build() {
cd "$_pkgname"
make
@@ -36,7 +29,6 @@ check() {
package() {
cd "$_pkgname"
- mkdir -p "$pkgdir/usr/include"
- make install PREFIX="$pkgdir/usr"
- install -m644 -D 'LICENSE-MIT.txt' "$pkgdir/usr/share/licenses/$pkgname/LICENSE-MIT"
+ install -Dm644 -t "$pkgdir/usr/include" include/*.hpp
+ install -Dm644 'LICENSE-MIT.txt' "$pkgdir/usr/share/licenses/$pkgname/LICENSE-MIT"
}
diff --git a/fix-makefile.patch b/fix-makefile.patch
deleted file mode 100644
index 04c8fb1e73c2..000000000000
--- a/fix-makefile.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-diff --git a/Makefile b/Makefile
-index 21290ab..ccb9ce5 100644
---- a/Makefile
-+++ b/Makefile
-@@ -23,10 +23,10 @@ all:
- cd test-high; $(MAKE)
- cd sample; $(MAKE)
-
--PREFIX = /usr/local
-+PREFIX ?= /usr/local
-
- install: all
-- install -m 0644 include/*.hpp $PREFIX/include
-+ install -m 0644 include/*.hpp $(PREFIX)/include
-
- test: all
- cd test-high; $(MAKE) test