summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohannes Löthberg2013-10-22 19:03:48 +0200
committerJohannes Löthberg2015-06-08 12:21:37 +0200
commita3663404df89190fb092d2fa05ca9bf1dde093b4 (patch)
treede2919af5aa525217aa85668b69f47c84d3693b4
parentb859f6c12f90237acee1ca63ea850ed53bbd61a4 (diff)
downloadaur-a3663404df89190fb092d2fa05ca9bf1dde093b4.tar.gz
did some shit, too lazy to split things up
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
2 files changed, 5 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 952b428d9fea..b60894e96c9d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -3,7 +3,7 @@
pkgbase = pcmanfm-git
pkgdesc = An extremely fast, lightweight, yet feature-rich file manager with tabbed browsing
pkgver = 1.1.2.r36.g9b9dd4c
- pkgrel = 1
+ pkgrel = 2
url = http://pcmanfm.sourceforge.net/
install = pcmanfm.install
arch = i686
@@ -17,7 +17,7 @@ pkgbase = pcmanfm-git
optdepends = gnome-menus: applications menu and "Open with..." dialog
provides = pcmanfm
conflicts = pcmanfm
- source = git://pcmanfm.git.sourceforge.net/gitroot/pcmanfm/pcmanfm
+ source = git+https://pcmanfm.git.sourceforge.net/gitroot/pcmanfm/pcmanfm
md5sums = SKIP
pkgname = pcmanfm-git
diff --git a/PKGBUILD b/PKGBUILD
index b1ca2a8c4045..5a7e804f2119 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=pcmanfm-git
pkgver=1.1.2.r36.g9b9dd4c
-pkgrel=1
+pkgrel=2
pkgdesc="An extremely fast, lightweight, yet feature-rich file manager with tabbed browsing"
arch=('i686' 'x86_64')
url="http://pcmanfm.sourceforge.net/"
@@ -15,27 +15,23 @@ optdepends=('gvfs: mounting of local and remote drives'
provides=('pcmanfm')
conflicts=('pcmanfm')
install=pcmanfm.install
-source=('git://pcmanfm.git.sourceforge.net/gitroot/pcmanfm/pcmanfm')
+source=('git+https://pcmanfm.git.sourceforge.net/gitroot/pcmanfm/pcmanfm')
md5sums=('SKIP')
pkgver() {
cd pcmanfm
-
printf "%s" "$(git describe --always --long | sed 's/-/-r/' | tr - .)"
}
build() {
cd pcmanfm
-
- msg "Starting make..."
./autogen.sh
./configure --prefix=/usr --sysconfdir=/etc
make LDFLAGS="-lm ${LDFLAGS}"
}
package() {
- cd pcmanfm
- make DESTDIR="$pkgdir" install
+ make -C pcmanfm DESTDIR="$pkgdir" install
}
# vim: set ts=4 sw=4 noet: