summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkenshen1122023-03-23 08:42:39 -0700
committerkenshen1122023-03-23 08:42:39 -0700
commit3366628d5fa9109eda4a63360522961e5550dd95 (patch)
tree13f97221d73018b64e2d8d9a17f8d08b38b19743
parentdd683e157d61eb8dbb22450f113d2ce57b61aca7 (diff)
downloadaur-3366628d5fa9109eda4a63360522961e5550dd95.tar.gz
VCS Submodules
-rw-r--r--PKGBUILD150
1 files changed, 98 insertions, 52 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e99c7178b73c..1e4947d4c0f6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,54 +3,54 @@
# Contributor: Themaister <maister@archlinux.us>
pkgname=pcsx2-git
-pkgver=v1.7.4110.r0.gef31c733e
+pkgver=v1.7.4268.r0.gad12a3f73
pkgrel=1
pkgdesc='A Sony PlayStation 2 emulator'
arch=(x86_64)
url=https://www.pcsx2.net
license=(
- GPL2
- GPL3
- LGPL2.1
- LGPL3
+ GPL2
+ GPL3
+ LGPL2.1
+ LGPL3
)
install=post.install
depends=(
- libaio
- libjpeg-turbo
- libpcap
- libzip
- libgl # For Steam Deck
- xorg-xrandr # For Steam Deck
- libxrender # For Steam Deck
- linux-api-headers # For Steam Deck
- libpulse
- ffmpeg
- portaudio
- libsamplerate
- sdl2
- rapidyaml
- qt6-base
- qt6-wayland
- qt6-tools
- qt6-svg
- soundtouch
- wayland
- zstd
+ libaio
+ libjpeg-turbo
+ libpcap
+ libzip
+ libgl # For Steam Deck
+ xorg-xrandr # For Steam Deck
+ libxrender # For Steam Deck
+ linux-api-headers # For Steam Deck
+ libpulse
+ ffmpeg
+ portaudio
+ libsamplerate
+ sdl2
+ rapidyaml
+ qt6-base
+ qt6-wayland
+ qt6-tools
+ qt6-svg
+ soundtouch
+ wayland
+ zstd
)
makedepends=(
- cmake
- clang
- lld
- llvm
- git
- xorgproto
- ninja
- swig
- python
- vulkan-headers
+ cmake
+ clang
+ lld
+ llvm
+ git
+ xorgproto
+ ninja
+ swig
+ python
+ vulkan-headers
)
provides=(pcsx2-qt)
@@ -58,29 +58,66 @@ provides=(pcsx2-qt)
conflicts=(pcsx2)
source=(
-git+https://github.com/PCSX2/pcsx2.git
-0001-Fix-resources-Fix-CMake.patch
+ git+https://github.com/PCSX2/pcsx2.git
+ git+https://github.com/google/googletest.git
+ git+https://github.com/fmtlib/fmt.git
+ git+https://github.com/microsoft/wil.git
+ git+https://github.com/biojppm/rapidyaml.git
+ git+https://github.com/KhronosGroup/glslang.git
+ git+https://github.com/KhronosGroup/Vulkan-Headers.git
+ git+https://github.com/libsdl-org/SDL.git
+ git+https://github.com/nih-at/libzip.git
+ git+https://github.com/facebook/zstd.git
+ git+https://github.com/RetroAchievements/rcheevos.git
+ 0001-Fix-resources-Fix-CMake.patch
)
prepare()
{
- cd pcsx2
- git submodule update --init --recursive
- git apply -3 "${srcdir}/0001-Fix-resources-Fix-CMake.patch"
+ cd pcsx2
+ git apply -3 "${srcdir}/0001-Fix-resources-Fix-CMake.patch"
+
+ git config --global protocol.file.allow always
+ local submodule
+ for submodule in 3rdparty/{glslang/glslang,libchdr/libchdr,rapidyaml/rapidyaml,rcheevos/rcheevos}; do
+ git submodule init ${submodule}
+ git submodule set-url ${submodule} "${srcdir}/${submodule##*/}"
+ git submodule update ${submodule}
+ done
+ cd 3rdparty/rapidyaml/rapidyaml
+ for submodule in ext/c4core; do
+ git submodule init ${submodule}
+ git submodule set-url ${submodule} "${srcdir}/${submodule##*/}"
+ git submodule update ${submodule}
+ done
+ cd ext/c4core
+ git submodule init cmake
+ git submodule set-url cmake "${srcdir}"/cmake
+ git submodule update cmake
+ for submodule in src/c4/ext/debugbreak; do
+ git submodule init ${submodule}
+ git submodule set-url ${submodule} "${srcdir}/${submodule##*/}"
+ git submodule update ${submodule}
+ done
+ for submodule in src/c4/ext/fast_float; do
+ git submodule init ${submodule}
+ git submodule set-url ${submodule} "${srcdir}/${submodule##*/}"
+ git submodule update ${submodule}
+ done
}
pkgver()
{
- cd pcsx2
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ cd pcsx2
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build()
{
- mkdir -p build
- cd build
-
- cmake ../pcsx2 \
+ mkdir -p build
+ cd build
+
+ cmake ../pcsx2 \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INTERPROCEDURAL_OPTIMIZATION=ON \
@@ -94,10 +131,9 @@ build()
-DDISABLE_ADVANCE_SIMD=ON \
-GNinja \
-DPACKAGE_MODE=ON
- ninja -j$(nproc)
-
- cd ..
- cp -r pcsx2/.github/workflows/scripts/linux/pcsx2-qt.desktop build/bin/PCSX2.desktop
+ ninja -j$(nproc)
+ cd ..
+ cp -r pcsx2/.github/workflows/scripts/linux/pcsx2-qt.desktop build/bin/PCSX2.desktop
}
package()
@@ -109,5 +145,15 @@ package()
# vim: ts=2 sw=2 et:
sha256sums=('SKIP'
- 'b69b3369e62bee6b6063b49621144343bb9ba81fd51f38e5e9bee4efbc731230'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'b69b3369e62bee6b6063b49621144343bb9ba81fd51f38e5e9bee4efbc731230'
)