summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkenshen1122022-05-21 21:38:57 -0700
committerkenshen1122022-05-21 21:38:57 -0700
commit81ffe2e644e0285cc50769df676872734a48b7cc (patch)
treec83318e7c5d53d43fe8446aac343bdeecda5fd89
parentbec98fc3da577f56291050cf7f9b10818d034596 (diff)
downloadaur-81ffe2e644e0285cc50769df676872734a48b7cc.tar.gz
Optionally use system libs
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD26
2 files changed, 18 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4167e5bfe6a1..a15ee72f3b76 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = pcsx2-git
pkgdesc = A Sony PlayStation 2 emulator
- pkgver = 1.7.2747
+ pkgver = 1.7.2759
pkgrel = 1
url = https://www.pcsx2.net
install = dev9.install
@@ -19,6 +19,7 @@ pkgbase = pcsx2-git
depends = libaio
depends = libjpeg-turbo
depends = libpcap
+ depends = libzip
depends = libgl
depends = xorg-xrandr
depends = libxrender
@@ -27,25 +28,21 @@ pkgbase = pcsx2-git
depends = portaudio
depends = libsamplerate
depends = sdl2
+ depends = fmt
depends = soundtouch
depends = wxgtk3
depends = wayland
depends = rapidyaml
+ depends = zstd-cmake
provides = pcsx2
conflicts = pcsx2
source = git+https://github.com/PCSX2/pcsx2.git
- source = git+https://github.com/fmtlib/fmt.git
source = git+https://github.com/ocornut/imgui.git
source = git+https://github.com/rtissera/libchdr.git
source = git+https://github.com/google/googletest.git
- source = git+https://github.com/nih-at/libzip.git
- source = git+https://github.com/facebook/zstd.git
source = git+https://github.com/mozilla/cubeb.git
source = git+https://github.com/KhronosGroup/glslang.git
- source = git+https://github.com/libsdl-org/SDL.git
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
+ source = git+https://github.com/KhronosGroup/Vulkan-Headers.git
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 1f454fbb8683..419e74778002 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Themaister <maister@archlinux.us>
pkgname=pcsx2-git
-pkgver=1.7.2747
+pkgver=1.7.2759
pkgrel=1
pkgdesc='A Sony PlayStation 2 emulator'
arch=(x86_64)
@@ -21,6 +21,7 @@ depends=(
libaio
libjpeg-turbo
libpcap
+ libzip
libgl # For Steam Deck
xorg-xrandr # For Steam Deck
libxrender # For Steam Deck
@@ -29,10 +30,12 @@ depends=(
portaudio
libsamplerate
sdl2
+ fmt
soundtouch
wxgtk3
wayland
rapidyaml
+ zstd-cmake # AUR Package
)
makedepends=(
cmake
@@ -47,15 +50,12 @@ provides=(pcsx2)
conflicts=(pcsx2)
source=(
git+https://github.com/PCSX2/pcsx2.git
-git+https://github.com/fmtlib/fmt.git
git+https://github.com/ocornut/imgui.git
git+https://github.com/rtissera/libchdr.git
git+https://github.com/google/googletest.git
-git+https://github.com/nih-at/libzip.git
-git+https://github.com/facebook/zstd.git
git+https://github.com/mozilla/cubeb.git
git+https://github.com/KhronosGroup/glslang.git
-git+https://github.com/libsdl-org/SDL.git
+git+https://github.com/KhronosGroup/Vulkan-Headers.git
)
sha256sums=(SKIP)
@@ -68,16 +68,18 @@ pkgver()
prepare()
{
cd $srcdir/pcsx2/3rdparty
- git submodule init
- git config submodule.https://github.com/fmtlib/src/fmt.git.url fmt
+ git submodule update --init libchdr
+ git submodule update --init gtest
+ git submodule update --init cubeb
+ git submodule update --init imgui
+ git submodule update --init glslang
+ git submodule update --init vulkan-headers
git config submodule.https://github.com/rtissera/libchdr.git.url libchdr
git config submodule.https://github.com/google/googletest.git.url gtest
git config submodule.https://github.com/mozilla/cubeb.git.url cubeb
git config submodule.https://github.com/ocornut/imgui.git.url imgui
git config submodule.https://github.com/KhronosGroup/glslang.git glslang
- git config submodule.https://github.com/libsdl-org/SDL.git SDL
- git config submodule.https://github.com/nih-at/libzip.git libzip
- git config submodule.https://github.com/facebook/zstd.git ztsd
+ git config submodule.https://github.com/KhronosGroup/Vulkan-Headers.git vulkan-headers
git submodule update
}
@@ -93,6 +95,7 @@ build()
-DCMAKE_INTERPROCEDURAL_OPTIMIZATION=ON \
-DWAYLAND_API=ON \
-USE_VULKAN=ON \
+ -DUSE_SYSTEM_LIBS=ON \
-GNinja \
-DPACKAGE_MODE=ON \
-DXDG_STD=TRUE \
@@ -112,7 +115,4 @@ sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
'SKIP')