summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkenshen1122022-09-22 10:54:42 -0700
committerkenshen1122022-09-22 10:54:42 -0700
commitc898435a477f5adb757045a0d82e8d6a47e524cf (patch)
tree8a8a24a5789e7d905cc141cdb03d1a2bcf5600e5
parentacfd91e7f322332a331f5dd33794acdae6798762 (diff)
downloadaur-c898435a477f5adb757045a0d82e8d6a47e524cf.tar.gz
Added cheats downloading
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--dev9.install10
-rw-r--r--post.install19
4 files changed, 23 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b548d078c3dc..3e7e2dd1da88 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
pkgbase = pcsx2-git
pkgdesc = A Sony PlayStation 2 emulator
- pkgver = v1.7.0.dev.r4305.g4ee4dfde3
+ pkgver = v1.7.0.dev.r4311.g173d62b1c
pkgrel = 1
url = https://www.pcsx2.net
- install = dev9.install
+ install = post.install
arch = x86_64
license = GPL2
license = GPL3
diff --git a/PKGBUILD b/PKGBUILD
index 857cd373ff99..62156e89366f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Themaister <maister@archlinux.us>
pkgname=pcsx2-git
-pkgver=v1.7.0.dev.r4305.g4ee4dfde3
+pkgver=v1.7.0.dev.r4311.g173d62b1c
pkgrel=1
pkgdesc='A Sony PlayStation 2 emulator'
arch=(x86_64)
@@ -15,7 +15,7 @@ license=(
LGPL3
)
-install=dev9.install
+install=post.install
OPTIONS+=(
debug !strip
diff --git a/dev9.install b/dev9.install
deleted file mode 100644
index 88acda2e94fd..000000000000
--- a/dev9.install
+++ /dev/null
@@ -1,10 +0,0 @@
-# For DEV9 netplay support
-post_install()
-{
- setcap 'CAP_NET_RAW+eip CAP_NET_ADMIN+eip' /usr/bin/pcsx2-qt
-}
-
-post_upgrade()
-{
- setcap 'CAP_NET_RAW+eip CAP_NET_ADMIN+eip' /usr/bin/pcsx2-qt
-}
diff --git a/post.install b/post.install
new file mode 100644
index 000000000000..0890f658d18a
--- /dev/null
+++ b/post.install
@@ -0,0 +1,19 @@
+# For DEV9 netplay support
+post_install()
+{
+ setcap 'CAP_NET_RAW+eip CAP_NET_ADMIN+eip' /usr/bin/pcsx2-qt
+
+ cd /usr/share/PCSX2/resources
+ sudo curl -O -L https://github.com/PCSX2/pcsx2_patches/releases/download/latest/cheats_ni.zip
+ sudo curl -O -L https://github.com/PCSX2/pcsx2_patches/releases/download/latest/cheats_ws.zip
+}
+
+post_upgrade()
+{
+ setcap 'CAP_NET_RAW+eip CAP_NET_ADMIN+eip' /usr/bin/pcsx2-qt
+ cd /usr/share/PCSX2/resources
+ sudo rm cheats_ws.zip
+ sudo rm cheats_ni.zip
+ sudo curl -O -L https://github.com/PCSX2/pcsx2_patches/releases/download/latest/cheats_ni.zip
+ sudo curl -O -L https://github.com/PCSX2/pcsx2_patches/releases/download/latest/cheats_ws.zip
+}