summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkenshen1122023-03-26 11:56:31 -0700
committerkenshen1122023-03-26 11:56:31 -0700
commitdb3bdfba0ad83718dfe7c85ff691eade416fec65 (patch)
tree0ac4c5965f3d7abb79409d8ddb77cdc039adb320
parentd706f2ff2878f65939fa5bafe42a24c449391f0d (diff)
downloadaur-db3bdfba0ad83718dfe7c85ff691eade416fec65.tar.gz
Remove needless submodule. Set Cmake to similar to AppImage
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD22
-rw-r--r--pcsx2-fix.patch326
3 files changed, 8 insertions, 346 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3d124006e913..9a250ea3fa80 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = pcsx2-git
pkgdesc = A Sony PlayStation 2 emulator
- pkgver = 1.7.4272.r0.g42155dd11
+ pkgver = 1.7.4275.r0.g66a13d4c3
pkgrel = 1
url = https://www.pcsx2.net
install = pcsx2-git.install
@@ -42,7 +42,6 @@ pkgbase = pcsx2-git
source = xz-pcsx2::git+https://github.com/PCSX2/xz.git
source = git+https://github.com/google/googletest.git
source = git+https://github.com/fmtlib/fmt.git
- source = git+https://github.com/microsoft/wil.git
source = git+https://github.com/rtissera/libchdr.git
source = git+https://github.com/biojppm/rapidyaml.git
source = git+https://github.com/biojppm/cmake.git
@@ -50,7 +49,7 @@ pkgbase = pcsx2-git
source = git+https://github.com/biojppm/debugbreak.git
source = git+https://github.com/fastfloat/fast_float.git
source = git+https://github.com/KhronosGroup/glslang.git
- source = git+https://github.com/KhronosGroup/Vulkan-Headers.git
+ source = vulkan-headers::git+https://github.com/KhronosGroup/Vulkan-Headers.git
source = git+https://github.com/nih-at/libzip.git
source = git+https://github.com/facebook/zstd.git
source = git+https://github.com/RetroAchievements/rcheevos.git
@@ -71,7 +70,6 @@ pkgbase = pcsx2-git
b2sums = SKIP
b2sums = SKIP
b2sums = SKIP
- b2sums = SKIP
b2sums = 20a92373a9434f285f8d51d7e615bf53843a59abf40f2e2a22464fe1680fb077ed4a5d97cf8ecb0fca3b5a0a4d2b5e2864af656052c2dc55cc6f54eea16d4449
pkgname = pcsx2-git
diff --git a/PKGBUILD b/PKGBUILD
index 534abe92bb21..5c71b1022938 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: Themaister <maister@archlinux.us>
pkgname=pcsx2-git
-pkgver=1.7.4272.r0.g42155dd11
+pkgver=1.7.4275.r0.g66a13d4c3
pkgrel=1
pkgdesc='A Sony PlayStation 2 emulator'
arch=(x86_64)
@@ -56,7 +56,6 @@ source=(
xz-pcsx2::git+https://github.com/PCSX2/xz.git
git+https://github.com/google/googletest.git
git+https://github.com/fmtlib/fmt.git
- git+https://github.com/microsoft/wil.git
git+https://github.com/rtissera/libchdr.git
git+https://github.com/biojppm/rapidyaml.git
git+https://github.com/biojppm/cmake.git
@@ -64,7 +63,7 @@ source=(
git+https://github.com/biojppm/debugbreak.git
git+https://github.com/fastfloat/fast_float.git
git+https://github.com/KhronosGroup/glslang.git
- git+https://github.com/KhronosGroup/Vulkan-Headers.git
+ vulkan-headers::git+https://github.com/KhronosGroup/Vulkan-Headers.git
git+https://github.com/nih-at/libzip.git
git+https://github.com/facebook/zstd.git
git+https://github.com/RetroAchievements/rcheevos.git
@@ -79,11 +78,10 @@ prepare() {
xz-pcsx2::3rdparty/xz/xz
googletest::3rdparty/gtest
fmt::3rdparty/fmt/fmt
- wil::3rdparty/wil
libchdr::3rdparty/libchdr/libchdr
rapidyaml::3rdparty/rapidyaml/rapidyaml
glslang::3rdparty/glslang/glslang
- Vulkan-Headers::3rdparty/vulkan-headers
+ vulkan-headers::3rdparty/vulkan-headers
libzip::3rdparty/libzip/libzip
zstd::3rdparty/zstd/zstd
rcheevos::3rdparty/rcheevos/rcheevos
@@ -117,25 +115,18 @@ pkgver() {
build() {
cmake -S pcsx2 -B build \
-G Ninja \
+ -DCMAKE_CXX_FLAGS_RELEASE="-O2" \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_C_COMPILER=clang \
-DCMAKE_CXX_COMPILER=clang++ \
-DCMAKE_EXE_LINKER_FLAGS_INIT="-fuse-ld=lld" \
-DCMAKE_MODULE_LINKER_FLAGS_INIT="-fuse-ld=lld" \
-DCMAKE_SHARED_LINKER_FLAGS_INIT="-fuse-ld=lld" \
+ -DUSE_VULKAN=ON \
-DCMAKE_INTERPROCEDURAL_OPTIMIZATION=ON \
- -DQT_BUILD=ON \
- -DCUBEB_API=ON \
- -DX11_API=ON \
- -DWAYLAND_API=ON \
- -DENABLE_SETCAP=OFF \
- -DUSE_SYSTEM_LIBS=OFF \
- -DUSE_SYSTEM_FMT=OFF \
- -DUSE_SYSTEM_LIBZIP=OFF \
- -DUSE_SYSTEM_RYML=OFF \
+ -DDISABLE_ADVANCE_SIMD=ON \
-DUSE_SYSTEM_SDL2=ON \
-DUSE_SYSTEM_ZSTD=OFF \
- -DDISABLE_ADVANCE_SIMD=ON \
-DDISABLE_BUILD_DATE=ON
ninja -C build -v
@@ -171,5 +162,4 @@ b2sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- 'SKIP'
'20a92373a9434f285f8d51d7e615bf53843a59abf40f2e2a22464fe1680fb077ed4a5d97cf8ecb0fca3b5a0a4d2b5e2864af656052c2dc55cc6f54eea16d4449')
diff --git a/pcsx2-fix.patch b/pcsx2-fix.patch
deleted file mode 100644
index 67d4fb7b73d1..000000000000
--- a/pcsx2-fix.patch
+++ /dev/null
@@ -1,326 +0,0 @@
-From c496b48eab140d13ddf44982972a0330cd9f1632 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?=C3=A9clairevoyant?=
- <848000+eclairevoyant@users.noreply.github.com>
-Date: Thu, 23 Mar 2023 19:15:08 -0400
-Subject: [PATCH] fix packaging
-
----
- .SRCINFO | 45 ++++++++++---------
- PKGBUILD | 108 +++++++++++++++++++++++-----------------------
- pcsx2-git.install | 10 +++++
- post.install | 19 --------
- 4 files changed, 88 insertions(+), 94 deletions(-)
- create mode 100644 pcsx2-git.install
- delete mode 100644 post.install
-
-diff --git a/.SRCINFO b/.SRCINFO
-index 9850ead..7d058a3 100644
---- a/.SRCINFO
-+++ b/.SRCINFO
-@@ -1,9 +1,9 @@
- pkgbase = pcsx2-git
- pkgdesc = A Sony PlayStation 2 emulator
-- pkgver = v1.7.4268.r0.gad12a3f73
-+ pkgver = 1.7.4269.r0.g72b38ce71
- pkgrel = 1
- url = https://www.pcsx2.net
-- install = post.install
-+ install = pcsx2-git.install
- arch = x86_64
- license = GPL2
- license = GPL3
-@@ -40,10 +40,12 @@ pkgbase = pcsx2-git
- depends = soundtouch
- depends = wayland
- depends = zstd
-+ provides = pcsx2
- provides = pcsx2-qt
- conflicts = pcsx2
- source = git+https://github.com/PCSX2/pcsx2.git
-- source = git+https://github.com/google/googletest.git
-+ source = git+https://github.com/PCSX2/xz.git
-+ source = gtest::git+https://github.com/google/googletest.git
- source = git+https://github.com/fmtlib/fmt.git
- source = git+https://github.com/microsoft/wil.git
- source = git+https://github.com/rtissera/libchdr.git
-@@ -53,28 +55,29 @@ pkgbase = pcsx2-git
- source = git+https://github.com/biojppm/debugbreak.git
- source = git+https://github.com/KhronosGroup/glslang.git
- source = git+https://github.com/fastfloat/fast_float.git
-- source = git+https://github.com/KhronosGroup/Vulkan-Headers.git
-+ source = vulkan-headers::git+https://github.com/KhronosGroup/Vulkan-Headers.git
- source = git+https://github.com/libsdl-org/SDL.git
- source = git+https://github.com/nih-at/libzip.git
- source = git+https://github.com/facebook/zstd.git
- source = git+https://github.com/RetroAchievements/rcheevos.git
- source = 0001-Fix-resources-Fix-CMake.patch
-- sha256sums = SKIP
-- sha256sums = SKIP
-- sha256sums = SKIP
-- sha256sums = SKIP
-- sha256sums = SKIP
-- sha256sums = SKIP
-- sha256sums = SKIP
-- sha256sums = SKIP
-- sha256sums = SKIP
-- sha256sums = SKIP
-- sha256sums = SKIP
-- sha256sums = SKIP
-- sha256sums = SKIP
-- sha256sums = SKIP
-- sha256sums = SKIP
-- sha256sums = SKIP
-- sha256sums = b69b3369e62bee6b6063b49621144343bb9ba81fd51f38e5e9bee4efbc731230
-+ b2sums = SKIP
-+ b2sums = SKIP
-+ b2sums = SKIP
-+ b2sums = SKIP
-+ b2sums = SKIP
-+ b2sums = SKIP
-+ b2sums = SKIP
-+ b2sums = SKIP
-+ b2sums = SKIP
-+ b2sums = SKIP
-+ b2sums = SKIP
-+ b2sums = SKIP
-+ b2sums = SKIP
-+ b2sums = SKIP
-+ b2sums = SKIP
-+ b2sums = SKIP
-+ b2sums = SKIP
-+ b2sums = db0e71c76fc59f8e07684d032a3ab145eaff8964900a1690010ac1963513a050be438f651209b0cb160559c16d50d2cf5b0b8035f40c5f82e4c199d459dcec9d
-
- pkgname = pcsx2-git
-diff --git a/PKGBUILD b/PKGBUILD
-index d57e333..dd3c9ad 100644
---- a/PKGBUILD
-+++ b/PKGBUILD
-@@ -1,9 +1,10 @@
- # Maintainer: rafaelff <rafaelff@gnome.org>, WeirdBeard <obarrtimothy@gmail.com>
-+# Contributor: éclairevoyant
- # Contributor: Maxime Gauduin <alucryd@archlinux.org>
- # Contributor: Themaister <maister@archlinux.us>
-
- pkgname=pcsx2-git
--pkgver=v1.7.4268.r0.gad12a3f73
-+pkgver=1.7.4269.r0.g72b38ce71
- pkgrel=1
- pkgdesc='A Sony PlayStation 2 emulator'
- arch=(x86_64)
-@@ -15,8 +16,6 @@ license=(
- LGPL3
- )
-
--install=post.install
--
- depends=(
- libaio
- libjpeg-turbo
-@@ -52,14 +51,14 @@ makedepends=(
- python
- vulkan-headers
- )
--
--provides=(pcsx2-qt)
--
-+install=pcsx2-git.install
-+provides=(pcsx2 pcsx2-qt)
- conflicts=(pcsx2)
-
- source=(
- git+https://github.com/PCSX2/pcsx2.git
-- git+https://github.com/google/googletest.git
-+ git+https://github.com/PCSX2/xz.git
-+ gtest::git+https://github.com/google/googletest.git
- git+https://github.com/fmtlib/fmt.git
- git+https://github.com/microsoft/wil.git
- git+https://github.com/rtissera/libchdr.git
-@@ -69,62 +68,82 @@ source=(
- git+https://github.com/biojppm/debugbreak.git
- git+https://github.com/KhronosGroup/glslang.git
- git+https://github.com/fastfloat/fast_float.git
-- git+https://github.com/KhronosGroup/Vulkan-Headers.git
-+ vulkan-headers::git+https://github.com/KhronosGroup/Vulkan-Headers.git
- git+https://github.com/libsdl-org/SDL.git
- git+https://github.com/nih-at/libzip.git
- git+https://github.com/facebook/zstd.git
- git+https://github.com/RetroAchievements/rcheevos.git
- 0001-Fix-resources-Fix-CMake.patch
- )
-+b2sums=('SKIP'
-+ 'SKIP'
-+ 'SKIP'
-+ 'SKIP'
-+ 'SKIP'
-+ 'SKIP'
-+ 'SKIP'
-+ 'SKIP'
-+ 'SKIP'
-+ 'SKIP'
-+ 'SKIP'
-+ 'SKIP'
-+ 'SKIP'
-+ 'SKIP'
-+ 'SKIP'
-+ 'SKIP'
-+ 'SKIP'
-+ 'db0e71c76fc59f8e07684d032a3ab145eaff8964900a1690010ac1963513a050be438f651209b0cb160559c16d50d2cf5b0b8035f40c5f82e4c199d459dcec9d')
-
- prepare()
- {
- cd pcsx2
-- git apply -3 "${srcdir}/0001-Fix-resources-Fix-CMake.patch"
-- git -c protocol.file.allow=always submodule update
-+ git apply -3 ../0001-Fix-resources-Fix-CMake.patch
-+
- local submodule
-- git submodule init 3rdparty/vulkan-headers
-- git submodule set-url 3rdparty/vulkan-headers "${srcdir}"/Vulkan-Headers
-- git submodule update 3rdparty/vulkan-headers
-- for submodule in 3rdparty/{glslang/glslang,libchdr/libchdr,rapidyaml/rapidyaml,rcheevos/rcheevos}; do
-+ _pcsx2_submodules=(
-+ 3rdparty/xz/xz
-+ 3rdparty/gtest
-+ 3rdparty/fmt/fmt
-+ 3rdparty/libchdr/libchdr
-+ 3rdparty/wil
-+ 3rdparty/rapidyaml/rapidyaml
-+ 3rdparty/glslang/glslang
-+ 3rdparty/vulkan-headers
-+ 3rdparty/sdl2/SDL
-+ 3rdparty/libzip/libzip
-+ 3rdparty/zstd/zstd
-+ 3rdparty/rcheevos/rcheevos
-+ )
-+ for submodule in ${_pcsx2_submodules[@]}; do
- git submodule init ${submodule}
- git submodule set-url ${submodule} "${srcdir}/${submodule##*/}"
-- git submodule update ${submodule}
-+ git -c protocol.file.allow=always submodule update ${submodule}
- done
-+
- cd 3rdparty/rapidyaml/rapidyaml
- for submodule in ext/c4core; do
- git submodule init ${submodule}
- git submodule set-url ${submodule} "${srcdir}/${submodule##*/}"
-- git submodule update ${submodule}
-+ git -c protocol.file.allow=always submodule update ${submodule}
- done
-+
- cd ext/c4core
-- git submodule init cmake
-- git submodule set-url cmake "${srcdir}"/cmake
-- git submodule update cmake
-- for submodule in src/c4/ext/debugbreak; do
-+ for submodule in cmake src/c4/ext/{debugbreak,fast_float}; do
- git submodule init ${submodule}
- git submodule set-url ${submodule} "${srcdir}/${submodule##*/}"
-- git submodule update ${submodule}
-- done
-- for submodule in src/c4/ext/fast_float; do
-- git submodule init ${submodule}
-- git submodule set-url ${submodule} "${srcdir}/${submodule##*/}"
-- git submodule update ${submodule}
-+ git -c protocol.file.allow=always submodule update ${submodule}
- done
- }
-
- pkgver()
- {
- cd pcsx2
-- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
-+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'
- }
-
- build()
- {
-- mkdir -p build
-- cd build
--
-- cmake ../pcsx2 \
-+ cmake -B build -S pcsx2 \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INTERPROCEDURAL_OPTIMIZATION=ON \
-@@ -138,9 +157,10 @@ build()
- -DDISABLE_ADVANCE_SIMD=ON \
- -GNinja \
- -DPACKAGE_MODE=ON
-- ninja -j$(nproc)
-- cd ..
-- cp -r pcsx2/.github/workflows/scripts/linux/pcsx2-qt.desktop build/bin/PCSX2.desktop
-+
-+ ninja -C build
-+
-+ cp pcsx2/.github/workflows/scripts/linux/pcsx2-qt.desktop build/bin/PCSX2.desktop
- }
-
- package()
-@@ -150,23 +170,3 @@ package()
- }
-
- # vim: ts=2 sw=2 et:
--
--sha256sums=(
-- 'SKIP'
-- 'SKIP'
-- 'SKIP'
-- 'SKIP'
-- 'SKIP'
-- 'SKIP'
-- 'SKIP'
-- 'SKIP'
-- 'SKIP'
-- 'SKIP'
-- 'SKIP'
-- 'SKIP'
-- 'SKIP'
-- 'SKIP'
-- 'SKIP'
-- 'SKIP'
-- 'b69b3369e62bee6b6063b49621144343bb9ba81fd51f38e5e9bee4efbc731230'
--)
-diff --git a/pcsx2-git.install b/pcsx2-git.install
-new file mode 100644
-index 0000000..83bfd01
---- /dev/null
-+++ b/pcsx2-git.install
-@@ -0,0 +1,10 @@
-+# For DEV9 netplay support
-+post_install()
-+{
-+ setcap 'CAP_NET_RAW+eip CAP_NET_ADMIN+eip' usr/bin/pcsx2-qt
-+}
-+
-+post_upgrade()
-+{
-+ setcap 'CAP_NET_RAW+eip CAP_NET_ADMIN+eip' usr/bin/pcsx2-qt
-+}
-diff --git a/post.install b/post.install
-deleted file mode 100644
-index 0890f65..0000000
---- a/post.install
-+++ /dev/null
-@@ -1,19 +0,0 @@
--# For DEV9 netplay support
--post_install()
--{
-- setcap 'CAP_NET_RAW+eip CAP_NET_ADMIN+eip' /usr/bin/pcsx2-qt
--
-- cd /usr/share/PCSX2/resources
-- sudo curl -O -L https://github.com/PCSX2/pcsx2_patches/releases/download/latest/cheats_ni.zip
-- sudo curl -O -L https://github.com/PCSX2/pcsx2_patches/releases/download/latest/cheats_ws.zip
--}
--
--post_upgrade()
--{
-- setcap 'CAP_NET_RAW+eip CAP_NET_ADMIN+eip' /usr/bin/pcsx2-qt
-- cd /usr/share/PCSX2/resources
-- sudo rm cheats_ws.zip
-- sudo rm cheats_ni.zip
-- sudo curl -O -L https://github.com/PCSX2/pcsx2_patches/releases/download/latest/cheats_ni.zip
-- sudo curl -O -L https://github.com/PCSX2/pcsx2_patches/releases/download/latest/cheats_ws.zip
--}
---
-2.39.2
-