summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzoe2018-06-19 11:32:45 +0200
committerzoe2018-06-19 11:32:45 +0200
commit7eadcb4deefbe13563ea0fff61d617de605d0a43 (patch)
treea3384d7431bb68a62da6d129656a816c29c96f34
parent51aeeb6a4da7b07e8d8210a3991b518de27efa4d (diff)
downloadaur-pdf-remove-blank-pages.tar.gz
Improved bash script
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD4
-rwxr-xr-xpdf-remove-blank-pages.sh2
3 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6ca4aeec73c1..e8a33da25b15 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Tue Jun 19 09:19:59 UTC 2018
+# Tue Jun 19 09:32:20 UTC 2018
pkgbase = pdf-remove-blank-pages
pkgdesc = Automatically remove blank pages from pdf. For text-pdf only, not for images-pdf (removes pages with no text in it)
pkgver = 0.2
- pkgrel = 2
+ pkgrel = 3
url = https://repolinux.wordpress.com/2012/04/05/automatically-remove-blank-pages-from-pdf/
arch = any
license = GPLv3+
@@ -15,7 +15,7 @@ pkgbase = pdf-remove-blank-pages
source = non-blank-page-ranges.py
source = pdf-remove-blank-pages.sh
md5sums = 1a9c76689a828c18b1263ef11c3ee990
- md5sums = 0e4c76df31ae13d6b3f3b2aca3556ed8
+ md5sums = 24814509b89239a4c270d57a1ff35304
pkgname = pdf-remove-blank-pages
diff --git a/PKGBUILD b/PKGBUILD
index e60a07218cab..4f9be5d3ab8c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
pkgname=pdf-remove-blank-pages
pkgver=0.2
-pkgrel=2
+pkgrel=3
pkgdesc="Automatically remove blank pages from pdf. For text-pdf only, not for images-pdf (removes pages with no text in it)"
arch=(any)
url="https://repolinux.wordpress.com/2012/04/05/automatically-remove-blank-pages-from-pdf/"
license=("GPLv3+")
depends=('python' 'bash' 'pdftk' 'poppler' 'gawk')
source=("non-blank-page-ranges.py" "pdf-remove-blank-pages.sh")
-md5sums=('1a9c76689a828c18b1263ef11c3ee990' '0e4c76df31ae13d6b3f3b2aca3556ed8')
+md5sums=('1a9c76689a828c18b1263ef11c3ee990' '24814509b89239a4c270d57a1ff35304')
package() {
diff --git a/pdf-remove-blank-pages.sh b/pdf-remove-blank-pages.sh
index 964a7d0dd8f7..2e917bf98d9d 100755
--- a/pdf-remove-blank-pages.sh
+++ b/pdf-remove-blank-pages.sh
@@ -23,7 +23,7 @@ do
esac
done
-if [ $filename == "" ]; then
+if [ -z "$filename" ]; then
echo "-f <PDF-file> is missing ; aborted"
exit 99
fi