summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Hu2023-11-21 16:55:22 +0100
committerTom Hu2023-11-21 16:55:22 +0100
commite65fe179513222f82d074d07f75356dddcdd5e47 (patch)
tree7f516780950d802853bcf71458c707b5d77447ac
parent6167e9eb65726322494aba3d275037572d240a9d (diff)
downloadaur-pdfmted-git.tar.gz
updated dependencies
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD31
2 files changed, 23 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 36347e6b19cd..769ce8fb139d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,20 @@
pkgbase = pdfmted-git
pkgdesc = View and modify PDF metadata on Linux graphically
- pkgver = r6.a5d363d
+ pkgver = r21.7d7af77
pkgrel = 1
url = https://github.com/glutanimate/PDFMtEd
arch = any
license = GPL3
makedepends = git
depends = perl-image-exiftool
- depends = python2
+ depends = python3
depends = qpdf
depends = yad
depends = xdg-utils
- optdepends = java-sejda
- source = pdfmted-git::git+https://github.com/glutanimate/pdfmted
+ optdepends = sejda-console
+ provides = pdfmted
+ conflicts = pdfmted
+ source = git+https://github.com/glutanimate/pdfmted#branch=master
sha256sums = SKIP
pkgname = pdfmted-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 3b265648a209..1c76f766c22a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,31 @@
-# Maintainer: Daniel Gray <dng@disroot.org>
+# Contributor: Daniel Gray <dng@disroot.org>
+# Maintainer: Tom Hu <tom@bluespice.org>
pkgname=pdfmted-git
-pkgver=r6.a5d363d
+pkgver=r21.7d7af77
pkgrel=1
pkgdesc="View and modify PDF metadata on Linux graphically"
-arch=("any")
+arch=('any')
url="https://github.com/glutanimate/PDFMtEd"
license=('GPL3')
-depends=('perl-image-exiftool' 'python2' 'qpdf' 'yad' 'xdg-utils')
-optdepends=('java-sejda')
+depends=('perl-image-exiftool' 'python3' 'qpdf' 'yad' 'xdg-utils')
+optdepends=('sejda-console')
makedepends=('git')
-source=("${pkgname}::git+https://github.com/glutanimate/pdfmted")
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=('git+https://github.com/glutanimate/pdfmted#branch=master')
sha256sums=('SKIP')
pkgver() {
- cd "${srcdir}/${pkgname}"
+ cd "${srcdir}/${pkgname%-git}"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
package() {
- install -Dm755 "${pkgname}"/pdfmted-editor -t "${pkgdir}"/usr/bin
- install -Dm755 "${pkgname}"/pdfmted-inspector -t "${pkgdir}"/usr/bin
- install -Dm755 "${pkgname}"/pdfmted-thumbnailer -t "${pkgdir}"/usr/bin
- install -Dm644 "${pkgname}"/desktop/pdfmted-editor.desktop -t "${pkgdir}"/usr/share/applications
- install -Dm644 "${pkgname}"/desktop/pdfmted-inspector.desktop -t "${pkgdir}"/usr/share/applications
- install -Dm644 "${pkgname}"/desktop/pdfmted.png -t "${pkgdir}"/usr/share/icons/hicolor/scalable/apps/
- install -Dm644 "${pkgname}"/desktop/pdfmted.svg -t "${pkgdir}"/usr/share/icons/hicolor/scalable/apps/
+ install -Dm755 "${pkgname%-git}"/pdfmted-editor -t "${pkgdir}"/usr/bin
+ install -Dm755 "${pkgname%-git}"/pdfmted-inspector -t "${pkgdir}"/usr/bin
+ install -Dm755 "${pkgname%-git}"/pdfmted-thumbnailer -t "${pkgdir}"/usr/bin
+ install -Dm644 "${pkgname%-git}"/desktop/pdfmted-editor.desktop -t "${pkgdir}"/usr/share/applications
+ install -Dm644 "${pkgname%-git}"/desktop/pdfmted-inspector.desktop -t "${pkgdir}"/usr/share/applications
+ install -Dm644 "${pkgname%-git}"/desktop/pdfmted.png -t "${pkgdir}"/usr/share/icons/hicolor/scalable/apps/
+ install -Dm644 "${pkgname%-git}"/desktop/pdfmted.svg -t "${pkgdir}"/usr/share/icons/hicolor/scalable/apps/
}