summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2021-12-01 15:59:18 -0500
committerCarlos Aznarán Laos2021-12-01 15:59:18 -0500
commit9050a59e245f668c20222a3ea34984db0d73ad42 (patch)
tree1a176211480bdf18d16e404700deb84d9eab0c55
parentb732589f698511db13e370cbd67f0e11eafb9594 (diff)
downloadaur-pdfquirk-git.tar.gz
Add clang as makedependency
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index edf200523785..d047b3f2cb04 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
pkgbase = pdfquirk-git
pkgdesc = Creating PDFs from images or scanner made easy
- pkgver = continuous.r13.g157f773
+ pkgver = continuous.r18.g3f45dc9
pkgrel = 1
url = https://dragotin.github.io/quirksite
arch = x86_64
license = GPL3
+ makedepends = clang
makedepends = extra-cmake-modules
makedepends = glu
makedepends = git
diff --git a/PKGBUILD b/PKGBUILD
index f2e829e95194..ac9ce4b1b518 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
# Contributor: Caltlgin Stsodaat <contact@fossdaily.xyz>
pkgname=pdfquirk-git
-pkgver=continuous.r13.g157f773
+pkgver=continuous.r18.g3f45dc9
pkgrel=1
pkgdesc="Creating PDFs from images or scanner made easy"
arch=('x86_64')
url="https://dragotin.github.io/quirksite"
license=(GPL3)
depends=(hicolor-icon-theme imagemagick qt6-tools)
-makedepends=(extra-cmake-modules glu git)
+makedepends=(clang extra-cmake-modules glu git)
optdepends=('sane: scanning support')
provides=("${pkgname/-git/}")
source=("git+https://github.com/dragotin/${pkgname/-git/}.git")
@@ -33,4 +33,4 @@ build() {
package() {
DESTDIR="${pkgdir}" cmake --build build --target install
install -Dm644 "${pkgname/-git/}/README.md" "${pkgdir}/usr/share/doc/${_pkgname}/README.md"
-}
+} \ No newline at end of file