summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoey Dumont2017-06-26 07:02:46 -0400
committerJoey Dumont2017-06-26 07:02:46 -0400
commit52ac76d8670aaf8710afa439377dffb72bb9e01c (patch)
tree13f12e235268e62f6cc44f6d8df2eb75c28707d4
parentc1dd9637c51eb8836739a001a5c581c9441759c2 (diff)
downloadaur-52ac76d8670aaf8710afa439377dffb72bb9e01c.tar.gz
Updated to depend on gcc63.
-rw-r--r--.SRCINFO8
-rw-r--r--Makefile.Arch11
-rw-r--r--PKGBUILD6
3 files changed, 13 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d261bd7c25d3..ca31b76bd1d8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,20 @@
# Generated by mksrcinfo v8
-# Wed Aug 31 15:19:54 UTC 2016
+# Mon Jun 26 11:02:01 UTC 2017
pkgbase = pdftk
pkgdesc = Pdftk is a simple tool for doing everyday things with PDF documents
pkgver = 2.02
- pkgrel = 11
+ pkgrel = 12
url = http://www.pdfhacks.com/pdftk
arch = i686
arch = x86_64
license = GPL
- depends = gcc-gcj
+ depends = gcc63-gcj
depends = gcc-gcj-ecj
options = !makeflags
source = http://www.pdflabs.com/tools/pdftk-the-pdf-toolkit/pdftk-2.02-src.zip
source = Makefile.Arch
sha1sums = a4a27e984c5e1401cfa44b8e92a64113d7396a06
- sha1sums = 4e73f36f161a5920a20f7811bf2c74825675233b
+ sha1sums = 7052d81754b99a4ef3a8c8dbe749886f2fb2159e
pkgname = pdftk
diff --git a/Makefile.Arch b/Makefile.Arch
index 9acafa41793d..d0247daf0d33 100644
--- a/Makefile.Arch
+++ b/Makefile.Arch
@@ -1,17 +1,18 @@
# Based on 'Makefile.Debian', part of pdftk
# Copyright (c) 2004-2012 Sid Steward
-export CXX= g++
-export GCJ= gcj
-export GCJH= gcjh
-export GJAR= gjar
+export CXX= g++-6.3
+export GCJ= gcj-6.3
+export GCJH= gcjh-6.3
+export GJAR= gjar-6.3
+export CC1PLUS= cc1plus-6.3
export LIBGCJ= /usr/share/java/libgcj.jar
export AR= ar
export RM= rm
export ARFLAGS= rs
export RMFLAGS= -vf
export CPPFLAGS= -DPATH_DELIM=0x2f -DASK_ABOUT_WARNINGS=false -DUNBLOCK_SIGNALS -fdollars-in-identifiers -fPIC
-export CXXFLAGS= -O2 -fPIC
+export CXXFLAGS= -O2 -fPIC -I/usr/lib/gcc/x86_64-pc-linux-gnu/6.3.1/include/c++/ -I/usr/lib/gcc/x86_64-pc-linux-gnu/6.3.1/include/c++/x86_64-pc-linux-gnu
export GCJFLAGS= -Wno-all -fsource=1.3 -O2 -fPIC
export GCJHFLAGS= -force
export LDLIBS= -lgcj
diff --git a/PKGBUILD b/PKGBUILD
index 3c91eff0cef6..f5a7a38116ec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,18 +5,18 @@
pkgname=pdftk
pkgver=2.02
-pkgrel=11
+pkgrel=12
pkgdesc="Pdftk is a simple tool for doing everyday things with PDF documents"
arch=('i686' 'x86_64')
url="http://www.pdfhacks.com/pdftk"
license=("GPL")
-depends=('gcc-gcj' 'gcc-gcj-ecj')
+depends=('gcc63-gcj' 'gcc-gcj-ecj')
options=('!makeflags')
source=("http://www.pdflabs.com/tools/pdftk-the-pdf-toolkit/${pkgname}-${pkgver}-src.zip"
"Makefile.Arch"
)
sha1sums=('a4a27e984c5e1401cfa44b8e92a64113d7396a06'
- '4e73f36f161a5920a20f7811bf2c74825675233b')
+ '7052d81754b99a4ef3a8c8dbe749886f2fb2159e')
prepare() {
cd "$srcdir/$pkgname-$pkgver-dist/$pkgname"