summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYaohan Chen2015-06-20 23:01:04 -0400
committerYaohan Chen2015-06-20 23:01:04 -0400
commita5140e1b3504f6f3703958bbb565911a7a57da65 (patch)
treeb17c4abfb08ab6e98c2f87b97a062cf813e0a4b8
downloadaur-a5140e1b3504f6f3703958bbb565911a7a57da65.tar.gz
Initial import
-rw-r--r--.AURINFO19
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD57
-rw-r--r--altconf.txt2
-rw-r--r--peazip.desktop10
5 files changed, 110 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..fb03b6cc24b9
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,19 @@
+pkgbase = peazip-qt-build
+ pkgdesc = Free cross-platform file archiver (compiles from source)
+ pkgver = 5.5.3
+ pkgrel = 2
+ url = http://peazip.org
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = lazarus-qt
+ makedepends = icoutils
+ depends = qt4pas
+ provides = peazip-qt
+ conflicts = peazip-qt
+ source = http://sourceforge.net/projects/peazip/files/5.5.3/peazip-5.5.3.src.zip
+ source = peazip.desktop
+ source = altconf.txt
+
+pkgname = peazip-qt-build
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dd7881012d38
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = peazip-qt-build
+ pkgdesc = Free cross-platform file archiver (compiles from source)
+ pkgver = 5.5.3
+ pkgrel = 2
+ url = http://peazip.org
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = lazarus-qt
+ makedepends = icoutils
+ depends = qt4pas
+ provides = peazip-qt
+ conflicts = peazip-qt
+ source = http://sourceforge.net/projects/peazip/files/5.5.3/peazip-5.5.3.src.zip
+ source = peazip.desktop
+ source = altconf.txt
+ md5sums = 58c518ebc8c4020d0e3ec1778faa6fd7
+ md5sums = 6fef20588a593e13c218cc9863a4fd5c
+ md5sums = d9ba7d703137b28770d1aa64d8ea6a28
+
+pkgname = peazip-qt-build
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3cf812237c08
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,57 @@
+pkgname='peazip-qt-build'
+pkgver='5.5.3'
+pkgrel=2
+pkgdesc='Free cross-platform file archiver (compiles from source)'
+license='GPL3'
+url='http://peazip.org'
+
+arch=('i686' 'x86_64')
+depends=('qt4pas')
+makedepends=('lazarus-qt' 'icoutils')
+provides=('peazip-qt')
+conflicts=('peazip-qt')
+
+source=("http://sourceforge.net/projects/peazip/files/${pkgver}/peazip-${pkgver}.src.zip"
+ 'peazip.desktop'
+ 'altconf.txt')
+md5sums=('58c518ebc8c4020d0e3ec1778faa6fd7'
+ '6fef20588a593e13c218cc9863a4fd5c'
+ 'd9ba7d703137b28770d1aa64d8ea6a28')
+_extractdir="peazip-${pkgver}.src"
+
+build() {
+ cd "$srcdir/$_extractdir"
+ lazbuild --widgetset=qt project_pea.lpi && [ -f pea ]
+ lazbuild --widgetset=qt project_gwrap.lpi && [ -f pealauncher ]
+ lazbuild --widgetset=qt project_peach.lpi && [ -f peazip ]
+
+ mkdir -p icons
+ icotool --extract --output='icons' 'res/icons/PeaZip.ico'
+ for icon in icons/*.png; do
+ _size="$(basename "$icon" | grep -o '[0-9]\+x[0-9]\+')"
+ mv "$icon" "$(_dir icons/$_size/apps)/peazip.png"
+ done
+}
+
+# Create directory if non-existent, and print the directory name
+_dir() {
+ mkdir -p "$1"
+ echo "$1"
+}
+
+package() {
+ _installdir="opt/peazip"
+
+ cd "$srcdir/$_extractdir"
+ install -Dm755 peazip "$pkgdir/$_installdir/peazip"
+
+ mv res "$pkgdir/$_installdir"
+ install -Dm755 pea "$pkgdir/$_installdir/res/pea"
+ install -Dm755 pealauncher "$pkgdir/$_installdir/res/pealauncher"
+ install -Dm644 "$srcdir/altconf.txt" "$pkgdir/$_installdir/res/altconf.txt"
+
+ ln -s "/$_installdir/peazip" "$(_dir "$pkgdir/usr/bin")/peazip"
+ mv icons/* "$(_dir "$pkgdir/usr/share/icons/hicolor/")"
+ install -Dm644 "$srcdir/peazip.desktop" "$pkgdir/usr/share/applications/peazip.desktop"
+}
+
diff --git a/altconf.txt b/altconf.txt
new file mode 100644
index 000000000000..dec562eac4c0
--- /dev/null
+++ b/altconf.txt
@@ -0,0 +1,2 @@
+[alternative configuration's path: specify a location for bookmarks.txt, conf.txt and rnd (either absolute or relative path, use " and ' if needed); write "same" to use this path, "appdata" to use user's application data or home path]
+appdata
diff --git a/peazip.desktop b/peazip.desktop
new file mode 100644
index 000000000000..80ad9cfacc3b
--- /dev/null
+++ b/peazip.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Encoding=UTF-8
+Type=Application
+Name=Peazip
+Comment=Archiver utility
+Exec=peazip
+Icon=peazip
+Terminal=false
+StartupNotify=false
+Categories=Application;Utility;